Veeam MP for VMware Reference

 Top Next

Online reference provides basic assistance information for Veeam MP for VMware objects and properties, discoveries, rules and monitors, overrides and metric definitions.

Objects and Properties

Discoveries

Rules and Monitors

Overrides

Veeam MP for VMware Metric Definitions

Topology Agenda


Objects and Properties

 Top Previous Next

This section describes Veeam MP for VMware objects and properties.

Veeam VMware vCenter Monitoring

Veeam VMware Library

Veeam Base Discovery

Veeam VMware High-Granularity

Veeam VMware Required Overrides


Veeam VMware vCenter Monitoring

Display Name | Object ID | Properties | Key
VMware vCenter Server | Veeam.Virt.Extensions.VMware.vCenter | version |
 |  | Display Name |
VMware vCenter Servers | Veeam.Virt.Extensions.VMware.vCenter.Group | Display Name |
VMware vCenter Servers version 2.5 | Veeam.Virt.Extensions.VMware.vCenter.VC2.Group | Display Name |
VMware vCenter Servers version 4.0 and 4.1 | Veeam.Virt.Extensions.VMware.vCenter.VC4.Group | Display Name |
VMware vCenter Servers version 5.x | Veeam.Virt.Extensions.VMware.vCenter.VC5.Group | Display Name |


Veeam VMware Library

Display Name | Object ID | Properties
 |  | Display Name | Key
Veeam VMware | Veeam.Virt.Extensions.VMware.nworksVMware | Display Name |
Veeam VMware Topo - Deprecated | Veeam.Virt.Extensions.VMware.Topology.Group | Display Name |
VM Container | Veeam.Virt.Extensions.VMware.VMGuestContainer | hostName |
 |  | id | ✓
 |  | Display Name |
VM Discovery Container | Veeam.Virt.Extensions.VMware.VMGuestContainerLSChild | hostName |
 |  | id | ✓
 |  | TaskPath |
 |  | Veeam Collector |
 |  | Display Name |
VMware Cluster | Veeam.Virt.Extensions.VMware.VMCCR | Custom Tag 3 |
 |  | Datacenter Name |
 |  | DRS Status |
 |  | Folder Name |
 |  | HA Status |
 |  | id | ✓
 |  | Num Hosts |
 |  | Total CPU GHz |
 |  | Total Memory GB |
 |  | Total Storage TB |
 |  | vCenter Name |
 |  | Veeam Monitoring Group |
 |  | Display Name |
VMware Clusters | Veeam.Virt.Extensions.VMware.VMCCR.Group | Display Name |
VMware Connections | Veeam.Virt.Extensions.VMware.VIAPILink | id | ✓
 |  | Target URL |
 |  | targetPort |
 |  | targetServer |
 |  | targetType |
 |  | Display Name |
VMware Datacenter | Veeam.Virt.Extensions.VMware.VMDATA_CENTER | Datacenter Name |
 |  | Folder Name |
 |  | id | ✓
 |  | vCenter Name |
 |  | Display Name |
VMware Datacenter - Network | Veeam.Virt.Extensions.VMware.VMNETDATA_CENTER | Datacenter Name |
 |  | Folder Name |
 |  | id | ✓
 |  | vCenter Name |
 |  | Display Name |
VMware Datacenter - Network Group | Veeam.Virt.Extensions.VMware.VMNETDATA_CENTER.Group | Display Name |
VMware Datacenter - Storage | Veeam.Virt.Extensions.VMware.VMDSDATA_CENTER | Datacenter Name |
 |  | Folder Name |
 |  | id | ✓
 |  | vCenter Name |
 |  | Display Name |
VMware Datacenter - Storage Group | Veeam.Virt.Extensions.VMware.VMDSDATA_CENTER.Group | Display Name |
VMware Datacenters | Veeam.Virt.Extensions.VMware.VMDATA_CENTER.Group | Display Name |
VMware Datastore | Veeam.Virt.Extensions.VMware.VMDATASTORE | Custom Tag 1 |
 |  | Custom Tag 2 |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | Datastore Cluster Name |
 |  | Disk Size GB |
 |  | Filesystem |
 |  | Folder Name |
 |  | SDRS |
 |  | SIOC |
 |  | Task Path |
 |  | vCenter Name |
 |  | Display Name |
VMware Datastore Base Class | Veeam.Virt.Extensions.VMware.VMDATASTORE.Base | id | ✓
 |  | Display Name |
VMware Datastore Cluster | Veeam.Virt.Extensions.VMware.VMDSCLUSTER | Automation Level |
 |  | Capacity GB |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | Folder Name |
 |  | id | ✓
 |  | SDRS I/O Metrics |
 |  | Storage DRS |
 |  | Type |
 |  | vCenter Name |
 |  | Display Name |
VMware Datastore Cluster Group | Veeam.Virt.Extensions.VMware.VMDSCLUSTER.Group | Display Name |
VMware Datastore Container | Veeam.Virt.Extensions.VMware.VMHOSTDATASTORE.Container | id | ✓
 |  | Veeam Collector | ✓
 |  | Display Name |
VMware Datastores | Veeam.Virt.Extensions.VMware.VMDATASTORE.Group | Display Name |
VMware Distributed Virtual Switch | Veeam.Virt.Extensions.VMware.VMDVSWITCH | Custom Tag 3 |
 |  | Datacenter Name |
 |  | Direct Path I/O |
 |  | Folder Name |
 |  | FT Logging |
 |  | id | ✓
 |  | Management Traffic |
 |  | Manufacturer |
 |  | Network I/O Control |
 |  | Number of ports |
 |  | Number of Uplink ports |
 |  | vCenter Name |
 |  | Version |
 |  | vMotion |
 |  | Display Name |
VMware Distributed Virtual Switch Group | Veeam.Virt.Extensions.VMware.VMDVSWITCH.Group | Display Name |
VMware Logical Hardware | Veeam.Virt.Extensions.VMware.VMHARDWARE | Display Name |
VMware Resource Pool | Veeam.Virt.Extensions.VMware.VMPOOL | Cluster Name |
 |  | CPU Allocation |
 |  | CPU Limit |
 |  | CPU Reservation |
 |  | CPU Shares |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | id | ✓
 |  | Memory Allocation |
 |  | Memory Limit |
 |  | Memory Reservation |
 |  | Memory Shares |
 |  | Parent Container |
 |  | vCenter Name |
 |  | Display Name |
VMware Resource Pools | Veeam.Virt.Extensions.VMware.VMPOOL.Group | Display Name |
VMware SIOC/SDRS Datastore | Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS | Display Name |
VMware vCenter | Veeam.Virt.Extensions.VMware.vCenterEvents | id | ✓
 |  | Version |
 |  | Display Name |
VMware vCenter - Network | Veeam.Virt.Extensions.VMware.vCenterNetwork | id | ✓
 |  | vCenter Name |
 |  | Version |
 |  | Display Name |
VMware vCenter - Network Group | Veeam.Virt.Extensions.VMware.vCenterNetwork.Group | Display Name |
VMware vCenter - Storage | Veeam.Virt.Extensions.VMware.vCenterStorage | id | ✓
 |  | vCenter Name |
 |  | Version |
 |  | Display Name |
VMware vCenter - Storage Group | Veeam.Virt.Extensions.VMware.vCenterStorage.Group | Display Name |
VMware vCenter Group | Veeam.Virt.Extensions.VMware.vCenterEvents.Group | Display Name |
VMware Virtual Application | Veeam.Virt.Extensions.VMware.VMVAPP | Cluster Name |
 |  | CPU Allocation |
 |  | CPU Limit |
 |  | CPU Reservation |
 |  | CPU Shares |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | id | ✓
 |  | Memory Allocation |
 |  | Memory Limit |
 |  | Memory Reservation |
 |  | Memory Shares |
 |  | Parent Container |
 |  | TaskPath |
 |  | vCenter Name |
 |  | Display Name |
VMware Virtual Applications | Veeam.Virt.Extensions.VMware.VMVAPP.Group | Display Name |
VMware Virtual Machine | Veeam.Virt.Extensions.VMware.VMGUEST | Cluster Name |
 |  | CPU Allocation MHz |
 |  | CPU Count |
 |  | CPU Limit MHz |
 |  | CPU Reservation MHz |
 |  | CPU Shares |
 |  | Custom Tag 1 |
 |  | Custom Tag 2 |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | Disk Allocation GB |
 |  | Disk IOPS Limit |
 |  | Disk Shares |
 |  | Folder Name |
 |  | Guest DNS Name |
 |  | Guest OS |
 |  | Host Name |
 |  | id | ✓
 |  | IP Address(es) |
 |  | Memory Allocation MB |
 |  | Memory Limit MB |
 |  | Memory Reservation MB |
 |  | Memory Shares |
 |  | Resource Pool Name |
 |  | Task Path |
 |  | Uses Datastores |
 |  | Uses Networks |
 |  | vAPP Name |
 |  | vCenter Name |
 |  | Veeam Backup Replica Source |
 |  | Veeam Collector |
 |  | Veeam Monitoring Group |
 |  | VM Version |
 |  | VMware Tools Version |
 |  | vSphere HA Protection |
 |  | Display Name |
VMware Virtual Machine (Fault Tolerant) | Veeam.Virt.Extensions.VMware.VMGUEST.FT | Host (Secondary) |
 |  | Display Name |
VMware Virtual Machine (Template) | Veeam.Virt.Extensions.VMware.VMGUEST.Template | Cluster Name |
 |  | CPU Count |
 |  | CPU Limit MHz |
 |  | CPU Reservation MHz |
 |  | CPU Shares |
 |  | Custom Tag 1 |
 |  | Custom Tag 2 |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | Disk Allocation GB |
 |  | Disk IOPS Limit |
 |  | Disk Shares |
 |  | Folder Name |
 |  | Guest OS |
 |  | Host Name |
 |  | id | ✓
 |  | IsTemplate |
 |  | Memory Allocation MB |
 |  | Memory Limit MB |
 |  | Memory Reservation MB |
 |  | Memory Shares |
 |  | Uses Datastores |
 |  | Uses Networks |
 |  | vCenter Name |
 |  | Veeam Backup Replica Source |
 |  | Veeam Collector |
 |  | VM Version |
 |  | VMware Tools Version |
 |  | vSphere HA Protection |
 |  | Display Name |
VMware Virtual Machine Group | Veeam.Virt.Extensions.VMware.VMGUEST.Group | Display Name |
VMware Virtual Switch | Veeam.Virt.Extensions.VMware.VMHOSTSWITCH | Datacenter Name |
 |  | Folder Name |
 |  | FT Logging |
 |  | Host Name |
 |  | id | ✓
 |  | Management Traffic |
 |  | Number of ports |
 |  | vCenter Name |
 |  | vMotion |
 |  | vSwitch Name |
 |  | Display Name |
VMware Virtual Switch Group | Veeam.Virt.Extensions.VMware.VMHOSTSWITCH.Group | Display Name |
VMware VMs that run Ops Mgr agents | Veeam.Virt.Extensions.VMware.VMGuestRunsAgent.Group | Display Name |
VMware vSphere Host | Veeam.Virt.Extensions.VMware.VMHOST | Build Version |
 |  | Cluster Name |
 |  | CPU Cores |
 |  | CPU Model |
 |  | CPU Sockets |
 |  | Custom Tag 1 |
 |  | Custom Tag 2 |
 |  | Custom Tag 3 |
 |  | Datacenter Name |
 |  | id | ✓
 |  | Memory GB |
 |  | Mgmt Controller |
 |  | System BIOS |
 |  | System Manufacturer |
 |  | System Model |
 |  | System Serial Number |
 |  | TaskPath |
 |  | Total CPU GHz |
 |  | vCenter Name |
 |  | Veeam Collector |
 |  | Veeam Monitoring Group |
 |  | vSphere HA State |
 |  | Display Name |
VMware vSphere Host COS Partition | Veeam.Virt.Extensions.VMware.VMHOSTCOSPARTITION | Disk Size GB |
 |  | url |
 |  | Display Name |
VMware vSphere Host COS Partitions | Veeam.Virt.Extensions.VMware.VMHOST.DATASTORECONTAINER | id | ✓
 |  | Display Name |
VMware vSphere Host Fan Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.FAN | id | ✓
 |  | Display Name |
VMware vSphere Host Hardware Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.SENSOR | id | ✓
 |  | Display Name |
VMware vSphere Host Hardware Sensors Container | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER | Host Name |
 |  | id | ✓
 |  | Display Name |
VMware vSphere Host HBA Container | Veeam.Virt.Extensions.VMware.VMHOST.DISKCONTAINER | id | ✓
 |  | Display Name |
VMware vSphere Host Local Disk Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.STORAGE | id | ✓
 |  | Display Name |
Vmware vSphere Host Maintenance Mode Sync | Veeam.Virt.Extensions.VMware.VMHOST.MaintenanceModeTarget | id | ✓
 |  | Display Name |
VMware vSphere Host Network Card | Veeam.Virt.Extensions.VMware.VMHOSTNET | (d)vSwitch Name |
 |  | Adapter |
 |  | Duplex |
 |  | Host name |
 |  | id | ✓
 |  | IP Address |
 |  | MAC Address |
 |  | Speed Mb |
 |  | Display Name |
VMware vSphere Host NIC Container | Veeam.Virt.Extensions.VMware.VMHOST.NETCONTAINER | id | ✓
 |  | Display Name |
VMware vSphere Host Power Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.POWER | id | ✓
 |  | Display Name |
VMware vSphere Host Processor Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.PROCESSORS | id | ✓
 |  | Display Name |
VMware vSphere Host RAM DIMM Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.MEMORY | id | ✓
 |  | Display Name |
VMware vSphere Host Security Profile | Veeam.Virt.Extensions.VMware.HostSecurityProfile | FirewallRule 1 |
 |  | FirewallRule 2 |
 |  | FirewallRule 3 |
 |  | FirewallRule 4 |
 |  | FirewallRule 5 |
 |  | FirewallRule Active Directory All |
 |  | FirewallRule CIM Secure Server |
 |  | FirewallRule CIM Server |
 |  | FirewallRule CIM SLP |
 |  | FirewallRule cmmds |
 |  | FirewallRule DHCP Client |
 |  | FirewallRule DHCPv6 |
 |  | FirewallRule DNS Client |
 |  | FirewallRule DVFilter |
 |  | FirewallRule DVSSync |
 |  | FirewallRule Fault Tolerance |
 |  | FirewallRule FTP Client |
 |  | FirewallRule gdbserver |
 |  | FirewallRule HBR |
 |  | FirewallRule httpClient |
 |  | FirewallRule IKED |
 |  | FirewallRule ipfam |
 |  | FirewallRule NFC |
 |  | FirewallRule NFS Client |
 |  | FirewallRule NTP Client |
 |  | FirewallRule rabbitmqproxy |
 |  | FirewallRule rdt |
 |  | FirewallRule SNMP Server |
 |  | FirewallRule Sofware iSCSI Client |
 |  | FirewallRule SSH Client |
 |  | FirewallRule SSH Server |
 |  | FirewallRule syslog |
 |  | FirewallRule vCenter Agent |
 |  | FirewallRule vCenter Update Manager |
 |  | FirewallRule VM serial port connected over network |
 |  | FirewallRule VM serial port connected to vSPC |
 |  | FirewallRule vMotion |
 |  | FirewallRule vprobeServer |
 |  | FirewallRule vsanvp |
 |  | FirewallRule vSphere Client |
 |  | FirewallRule vSphere HA Agent |
 |  | FirewallRule vSphere Web Access |
 |  | FirewallRule WOL |
 |  | id | ✓
 |  | Lockdown Mode |
 |  | ServiceRule 1 |
 |  | ServiceRule 2 |
 |  | ServiceRule 3 |
 |  | ServiceRule 4 |
 |  | ServiceRule 5 |
 |  | ServiceRule CIM Server |
 |  | ServiceRule Direct Console UI |
 |  | ServiceRule ESXi Shell |
 |  | ServiceRule IO Redirector |
 |  | ServiceRule lbtd |
 |  | ServiceRule Local Security Authentication Server |
 |  | ServiceRule Network Login Server |
 |  | ServiceRule NTP Daemon |
 |  | ServiceRule snmpd |
 |  | ServiceRule SSH |
 |  | ServiceRule VMware vCenter Agent |
 |  | ServiceRule vprobed |
 |  | ServiceRule vpxa |
 |  | ServiceRule vSphere HA Agent |
 |  | ServiceRule xorg |
 |  | Display Name |
VMware vSphere Host Security Profile Group | Veeam.Virt.Extensions.VMware.HostSecurityProfile.Group | Display Name |
VMware vSphere Host Syslog | Veeam.Virt.Extensions.VMware.VMHOST.Syslog | id | ✓
 |  | Port Number |
 |  | Display Name |
VMware vSphere Host Temperature Sensors | Veeam.Virt.Extensions.VMware.VMHOST.VMSENSORCONTAINER.TEMPERATURE | id | ✓
 |  | Display Name |
VMware vSphere Host VMHBA | Veeam.Virt.Extensions.VMware.VMHOSTADAPTER | Host name |
 |  | id | ✓
 |  | Model |
 |  | Type |
 |  | WWN |
 |  | Display Name |
VMware vSphere Hosts | Veeam.Virt.Extensions.VMware.VMHOST.Group | Display Name |
VMwareTopology | Veeam.Virt.Extensions.VMware.Topology | id | ✓
 |  | Total Hosts |
 |  | Total VMGuests |
 |  | XML Topology File |
 |  | Display Name |


Veeam Base Discovery

Display Name | Object ID | Properties
 |  | Display Name | Key
Monitoring Group | Veeam.Virt.Extensions.VMware.EMMonitoringGroup | id | ✓
 |  | Display Name |
Veeam Collector Heartbeat | Veeam.Virt.Extensions.VMware.EMCollector | Collector Server |
 |  | Collector Version |
 |  | Extensions Service |
 |  | id | ✓
 |  | Monitoring Group |
 |  | Display Name |
Veeam Collector Heartbeat Group | Veeam.Virt.Extensions.VMware.EMCollector.Group | Display Name |
Veeam Ops Mgr agents running in VMware VMs | Veeam.Virt.Extensions.VMware.VMwareVirtualMachine.Group | Display Name |
Veeam Virtualization Extensions Object | Veeam.Virt.Extensions.VMware.VMwareVirtualMachine | CPU Count |
 |  | CPU Limit MHz |
 |  | CPU Reservation MHz |
 |  | CPU Shares |
 |  | Datacenter Name |
 |  | Disk IOPS Limit |
 |  | Disk Shares |
 |  | Folder Name |
 |  | Guest OS FQDN |
 |  | Guest OS NETBIOS Name |
 |  | Memory Allocation MB |
 |  | Memory Limit MB |
 |  | Memory Reservation MB |
 |  | Memory Shares |
 |  | Uses Datastores |
 |  | Uses Networks |
 |  | vCenter Name |
 |  | Virtualization Platform |
 |  | VMware BIOS Version |
 |  | Display Name |
Veeam Virtualization Extensions Service | Veeam.Virt.Extensions.VMware.EMServer | License Edition |
 |  | License Expired |
 |  | License Type |
 |  | Licensed Hyper-V Sockets |
 |  | Licensed Platform(s) |
 |  | Licensed vSphere Sockets |
 |  | Port |
 |  | Resource Pool |
 |  | Veeam UI URL |
 |  | Version |
 |  | Display Name |
Veeam Virtualization Extensions Service Group | Veeam.Virt.Extensions.VMware.EMServer.Group | Display Name |
Veeam VMware Collector Applications | Veeam.Virt.Extensions.VMware.Collector.Group | Display Name |
Veeam VMware Collector link to VMware API (vCenter, or vSphere Host) | Veeam.Virt.Extensions.VMware.EMTarget | API Version |
 |  | License Edition |
 |  | Port |
 |  | Target | ✓
 |  | Type |
 |  | Display Name |
Veeam VMware Collector Servers | Veeam.Virt.Extensions.VMware.CollectorServers.Group | Display Name |
Veeam VMware Collector Servers and Health Services | Veeam.Virt.Extensions.VMware.CollectorAndHealthService.Group | Display Name |
Veeam VMware Collector Service | Veeam.Virt.Extensions.VMware.Collector | Collector Server |
 |  | Collector Version |
 |  | Extensions Service |
 |  | Installation Folder |
 |  | Monitoring Group |
 |  | Display Name |
Veeam VMware Collectors and VE Services Group | Veeam.Virt.Extensions.VMware.Services.Group | Display Name |


Veeam VMware High-Granularity

Display Name | Object ID | Properties
 |  | Display Name | Key
Veeam VMware objects for high-granularity performance collection | Veeam.Virt.Extensions.VMware.Monitoring.HighGranularity.Enable.Group | Display Name |


Veeam VMware Required Overrides

Display Name | Object ID | Properties
 |  | Display Name | Key
Veeam Backup and Replication replica VMs | Veeam.Virt.Extensions.RequiredBackupOverrides.Backup.ReplicaVM.Group | id | ✓
 |  | Display Name


Discoveries

This section describes Veeam MP for VMware discoveries.

Veeam VMware vCenter Monitoring

Veeam VMware Discovery

Veeam Base Discovery

Veeam VMware Integration


Veeam VMware vCenter Monitoring

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Discover vCenter | Veeam.Virt.Extensions.VMware.vCenter.Discovery | VMware vCenter Server | DisplayName |


Veeam VMware Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Veeam Stage 1 - Core VMware topology discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.CoreObjects | VMware Datastore Cluster | id | id
 |  |  | DisplayName |
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | sdrs | Storage DRS
 |  |  | sioc | SDRS I/O Metrics
 |  |  | automationLevel | Automation Level
 |  |  | type | Type
 |  |  | capacity | Capacity GB
 |  |  | folderName | Folder Name
 |  | VM Container | id | id
 |  |  | hostName | hostName
 |  | VMware Cluster | id | id
 |  |  | DisplayName |
 |  |  | datacenterName | Datacenter Name
 |  |  | vCenterName | vCenter Name
 |  |  | drsStatus | DRS Status
 |  |  | haStatus | HA Status
 |  |  | totalCpu | Total CPU GHz
 |  |  | totalMemory | Total Memory GB
 |  |  | totalStorage | Total Storage TB
 |  |  | numHosts | Num Hosts
 |  |  | folderName | Folder Name
 |  | VMware Datacenter | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | DisplayName |
 |  | VMwareTopology | FileName | XML Topology File
 |  |  | id | id
 |  |  | vmCount | Total VMGuests
 |  |  | hostCount | Total Hosts
 |  | VMware Connections | id | id
 |  |  | targetType | targetType
 |  |  | targetServer | targetServer
 |  |  | targetPort | targetPort
 |  | VMware vSphere Host | id | id
 |  |  | TaskPath | TaskPath
 |  |  | nworksCollector | Veeam Collector
 |  |  | vCenterName | vCenter Name
 |  |  | clusterName | Cluster Name
 |  | VMware vSphere Host COS Partitions | id | id
 |  |  | DisplayName |
 |  | VMware vCenter | id | id
 |  |  | version | Version
 |  |  | DisplayName |
 |  | VMware vCenter - Storage | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | version | Version
 |  |  | DisplayName |
 |  | VMware Datacenter - Storage | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | DisplayName |
Veeam Stage 1 - Resource Pools and Virtual Applications discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.ResourcePools | VMware Resource Pool | id | id
 |  |  | DisplayName |
 |  |  | clusterId | Cluster Name
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | cpuAllocation | CPU Allocation
 |  |  | cpuShares | CPU Shares
 |  |  | cpuReservation | CPU Reservation
 |  |  | cpuLimit | CPU Limit
 |  |  | memoryAllocation | Memory Allocation
 |  |  | memoryShares | Memory Shares
 |  |  | memoryReservation | Memory Reservation
 |  |  | memoryLimit | Memory Limit
 |  |  | parentContainer | Parent Container
 |  |  | custom3 | Custom Tag 3
 |  | VMware Virtual Application | id | id
 |  |  | TaskPath | TaskPath
 |  |  | clusterId | Cluster Name
 |  |  | vCenterName | vCenter Name
 |  |  | DisplayName |
 |  |  | datacenterName | Datacenter Name
 |  |  | cpuAllocation | CPU Allocation
 |  |  | cpuShares | CPU Shares
 |  |  | cpuReservation | CPU Reservation
 |  |  | cpuLimit | CPU Limit
 |  |  | memoryAllocation | Memory Allocation
 |  |  | memoryShares | Memory Shares
 |  |  | memoryReservation | Memory Reservation
 |  |  | memoryLimit | Memory Limit
 |  |  | parentContainer | Parent Container
 |  |  | custom3 | Custom Tag 3
Veeam Stage 1 - Virtual Machine Containers discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.VMContainers | VM Container | id | id
 |  |  | hostName | hostName
 |  | VM Discovery Container | id | id
 |  |  | nworksCollector | Veeam Collector
 |  |  | hostName | hostName
 |  |  | TaskPath | TaskPath
Veeam Stage 1 - Virtual Switches and Ditributed Virtual Switches discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.vSwitches | VMware vCenter - Network | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | version | Version
 |  |  | DisplayName |
 |  | VMware Datacenter - Network | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | DisplayName |
 |  | VMware Distributed Virtual Switch | DisplayName |
 |  |  | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | folderName | Folder Name
 |  |  | numPorts | Number of ports
 |  |  | uplinkNumPorts | Number of Uplink ports
 |  |  | manufacturer | Manufacturer
 |  |  | version | Version
 |  |  | vMotion | vMotion
 |  |  | faultToleranceLogging | FT Logging
 |  |  | managementTraffic | Management Traffic
 |  |  | directPathIOControl | Direct Path I/O
 |  |  | networkIOControl | Network I/O Control
 |  |  | custom3 | Custom Tag 3
 |  | VMware Virtual Switch | DisplayName |
 |  |  | id | id
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | hostName | Host Name
 |  |  | numPorts | Number of ports
 |  |  | vMotion | vMotion
 |  |  | faultToleranceLogging | FT Logging
 |  |  | managementTraffic | Management Traffic
 |  |  | folderName | Folder Name
Veeam Stage 2 - Datastore discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.Datastore | VMware Datastore | id |
 |  |  | diskSize | Disk Size GB
 |  |  | fsType | Filesystem
 |  |  | custom1 | Custom Tag 1
 |  |  | custom2 | Custom Tag 2
 |  |  | custom3 | Custom Tag 3
 |  |  | storagePod | Datastore Cluster Name
 |  |  | sdrs | SDRS
 |  |  | sioc | SIOC
 |  |  | folderName | Folder Name
 |  |  | DisplayName |
Veeam Stage 2 - Host components discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.HostComponents | VMware vSphere Host VMHBA | id | id
 |  |  | model | Model
 |  |  | type | Type
 |  |  | WWN | WWN
 |  |  | DisplayName |
 |  | VMware vSphere Host Network Card | id | id
 |  |  | adapter | Adapter
 |  |  | speed | Speed Mb
 |  |  | duplex | Duplex
 |  |  | macAddress | MAC Address
 |  |  | ipAddress | IP Address
 |  |  | switchName | (d)vSwitch Name
 |  |  | DisplayName |
 |  | VMware vSphere Host | id | id
 |  |  | cpuPkgs | CPU Sockets
 |  |  | memoryTotalMem | Memory GB
 |  |  | vmwareVersion | Build Version
 |  |  | systemModel | System Model
 |  |  | DisplayName |
 |  |  | systemManufacturer | System Manufacturer
 |  |  | systemBIOS | System BIOS
 |  |  | systemSN | System Serial Number
 |  |  | bmcIp | Mgmt Controller
 |  |  | custom1 | Custom Tag 1
 |  |  | custom2 | Custom Tag 2
 |  |  | custom3 | Custom Tag 3
 |  |  | cpuTotal | Total CPU GHz
 |  | VMware vSphere Host COS Partitions | id | id
 |  |  | DisplayName |
 |  | VMware vSphere Host HBA Container | id | id
 |  |  | DisplayName |
 |  | VMware vSphere Host COS Partition | url | url
 |  |  | diskSize | Disk Size GB
 |  | VMware vSphere Host Syslog | id | id
 |  |  | portNumber | Port Number
 |  |  | DisplayName |
Veeam Stage 2 - Virtual Machine discovery | Veeam.Virt.Extensions.VMware.Topology.Discovery.VM | VMware Resource Pool | id | id
 |  | VMware Virtual Machine | resourcePoolId | Resource Pool Name
 |  |  | vAppId | vAPP Name
 |  |  | guestHostName | Guest DNS Name
 |  |  | host | Host Name
 |  |  | id | id
 |  |  | TaskPath | Task Path
 |  |  | guestOSFullName | Guest OS
 |  |  | clusterName | Cluster Name
 |  |  | toolsVersion | VMware Tools Version
 |  |  | datacenterName | Datacenter Name
 |  |  | memoryConfigMaximum | Memory Allocation MB
 |  |  | vCenterName | vCenter Name
 |  |  | DisplayName |
 |  |  | nworksCollector | Veeam Collector
 |  |  | folderName | Folder Name
 |  |  | vmVersion | VM Version
 |  |  | ipAddresses | IP Address(es)
 |  |  | usesNetworks | Uses Networks
 |  |  | usesDatastores | Uses Datastores
 |  |  | cpuCount | CPU Count
 |  |  | cpuShares | CPU Shares
 |  |  | cpuAllocReservation | CPU Reservation MHz
 |  |  | cpuLimit | CPU Limit MHz
 |  |  | cpuAllocation | CPU Allocation MHz
 |  |  | memoryShares | Memory Shares
 |  |  | memoryAllocReservation | Memory Reservation MB
 |  |  | memoryLimit | Memory Limit MB
 |  |  | diskAllocation | Disk Allocation GB
 |  |  | diskShares | Disk Shares
 |  |  | diskIOPSLimit | Disk IOPS Limit
 |  |  | monitoringGroup | Veeam Monitoring Group
 |  |  | custom1 | Custom Tag 1
 |  |  | custom2 | Custom Tag 2
 |  |  | custom3 | Custom Tag 3


Veeam Base Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Discover Veeam Virtualization Extensions for System Center | Veeam.Virt.Extensions.VMware.EMServer.Discovery | Veeam Virtualization Extensions Service | DisplayName |
Discover Veeam Virtualization Extensions Service properties | Veeam.Virt.Extensions.VMware.EMServer.i386.Discovery | Veeam Virtualization Extensions Service | ui_uri | Veeam UI URL
 |  |  | version | Version
 |  |  | licType | License Type
 |  |  | licPlat | Licensed Platform(s)
 |  |  | licEdition | License Edition
 |  |  | licExpired | License Expired
 |  |  | port | Port
 |  |  | resourcePool | Resource Pool
Discover Veeam VMware Collector | Veeam.Virt.Extensions.VMware.Collector.Discovery | Veeam VMware Collector Service | DisplayName |
 |  |  | VEMServer | Collector Server
 |  |  | CollectorVersion | Collector Version
 |  |  | InstallationFolder | Installation Folder
 |  |  | monitoringGroup | Monitoring Group
 |  |  | virtExtService | Extensions Service
Discover VMware Virtual Machine | Veeam.Virt.Extensions.VMware.VMwareVirtualMachine.Discovery | Veeam Virtualization Extensions Object | DisplayName |
 |  |  | VMwareBIOSVersion | VMware BIOS Version
 |  |  | GuestOSDNSName | Guest OS FQDN
Veeam Virtualization Extensions for System Center Topology discovery | Veeam.Virt.Extensions.VMware.EMTopology.Discovery | Veeam Collector Heartbeat | CollectorVersion | Collector Version
 |  |  | VEMServer | Collector Server
 |  |  | id | id
 |  |  | DisplayName |
 |  | Veeam VMware Collector link to VMware API (vCenter, or vSphere Host) | DisplayName |
 |  |  | type | Type
 |  |  | target | Target
 |  |  | version | API Version
 |  |  | port | Port
 |  | Veeam Virtualization Extensions Service | licSockets | Licensed vSphere Sockets
 |  |  | licSocketsHyperV | Licensed Hyper-V Sockets


Veeam VMware Integration

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Create relationship between VMware virtual machine and Ops Mgr Agent in VM | Veeam.Virt.Extensions.VMware.Integration.SDK.VMContainsWC.Discovery | VMware Virtual Machine | id | id
 |  | Ops Mgr Agent in VM | PrincipalName |
 |  |  | vCenterName | vCenter Name
 |  |  | datacenterName | Datacenter Name
 |  |  | folderName | Folder Name
 |  |  | usesNetworks | Uses Networks
 |  |  | usesDatastores | Uses Datastores
 |  |  | cpuShares | CPU Shares
 |  |  | cpuCount | CPU Count
 |  |  | cpuAllocReservation | CPU Reservation MHz
 |  |  | cpuLimit | CPU Limit MHz
 |  |  | memoryAllocReservation | Memory Reservation MB
 |  |  | memoryShares | Memory Shares
 |  |  | memoryConfigMaximum | Memory Allocation MB
 |  |  | memoryLimit | Memory Limit MB
 |  |  | diskShares | Disk Shares
 |  |  | diskIOPSLimit | Disk IOPS Limit


Rules and Monitors

This section described Veeam MP for VMware rules and monitors.

Performance Collection Rules

Event-Based Rules

Event Monitors

Performance Monitors

Dependency Monitors


Performance Collection Rules

This section describes Veeam MP for VMware performance collection rules.

Veeam VMware vCenter Monitoring

Veeam VMware Monitoring

Veeam Base Discovery

Veeam VMware High-Granularity


Veeam VMware vCenter Monitoring

Target | Rule/Alert Name | Metric Class | Metric Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
VMware vCenter Server | Veeam vCenter: Collect vCenter java process % Processor Time Note: This metric is collected only for VMware vSphere 5.x |  |  | Process | % Processor Time | yes | yes | no
VMware vCenter Server | Veeam vCenter: Collect vCenter java process Private Bytes Note: This metric is collected only for VMware vSphere 5.x |  |  | Process | Private Bytes | yes | yes | no
VMware vCenter Server | Veeam vCenter: Collect vCenter Service % Processor Time |  |  | Process | % Processor Time | yes | yes | no
VMware vCenter Server | Veeam vCenter: Collect vCenter Service Private Bytes |  |  | Process | Private Bytes | yes | yes | no
VMware vCenter Server | Veeam vCenter: Collect vCenter Web Service % Processor Time |  |  | Process | % Processor Time | yes | no | yes
VMware vCenter Server | Veeam vCenter: Collect vCenter Web Service Private Bytes |  |  | Process | Private Bytes | yes | no | yes


Veeam VMware Monitoring

Target | Rule/Alert Name | Metric Class | Metric Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
VMware Cluster | CLUSTER.Collect.cpuPressure |  |  | VMCluster-cpu | cpuPressure | yes | yes | no
VMware Cluster | CLUSTER.Collect.cpuUsageMHz |  |  | VMCluster-cpu | cpuUsageMHz | yes | yes | no
VMware Cluster | CLUSTER.Collect.cpuUsedPct | Cluster | cpuUsedPct | VMCluster-cpu | cpuUsedPct | yes | yes | no
VMware Cluster | CLUSTER.Collect.freeStorage | Cluster | freeStorage | VMCluster-disk | freeStorageTB | yes | yes | no
VMware Cluster | CLUSTER.Collect.memoryPressure | Cluster | memoryPressure | VMCluster-memory | memoryPressure | yes | yes | no
VMware Cluster | CLUSTER.Collect.memoryUsedMB |  |  | VMCluster-memory | memoryUsedMB | yes | yes | no
VMware Cluster | CLUSTER.Collect.memoryUsedPct | Cluster | memoryUsedPct | VMCluster-memory | memoryUsedPct | yes | yes | no
VMware Cluster | CLUSTER.Collect.totalDiskUsageRate | Cluster | totalDiskUsageRate | VMCluster-disk | usageRateKB/s | yes | yes | no
VMware Cluster | CLUSTER.Collect.totalNetUsageRate | Cluster | totalNetUsageRate | VMCluster-net | usageRateKB/s | yes | yes | no
VMware Cluster | CLUSTER.Collect.totalvMotions | Cluster | totalvMotions | VMCluster | vMotions | yes | yes | no
VMware Cluster | CLUSTER.Collect.vCpuCount |  |  | VMCluster | vCpuCount | yes | yes | no
VMware Cluster | CLUSTER.Collect.vmActive | Cluster | vmActive | VMCluster | vmActive | yes | yes | no
VMware Cluster | CLUSTER.Collect.vmShutdown | Cluster | vmShutdown | VMCluster | vmShutdown | yes | yes | no
VMware Cluster | CLUSTER.Collect.vmSuspended | Cluster | vmSuspended | VMCluster | vmSuspended | yes | yes | no
VMware Cluster | CLUSTER.Collect.vmTotal | Cluster | vmTotal | VMCluster | vmTotal | yes | yes | no
VMware Datastore | DATASTORE.Collect.diskFree | DatastoreStats | free | VMDatastore | freeGB | yes | yes | no
VMware Datastore | DATASTORE.Collect.diskPressure | DatastoreStats | pressure | VMDatastore | diskPressure | yes | yes | no
VMware Datastore | DATASTORE.Collect.IOPS | DatastoreHostStats | hostIOPS | VMDatastore | IOPS | yes | yes | no
VMware Datastore | DATASTORE.Collect.maxDeviceLatency | DatastoreStats | maxDeviceLatency | VMDatastore | MaxDeviceLatency | yes | yes | no
VMware Datastore | DATASTORE.Collect.maxDeviceReadLatency | DatastoreStats | maxDeviceReadLatency | VMDatastore | MaxDeviceReadLatency | yes | yes | no
VMware Datastore | DATASTORE.Collect.maxDeviceWriteLatency | DatastoreStats | maxDeviceWriteLatency | VMDatastore | MaxDeviceWriteLatency | yes | yes | no
VMware Datastore | DATASTORE.Collect.Provisioned | DatastoreStats | provisioned | VMDatastore | ProvisionedGB | yes | yes | no
VMware Datastore | DATASTORE.Collect.totalIOPS | DatastoreStats | totalIOPS | VMDatastore | IOPS | yes | yes | no
VMware Datastore | DATASTORE.Collect.totalReadRate | DatastoreStats | totalReadRate | VMDatastore | readRateKB/s | yes | yes | no
VMware Datastore | DATASTORE.Collect.totalWriteRate | DatastoreStats | totalWriteRate | VMDatastore | writeRateKB/s | yes | yes | no
VMware Datastore | DATASTORE.Collect.unknownFilesGB | DatastoreStats | unknownFilesGB | VMDatastore | unknownFilesGB | yes | yes | no
VMware Datastore | DATASTORE.Collect.vmTotal | DatastoreStats | vmTotal | VMDatastore | vmTotal | yes | yes | no
VMware Datastore | DATASTORE.Host.Collect.maxDeviceLatency | DatastoreHostStats | maxDeviceLatency | VMDatastore | maxDeviceLatency | yes | yes | no
VMware Datastore Base Class | DATASTORE.Collect.diskPercUsed | DatastoreStats | usedPct | VMDatastore | usedPct | yes | yes | no
VMware Datastore Cluster | DSCLUSTER.Collect.diskPressure | DatastoreCluster | pressure | VMDatastoreCluster | diskPressure | yes | yes | no
VMware Datastore Cluster | DSCLUSTER.Collect.freeGB | DatastoreCluster | freeGB | VMDatastoreCluster | freeGB | yes | yes | no
VMware Datastore Cluster | DSCLUSTER.Collect.freePct | DatastoreCluster | freePct | VMDatastoreCluster | freePct | yes | yes | no
VMware Datastore Cluster | DSCLUSTER.Collect.usedPct | DatastoreCluster | usedPct | VMDatastoreCluster | usedPct | yes | yes | no
VMware Datastore Cluster | DSCLUSTER.Collect.vmTotal | DatastoreCluster | vmTotal | VMDatastoreCluster | vmTotal | yes | yes | no
VMware Resource Pool | POOL.Collect.cpuUsageMHz | ResourcePool | cpuUsageMhz | VMPool-cpu | cpuUsageMHz | yes | yes | no
VMware Resource Pool | POOL.Collect.cpuUsedPct | ResourcePool | cpuUsedPct | VMPool-cpu | cpuUsedPct | yes | yes | no
VMware Resource Pool | POOL.Collect.memoryUsedMB | ResourcePool | memoryUsed | VMPool-memory | memoryUsedMB | yes | yes | no
VMware Resource Pool | POOL.Collect.memoryUsedPct | ResourcePool | memoryUsedPct | VMPool-memory | memoryUsedPct | yes | yes | no
VMware Resource Pool | POOL.Collect.vmActive | ResourcePool | vmActive | VMPool | vmActive | yes | yes | no
VMware Resource Pool | POOL.Collect.vmTotal | ResourcePool | vmTotal | VMPool | vmTotal | yes | yes | no
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.siocAggregatedIOPS | DatastoreStats | siocAggregatedIOPS | VMDatastore | SIOC Aggregated IOPS | yes | yes | no
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.siocNormalizedLatency | DatastoreStats | siocNormalizedLatency | VMDatastore | SIOC Normalized Latency | yes | yes | no
VMware Virtual Application | VAPP.Collect.cpuUsageMHz | ResourcePool | cpuUsageMhz | VMVApp-cpu | cpuUsageMHz | yes | yes | no
VMware Virtual Application | VAPP.Collect.cpuUsedPct | ResourcePool | cpuUsedPct | VMVApp-cpu | cpuUsedPct | yes | yes | no
VMware Virtual Application | VAPP.Collect.memoryUsedMB | ResourcePool | memoryUsed | VMVApp-memory | memoryUsedMB | yes | yes | no
VMware Virtual Application | VAPP.Collect.memoryUsedPct | ResourcePool | memoryUsedPct | VMVApp-memory | memoryUsedPct | yes | yes | no
VMware Virtual Application | VAPP.Collect.vmActive | ResourcePool | vmActive | VMVApp | vmActive | yes | yes | no
VMware Virtual Application | VAPP.Collect.vmTotal | ResourcePool | vmTotal | VMVApp | vmTotal | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.commands/sec | VMDiskStats | commands | VMGuest-disk | commands/sec | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.commandsFailed |  |  | VMGuest-disk | commandsFailed | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.commandsPs |  |  | VMGuest-disk | commands/sec | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuCoStopPct |  |  | VMGuest-cpu | cpuCoStopPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuLatencyPct |  |  | VMGuest-cpu | cpuLatencyPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuReadyPct |  |  | VMGuest-cpu | cpuReadyPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuSwapWaitPct |  |  | VMGuest-cpu | cpuSwapWaitPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuUsageMHz |  |  | VMGuest-cpu | cpuUsageMHz | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.cpuUsedPct |  |  | VMGuest-cpu | cpuUsedPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.diskLatency |  |  | VMGuest-disk | diskLatency | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.droppedPacketsTotal |  |  | VMGuest-net | droppedPackets | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.freeMB |  |  | VMGuest-disk | freeMB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryActiveMB |  |  | VMGuest-memory | memoryActiveMB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryActivePct |  |  | VMGuest-memory | memoryActivePct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryBalloonPct |  |  | VMGuest-memory | memoryBalloonPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryConsumed |  |  | VMGuest-memory | memoryConsumedMB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryLatencyPct |  |  | VMGuest-memory | memoryLatencyPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memorySwapRate |  |  | VMGuest-memory | memorySwapRateKB/s | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.memoryUsedPct |  |  | VMGuest-memory | memoryUsedPct | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.outstandingIOs |  |  | VMGuest-disk | outstandingIOs | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.readLatency | VMDiskStats | readLatency | VMGuest-disk | readLatency | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.snapshotAge |  |  | VMGuest | snapshotAgeHours | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.snapshotsSize |  |  | VMGuest | snapshotsSizeMB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.totalDiskUsageRate |  |  | VMGuest-disk | usageRateKB/s | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.totalNetUsageRate |  |  | VMGuest-net | usageRateKB/s | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.usedStorage | VMStats | usedStorage | VMGuest-disk | usedStorageGB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.usedStorageDatastore | DatastoreVmStats | usedStorageGB | VMGuest-disk | usedStorageGB | yes | yes | no
VMware Virtual Machine | VMGUEST.Collect.writeLatency | VMDiskStats | writeLatency | VMGuest-disk | writeLatency | yes | yes | no
VMware Virtual Machine (Template) | VMGUEST.Template.Collect.usedStorageGB | DatastoreVmStats | usedStorageGB | VMGuest-disk | usedStorageGB | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuCoStopPct | HostStats | cpuCoStopPct | VMHost-cpu | cpuCoStopPct | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuLatencyPct | HostStats | cpuLatency | VMHost-cpu | cpuLatencyPct | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuPressure |  |  | VMHost-cpu | cpuPressure | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuReadyPct | HostStats | cpuReadyPct | VMHost-cpu | cpuReadyPct | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuUsageMHz | HostStats | cpuUsageMhz | VMHost-cpu | cpuUsageMHz | yes | yes | no
VMware vSphere Host | HOST.Collect.cpuUsedPct | HostStats | cpuUsedPct | VMHost-cpu | cpuUsedPct | yes | yes | no
VMware vSphere Host | HOST.Collect.diskMaxTotalLatency | HostStats | diskMaxTotalLatency | VMHost-hba | diskMaxTotalLatency | yes | yes | no
VMware vSphere Host | HOST.Collect.droppedPacketsTotal | HostStats | droppedPacketsTotal | VMHost-net | droppedPackets | yes | yes | no
VMware vSphere Host | HOST.Collect.maxKernelLatency |  |  | VMHost-hba | MaxKernelLatency | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryAvail | HostStats | memoryAvail | VMHost-memory | memoryAvailMB | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryBalloonPct | HostStats | memoryBalloonPct | VMHost-memory | memoryBalloonPct | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryLatencyPct | HostStats | memoryLatency | VMHost-memory | memoryLatencyPct | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryPressure | HostStats | memoryPressure | VMHost-memory | memoryPressure | yes | yes | no
VMware vSphere Host | HOST.Collect.memorySwapRate | HostStats | memorySwapRate | VMHost-memory | memorySwapRateKB/s | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryUsedMB | HostStats | memoryUsageMb | VMHost-memory | memoryUsedMB | yes | yes | no
VMware vSphere Host | HOST.Collect.memoryUsedPct | HostStats | memoryUsedPct | VMHost-memory | memoryUsedPct | yes | yes | no
VMware vSphere Host | HOST.Collect.totalCommandsPS | HostStats | totalCommandsPS | VMHost-hba | commands/sec | yes | yes | no
VMware vSphere Host | HOST.Collect.totalDiskUsageRate | HostStats | totalDiskUsageRate | VMHost-hba | usageRateKB/s | yes | yes | no
VMware vSphere Host | HOST.Collect.totalNetUsageRate | HostStats | totalNetUsageRate | VMHost-net | usageRateKB/s | yes | yes | no
VMware vSphere Host | HOST.Collect.totalNumPaths | HostStats | totalNumPaths | VMHost-hba | totalNumPaths | yes | yes | no
VMware vSphere Host | HOST.Collect.vCpuCount |  |  | VMHost | vCpuCount | yes | yes | no
VMware vSphere Host | HOST.Collect.vmActive | HostStats | vmActive | VMHost | vmActive | yes | yes | no
VMware vSphere Host | HOST.Collect.vmShutdown | HostStats | vmShutdown | VMHost | vmShutdown | yes | yes | no
VMware vSphere Host | HOST.Collect.vmSuspended | HostStats | vmSuspended | VMHost | vmSuspended | yes | yes | no
VMware vSphere Host | HOST.Collect.vmTotal | HostStats | vmTotal | VMHost | vmTotal | yes | yes | no
VMware vSphere Host Network Card | HOSTNET.Collect.droppedPacketsTotal | HostNetStats | droppedPacketsTotal | VMHost-net | droppedPackets | yes | yes | no
VMware vSphere Host Network Card | HOSTNET.Collect.totalUsageRate | HostNetStats | totalUsageRate | VMHost-net | usageRateKB/s | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.commandsFailed | HostAdapterStats | commandsFailed | VMHost-hba | commandsFailed | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.commandsPS | HostAdapterStats | commandsPS | VMHost-hba | commands/sec | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.maxKernelLatency | HostAdapterStats | maxKernelLatency | VMHost-hba | MaxKernelLatency | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.maxTotalLatency | HostAdapterStats | maxTotalLatency | VMHost-hba | MaxTotalLatency | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.OIOsPct | HostAdapterStats | OIOsPct | VMHost-hba | OIOsPct | yes | yes | no
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.totalUsageRate | HostAdapterStats | totalUsageRate | VMHost-hba | usageRateKB/s | yes | yes | no
VMware vSphere Host | HOST.Collect.commandsFailed |  |  | VMHost-hba | commandsFailed | yes | no | no


Veeam Base Discovery

Target | Rule/Alert Name | Metric Class | Metric Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
Veeam Collector Heartbeat | Veeam VMware Collector: Clusters |  |  | Veeam VMware Collectors | Clusters | yes | yes | no
Veeam Collector Heartbeat | Veeam VMware Collector: Datastores |  |  | Veeam VMware Collectors | Datastores | yes | yes | no
Veeam Collector Heartbeat | Veeam VMware Collector: Hosts |  |  | Veeam VMware Collectors | Hosts | yes | yes | no
Veeam Collector Heartbeat | Veeam VMware Collector: Total Workflows |  |  | Veeam VMware Collectors | Total Workflows | yes | yes | no
Veeam Collector Heartbeat | Veeam VMware Collector: VMs |  |  | Veeam VMware Collectors | VMs | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - % Disk Time |  |  | LogicalDisk | % Disk Time | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - % Memory Used (_Total) |  |  | VMGuest-memory | % Memory Used | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - % Network bandwidth used |  |  | VMGuest-net | % Network bandwidth used | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - % Page File Used (_Total) |  |  | Paging File | % Usage | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - % Processor Time (_Total) |  |  | Processor | % Processor Time | yes | yes | no
Veeam Virtualization Extensions Object | Veeam Virtualization Extensions Object Performance Collection Rule - memory pages/sec (_Total) |  |  | Memory | Pages/sec | yes | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Ops Mgr Agent HealthService CPU Usage |  |  | Process | % Processor Time | yes | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Ops Mgr HealthService PrivateBytes Usage |  |  | Process | Private Bytes | yes | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Ops Mgr HealthService Workflow Count |  |  | Health Service | Workflow Count | yes | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Ops Mgr MonitoringHost PrivateBytes Usage |  |  | Process | Private Bytes | yes | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Ops Mgr MonitoringHost process CPU Usage |  |  | Process | % Processor Time | yes | yes | no


Veeam VMware High-Granularity

Target | Rule/Alert Name | Metric Class | Metric Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
VMware vSphere Host VMHBA | HOSTADAPTER.Disk.Collect.commandsFailed (High-Granularity MP) | HostDiskStats | commandsFailed | VMHost-disk | commandsFailed | yes | yes | no
VMware Datastore | DATASTORE.Collect.deviceReadLatency (High-Granularity MP) | HostDiskStats | deviceReadLatency | VMDatastore | deviceReadLatency | yes | no | yes
VMware Datastore | DATASTORE.Collect.deviceWriteLatency (High-Granularity MP) | HostDiskStats | deviceWriteLatency | VMDatastore | deviceWriteLatency | yes | no | yes
VMware Datastore | DATASTORE.Collect.diskIOPS (High-Granularity MP) | HostDiskStats | diskIOPS | VMDatastore | IOPS | yes | no | yes
VMware Datastore | DATASTORE.Collect.VMObservedLatency (High-Granularity MP) | DatastoreStats | VMObservedLatency | VMDatastore | VMObservedLatency | yes | no | yes
VMware Resource Pool | POOL.Collect.vmShutdown (High-Granularity MP) | ResourcePool | vmShutdown | VMPool | vmShutdown | yes | no | yes
VMware Resource Pool | POOL.Collect.vmSuspended (High-Granularity MP) | ResourcePool | vmSuspended | VMPool | vmSuspended | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsNormalizedReadLatency (High-Granularity MP) | DatastoreStats | sdrsNormalizedReadLatency | VMDatastore | SDRS Normalized Read Latency | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsNormalizedWriteLatency (High-Granularity MP) | DatastoreStats | sdrsNormalizedWriteLatency | VMDatastore | SDRS Normalized Write Latency | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsOutstandingReadRequests (High-Granularity MP) | DatastoreStats | sdrsOutstandingReadRequests | VMDatastore | SDRS Outstanding Read Requests | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsOutstandingWriteRequests (High-Granularity MP) | DatastoreStats | sdrsOutstandingWriteRequests | VMDatastore | SDRS Outstanding Write Requests | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsReadIOPS (High-Granularity MP) | DatastoreStats | sdrsReadIOPS | VMDatastore | SDRS Read IOPS | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.sdrsWriteIOPS (High-Granularity MP) | DatastoreStats | sdrsWriteIOPS | VMDatastore | SDRS Write IOPS | yes | no | yes
VMware SIOC/SDRS Datastore | DATASTORE.SIOCSDRS.Collect.siocMaxQueueDepth (High-Granularity MP) | DatastoreStats | siocMaxQueueDepth | VMDatastore | SIOC Max Queue Depth | yes | no | yes
VMware Virtual Application | VAPP.Collect.vmShutdown (High-Granularity MP) | ResourcePool | vmShutdown | VMVApp | vmShutdown | yes | no | yes
VMware Virtual Application | VAPP.Collect.vmSuspended (High-Granularity MP) | ResourcePool | vmSuspended | VMVApp | vmSuspended | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.cpuIdlePct (High-Granularity MP) |  |  | VMGuest-cpu | cpuIdlePct | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.cpuWaitPct (High-Granularity MP) |  |  | VMGuest-cpu | cpuWaitPct | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.freePct (High-Granularity MP) |  |  | VMGuest-disk | freePct | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.memoryShared (High-Granularity MP) |  |  | VMGuest-memory | memorySharedKB | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.receiveRate (High-Granularity MP) | VMNetStats | receiveRate | VMGuest-net | receiveRateKB/s | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.transmitRate (High-Granularity MP) | VMNetStats | transmitRate | VMGuest-net | transmitRateKB/s | yes | no | yes
VMware Virtual Machine | VMGUEST.Collect.usageRateKB (High-Granularity MP) | VMDiskStats | usageRateKB | VMGuest-disk | usageRateKB/s | yes | no | yes
VMware Virtual Machine | VMGUEST.Disk.Collect.outstandingIOs (High-Granularity MP) | VMDiskStats | outstandingIOs | VMGuest-disk | outstandingIOs | yes | no | yes
VMware vSphere Host | HOST.Collect.cpuIdlePct (High-Granularity MP) | HostStats | cpuIdlePct | VMHost-cpu | cpuIdlePct | yes | no | yes
VMware vSphere Host | HOST.Collect.memoryActive (High-Granularity MP) | HostStats | memoryActive | VMHost-memory | memoryActiveMB | yes | no | yes
VMware vSphere Host | HOST.Collect.memoryAvailPct (High-Granularity MP) | HostStats | memoryAvailPct | VMHost-memory | memoryAvailPct | yes | no | yes
VMware vSphere Host | HOST.Collect.memoryShared (High-Granularity MP) | HostStats | memoryShared | VMHost-memory | memorySharedMB | yes | no | yes
VMware vSphere Host | HOST.Collect.memorySwapped (High-Granularity MP) | HostStats | memorySwapped | VMHost-memory | memorySwappedMB | yes | no | yes
VMware vSphere Host COS Partition | HOSTCOSPARTITION.Collect.diskFree (High-Granularity MP) | DatastoreStats | free | VMDatastore | freeMB | yes | no | yes
VMware vSphere Host Network Card | HOSTNET.Collect.droppedRx (High-Granularity MP) | HostNetStats | droppedRx | VMHost-net | droppedRx | yes | no | yes
VMware vSphere Host Network Card | HOSTNET.Collect.droppedTx (High-Granularity MP) | HostNetStats | droppedTx | VMHost-net | droppedTx | yes | no | yes
VMware vSphere Host Network Card | HOSTNET.Collect.receiveRate (High-Granularity MP) | HostNetStats | receiveRate | VMHost-net | receiveRateKB/s | yes | no | yes
VMware vSphere Host Network Card | HOSTNET.Collect.transmitRate (High-Granularity MP) | HostNetStats | transmitRate | VMHost-net | transmitRateKB/s | yes | no | yes
VMware vSphere Host Power Sensors | SENSOR.POWER.Collect.actualValue.Amps (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Amps | yes | no | yes
VMware vSphere Host Power Sensors | SENSOR.POWER.Collect.actualValue.Percentage (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Percentage | yes | no | yes
VMware vSphere Host Power Sensors | SENSOR.POWER.Collect.actualValue.Volts (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Volts | yes | no | yes
VMware vSphere Host Power Sensors | SENSOR.POWER.Collect.actualValue.Watts (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Watts | yes | no | yes
VMware vSphere Host Temperature Sensors | SENSOR.TEMPERATURE.Collect.actualValue.DegreeC (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Degrees C | yes | no | yes
VMware vSphere Host Temperature Sensors | SENSOR.TEMPERATURE.Collect.actualValue.Percentage (High-Granularity MP) | SensorStats | actualValue | VMHost-Sensor | Percentage | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.diskReadRate (High-Granularity MP) | HostDiskStats | diskReadRate | VMHost-disk | readRateKB/s | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.diskUsageRate (High-Granularity MP) | HostDiskStats | diskUsageRate | VMHost-disk | usageRateKB/s | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.diskWriteRate (High-Granularity MP) | HostDiskStats | diskWriteRate | VMHost-disk | writeRateKB/s | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.kernelLatency (High-Granularity MP) | HostDiskStats | kernelCommandLatency | VMHost-disk | kernelLatency | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.kernelReadLatency (High-Granularity MP) | HostDiskStats | kernelReadLatency | VMHost-disk | kernelReadLatency | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.kernelWriteLatency (High-Granularity MP) | HostDiskStats | kernelWriteLatency | VMHost-disk | kernelWriteLatency | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.maxQueueDepth (High-Granularity MP) | HostDiskStats | maxQueueDepth | VMHost-disk | maxQueueDepth | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.readRate (High-Granularity MP) | HostAdapterStats | readRate | VMHost-hba | readRateKB/s | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.totalReadLatency (High-Granularity MP) | HostAdapterStats | totalReadLatency | VMHost-hba | readLatency | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.totalWriteLatency (High-Granularity MP) | HostAdapterStats | totalWriteLatency | VMHost-hba | writeLatency | yes | no | yes
VMware vSphere Host VMHBA | HOSTADAPTER.Collect.writeRate (High-Granularity MP) | HostAdapterStats | writeRate | VMHost-hba | writeRateKB/s | yes | no | yes


Event-Based Rules

This section describes Veeam MP for VMware event-based rules.

Veeam VMware vCenter Monitoring

Veeam VMware Monitoring

Veeam Base Discovery

Veeam VMware Integration


Veeam VMware vCenter Monitoring

Target | Rule/Alert Name | Event ID | Alert Level | Enabled | Overrides
VMware vCenter Server | Veeam vCenter: VC Application Error |  | Error | yes | no
VMware vCenter Server | Veeam vCenter: VC Application Warning |  | Warning | yes | no


Veeam VMware Monitoring

Target

Rule/Alert Name

Event ID

Alert Level

Enabled

Overrides

Veeam VMware Collector: vCenter connection failover errors and warnings

EventDisplayNumber Equal 995

Warning

yes

no

VMware Cluster

Veeam VMware: Collect Cluster events

yes

no

VMware vCenter

Veeam VMware: 3rd party component error message

esx.problem.3rdParty.error

Error

yes

no

VMware vCenter

Veeam VMware: 3rd party component warning message

esx.problem.3rdParty.warning

Warning

yes

no

VMware vCenter

Veeam VMware: A required license is not reserved

NoLicenseEvent

Error

yes

no

VMware vCenter

Veeam VMware: AD Certificate Import Failed

ad.event.ImportCertFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: AD Join Domain Failed

ad.event.JoinDomainFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: AD Leave Domain Failed

ad.event.LeaveDomainFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Authentication of user has failed

esx.audit.dcui.login.failed

Error

yes

no

VMware vCenter

Veeam VMware: Cannot clone vm to invalid or non-existent destination

com.vmware.vc.VmCloneFailedInvalidDestinationEvent

Error

yes

no

VMware vCenter

Veeam VMware: Cannot clone vm to resource pool

com.vmware.vc.VmCloneToResourcePoolFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Cannot synchronise vSphere Host

HostSyncFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Datastore cluster encountered errors while entering maintenance mode

com.vmware.vc.sdrs.DatastoreMaintenanceModeErrorsEvent

Error

yes

no

VMware vCenter

Veeam VMware: Datastore Locker Misconfigured

LockerMisconfiguredEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Duplicate Datastore names detected

DatastoreDuplicatedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Error Powering on VM after OVF cloning

com.vmware.vc.ovfconsumers.PowerOnAfterCloneErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: ESX Agent Manager (EAM) error

com.vmware.vim.eam.*

Error

yes

no

VMware vCenter

Veeam VMware: Failed to clone OVF state for the entity

com.vmware.vc.ovfconsumers.CloneOvfConsumerStateErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Failed to configure VM Auto-start settings

com.vmware.vc.host.AutoStartReconfigureFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Failed to register OVF entity on extension

com.vmware.vc.ovfconsumers.RegisterEntityErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Failed to retrieve OVF environment sections for VM

com.vmware.vc.ovfconsumers.GetOvfEnvironmentSectionsErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Failed to unregister OVF entities on extension

com.vmware.vc.ovfconsumers.UnregisterEntitiesErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Failed to update VM files on datastore

com.vmware.vc.datastore.UpdateVmFilesFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Failed to upgrade vCenter agent

VcAgentUpgradeFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Failed to validate OVF descriptor on extension

com.vmware.vc.ovfconsumers.ValidateOstErrorEvent

Warning

yes

no

VMware vCenter

Veeam VMware: General Error from Upgrade process

ErrorUpgradeEvent

Error

yes

no

VMware vCenter

Veeam VMware: Host Add Failed

HostAddFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Host does not comply with profile

HostNonCompliantEvent

Warning

yes

no

VMware vCenter

Veeam VMware: Host DVS Configuration out of sync

OutOfSyncDvsHost

Warning

yes

no

VMware vCenter

Veeam VMware: Host Invalid Edition for License

InvalidEditionEvent

Error

yes

no

VMware vCenter

Veeam VMware: Host License Restricted

LicenseRestrictedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Host Reconnect Failed

HostReconnectionFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: Host-based Replication Error

hbr.primary.

Error

yes

no

VMware vCenter

Veeam VMware: iSCSI Boot Failure

IScsiBootFailureEvent

Warning

yes

no

VMware vCenter

Veeam VMware: License assignment failed

com.vmware.license.LicenseAssignFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: License Expiry

com.vmware.license.LicenseExpiryEvent

Error

yes

no

VMware vCenter

Veeam VMware: Problem with ESXi image

esx.audit.esximage.install.securityalert
OR
*problem.esximage*

Warning

yes

no

VMware vCenter

Veeam VMware: Scheduled Task Failed

ScheduledTask*Failed*

Warning

yes

no

VMware vCenter

Veeam VMware: Storage Capacity Error for VSAN Datastore

com.vmware.vc.vsan.DatastoreNoCapacityEvent

Error

yes

no

VMware vCenter

Veeam VMware: Storage DRS Invocation Failed in Datastore Cluster

com.vmware.vc.sdrs.StorageDrsInvocationFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: VC Agent uninstall failed on Host

VcAgentUninstallFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: VM Clone Failed

VmCloneFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: VM customization failed

Customization*Fail*

Error

yes

no

VMware vCenter

Veeam VMware: VM Deploy Failed

VmDeployFailedEvent

Error

yes

no

VMware vCenter

Veeam VMware: VM Register Failed

com.vmware.vc.vm.VmRegisterFailedEvent

Error

yes

no

VMware Virtual Machine

Veeam VMware: Collect VM events

yes

no

VMware Virtual Machine

Veeam VMware: Virtual Machine Error

com.vmware.vc.vcp.FtFailoverFailedEvent

com.vmware.vc.vcp.FtSecondaryRestartFailedEvent

com.vmware.vc.vcp.VmDatastoreFailedEvent

com.vmware.vc.vcp.VmNetworkFailedEvent

com.vmware.vc.vcp.VmPowerOffHangEvent

com.vmware.vc.vcp.VmRestartFailedEvent

com.vmware.vc.vcp.VmWaitForCandidateHostEvent

com.vmware.vc.vm.VmStateFailedToRevertToSnapshot

com.vmware.vc.VmDiskFailedToConsolidateEvent

VmDasUpdateErrorEvent

VmDateRolledBackEvent

VmDiskFailedEvent

VmFailedRelayoutEvent

VmFailedRelayoutOnVmfs2DatastoreEvent

VmFailedStartingSecondaryEvent

VmFailedToPowerOffEvent

VmFailedToPowerOnEvent

VmFailedToRebootGuestEvent

VmFailedToResetEvent

VmFailedToShutdownGuestEvent

VmFailedToStandbyGuestEvent

VmFailedToSuspendEvent

VmFailedUpdatingSecondaryConfig

VmFaultToleranceVmTerminatedEvent

VmInstanceUuidConflictEvent

VmMacConflictEvent

VmMessageErrorEvent

VmPrimaryFailoverEvent

VmReloadFromPathFailedEvent

VmSecondaryDisabledBySystemEvent

VmUpgradeFailedEvent

VmWwnConflictEvent

Error

yes

no

VMware Virtual Machine

Veeam VMware: Virtual Machine Warning

com.vmware.vc.ft.VmAffectedByDasDisabledEvent

com.vmware.vc.guestOperations.GuestOperationAuthFailure

com.vmware.vc.HA.AnsweredVmLockLostQuestionEvent

com.vmware.vc.HA.AnsweredVmTerminatePDLEvent

com.vmware.vc.HA.VmNotProtectedEvent

com.vmware.vc.HA.VmUnprotectedEvent

com.vmware.vc.vmam.VmAppHealthStateChangedEvent

com.vmware.vc.vmam.VmDasAppHeartbeatFailedEvent

DrsRuleViolationEvent

VmMaxFTRestartCountReached

VmMaxRestartCountReached

VmMessageWarningEvent

VmNoNetworkAccessEvent

VmRequirementsExceedCurrentEVCModeEvent

VmUnsupportedStartingEvent

VmWwnChangedEvent

Warning

yes

no

VMware vSphere Cluster

Veeam VMware: vSphere Cluster Error

com.vmware.vc.HA.DasTotalClusterFailureEvent

com.vmware.vc.HA.DasFailoverHostFailedEvent

com.vmware.vc.HA.DasHostCompleteDatastoreFailureEvent

com.vmware.vc.HA.DasHostCompleteNetworkFailureEvent

com.vmware.vc.HA.HostDasErrorEvent

com.vmware.vc.HA.HostHasNoMountedDatastores

com.vmware.vc.HA.HostHasNoSslThumbprint

com.vmware.vc.HA.HostIncompatibleWithHA

DasAgentUnavailableEvent

DasClusterIsolatedEvent

DrsInvocationFailedEvent

DrsResourceConfigureFailedEvent

esx.problem.migrate.vmotion.default.heap.create.failed

HostDasErrorEvent

HostNotInClusterEvent

MigrationErrorEvent

MigrationHostErrorEvent

MigrationResourceErrorEvent

Error

yes

no

VMware vSphere Cluster

Veeam VMware: vSphere Cluster Warning

ClusterOvercommittedEvent

com.vmware.vc.HA.CannotResetVmWithInaccessibleDatastore

com.vmware.vc.HA.ClusterContainsIncompatibleHosts

com.vmware.vc.HA.DasFailoverHostIsolatedEvent

com.vmware.vc.HA.DasFailoverHostPartitionedEvent

com.vmware.vc.HA.DasFailoverHostUnreachableEvent

com.vmware.vc.HA.DasHostMonitoringDisabledEvent

com.vmware.vc.HA.HeartbeatDatastoreNotSufficient

com.vmware.vc.HA.HostHasNoIsolationAddrsDefined

com.vmware.vc.HA.HostUnconfiguredWithProtectedVms

com.vmware.vc.HA.HostUnconfigureError

com.vmware.vc.HA.InvalidMaster

com.vmware.vc.HA.NotAllHostAddrsPingable

com.vmware.vc.HA.UserHeartbeatDatastoreRemoved

esx.problem.migrate.vmotion.server.pending.cnx.listen.socket.shutdown

MigrationHostWarningEvent

MigrationResourceWarningEvent

MigrationWarningEvent

Warning

yes

no

VMware vSphere Host

Veeam VMware: Collect HOST events

yes

no

VMware vSphere Host Security Profile

Veeam VMware: Collect vSphere Host Security Profile Events

esx.audit.net.firewall
OR
esx.audit.lockdownmode
OR
esx.audit.shell
OR
esx.audit.ssh
OR
esx.audit.uw.secpolicy
taskevent
firewall
OR
service

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Error

com.vmware.vc.vsan.HostCommunicationErrorEvent

esx.problem.vm.kill.unexpected.fault.failure

esx.problem.vm.kill.unexpected.forcefulPageRetire

esx.problem.vm.kill.unexpected.noSwapResponse

esx.problem.vm.kill.unexpected.vmtrack

esx.problem.vmsyslogd.remote.failure

esx.problem.vmsyslogd.storage.failure

esx.problem.vmsyslogd.storage.logdir.invalid

HostUpgradeFailedEvent

IncorrectHostInformationEvent

Error

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Hardware Error

esx.problem.apei.bert.memory.error.corrected

esx.problem.apei.bert.memory.error.fatal

esx.problem.apei.bert.memory.error.recoverable

esx.problem.apei.bert.pcie.error.corrected

esx.problem.apei.bert.pcie.error.fatal

esx.problem.apei.bert.pcie.error.recoverable

esx.problem.cpu.amd.mce.dram.disabled

esx.problem.cpu.intel.ioapic.listing.error

esx.problem.cpu.mce.invalid

esx.problem.cpu.smp.ht.invalid

esx.problem.cpu.smp.ht.numpcpus.max

Error

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Hardware Warning

esx.problem.cpu.smp.ht.partner.missing

esx.problem.hardware.acpi.interrupt.routing.device.invalid

esx.problem.hardware.acpi.interrupt.routing.pin.invalid

esx.problem.hardware.ioapic.missing

Warning

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Network Error

com.vmware.vc.vsan.NetworkMisConfiguredEvent

esx.problem.dhclient.lease.none

esx.problem.net.e1000.tso6.notsupported

esx.problem.net.firewall.config.failed

esx.problem.net.firewall.port.hookfailed

esx.problem.net.gateway.set.failed

esx.problem.net.vdl2.instance.initialization.fail

esx.problem.net.vdl2.instance.notexist

esx.problem.net.vdl2.mcastgroup.fail

esx.problem.net.vdl2.network.initialization.fail

esx.problem.net.vdl2.port.initialization.fail

esx.problem.net.vdl2.vmknic.fail

esx.problem.net.vdl2.vmknic.notexist

esx.problem.net.lacp.peer.noresponse

esx.problem.net.lacp.policy.incompatible

esx.problem.net.lacp.policy.linkstatus

esx.problem.net.lacp.uplink.fail.duplex

esx.problem.net.lacp.uplink.fail.speed

esx.problem.net.lacp.uplink.inactive

esx.problem.vsan.no.network.connectivity

HostExtraNetworksEvent

HostGetShortNameFailedEvent

HostMissingNetworksEvent

HostNoAvailableNetworksEvent

HostPrimaryAgentNotShortNameEvent

MtuMismatchEvent

NetworkRollbackEvent

TeamingMisMatchEvent

UplinkPortMtuNotSupportEvent

UplinkPortVlanUntrunkedEvent

vprob.net.e1000.tso6.notsupported

vprob.net.proxyswitch.port.unavailable

Error

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Network Warning

DuplicateIpDetectedEvent

DvsHostWentOutOfSyncEvent

esx.audit.net.vdl2.ip.change

esx.audit.net.vdl2.mappingtable.full

esx.audit.net.vdl2.route.change

esx.problem.dhclient.lease.offered.error

esx.problem.dhclient.lease.persistent.none

esx.problem.net.fence.port.badfenceid

esx.problem.net.fence.resource.limited

esx.problem.net.fence.switch.unavailable

esx.problem.net.heap.belowthreshold

esx.problem.net.migrate.unsupported.latency

esx.problem.net.portset.port.full

esx.problem.net.portset.port.vlan.invalidid

esx.problem.net.proxyswitch.port.unavailable

esx.problem.net.vmknic.ip.duplicate

esx.problem.net.vmnic.linkstate.flapping

esx.problem.net.vmnic.watchdog.reset

esx.problem.net.lacp.uplink.blocked

esx.problem.net.lacp.uplink.disconnected

esx.problem.net.lacp.uplink.transition.down

esx.problem.net.migrate.bindtovmk

esx.problem.net.uplink.mtu.failed

esx.problem.vsan.net.not.ready

esx.problem.vsan.net.redundancy.lost

esx.problem.vsan.net.redundancy.reduced

HostIpInconsistentEvent

HostIpToShortNameFailedEvent

HostIsolationIpPingFailedEvent

HostNoRedundantManagementNetworkEvent

HostShortNameInconsistentEvent

HostShortNameToIpFailedEvent

Warning

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Storage Error

com.vmware.vc.host.vFlash.SsdConfigurationFailedEvent

esx.problem.scsi.apd.event.descriptor.alloc.failed

esx.problem.storage.connectivity.lost

esx.problem.vmfs.ats.support.lost

esx.problem.vmfs.error.volume.is.locked

esx.problem.vmfs.heartbeat.unrecoverable

esx.problem.vmfs.lock.corruptondisk

esx.problem.vmfs.nfs.mount.connect.failed

esx.problem.vmfs.nfs.mount.limit.exceeded

esx.problem.vmfs.nfs.server.disconnect

esx.problem.vmfs.resource.corruptondisk

esx.problem.vmfs.volume.locked

esx.problem.scsi.device.limitreached

esx.problem.scsi.device.state.permanentloss.withreservationheld

esx.problem.scsi.scsipath.limitreached

esx.problem.storage.iscsi.target.permanently.lost

esx.problem.visorfs.failure

esx.problem.visorfs.ramdisk.inodetable.full

HostWwnConflictEvent

vprob.storage.connectivity.lost

vprob.vmfs.error.volume.is.locked

vprob.vmfs.heartbeat.unrecoverable

vprob.vmfs.lock.corruptondisk

vprob.vmfs.nfs.server.disconnect

vprob.vmfs.resource.corruptondisk

vprob.vmfs.volume.locked

Error

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Storage Warning

esx.problem.iorm.badversion

esx.problem.iorm.nonviworkload

esx.problem.scsi.device.close.failed

esx.problem.scsi.device.detach.failed

esx.problem.scsi.device.filter.attach.failed

esx.problem.scsi.device.io.bad.plugin.type

esx.problem.scsi.device.io.inquiry.failed

esx.problem.scsi.device.io.invalid.disk.qfull.value

esx.problem.scsi.device.io.qerr.change.config

esx.problem.scsi.device.io.qerr.changed

esx.problem.scsi.device.is.local.failed

esx.problem.scsi.device.is.pseudo.failed

esx.problem.scsi.device.is.ssd.failed

esx.problem.scsi.device.state.permanentloss

esx.problem.scsi.device.state.permanentloss.pluggedback

esx.problem.scsi.device.thinprov.atquota

esx.problem.scsi.unsupported.plugin.type

esx.problem.storage.apd.start

esx.problem.storage.apd.timeout

esx.problem.storage.connectivity.devicepor

esx.problem.storage.connectivity.pathpor

esx.problem.storage.connectivity.pathstatechanges

esx.problem.storage.iscsi.discovery.connect.error

esx.problem.storage.iscsi.discovery.login.error

esx.problem.storage.redundancy.degraded

esx.problem.storage.iscsi.target.connect.error

esx.problem.storage.iscsi.target.login.error

esx.problem.storage.redundancy.lost

esx.problem.vfat.filesystem.full.other

esx.problem.vfat.filesystem.full.scratch

esx.problem.visorfs.inodetable.full

esx.problem.visorfs.ramdisk.full

esx.problem.vmfs.extent.offline

esx.problem.vmfs.heartbeat.timedout

esx.problem.vmfs.journal.createfailed

HostWwnChangedEvent

vprob.storage.redundancy.degraded

vprob.storage.redundancy.lost

vprob.vmfs.extent.offline

vprob.vmfs.heartbeat.timedout

vprob.vmfs.journal.createfailed

Warning

yes

no

VMware vSphere Host

Veeam VMware: vSphere Host Error

esx.problem.application.core.dumped

esx.problem.coredump.unconfigured

esx.problem.host.coredump

esx.problem.hostd.core.dumped

esx.problem.ntpd.clock.correction.error

esx.problem.pageretire.selectedmpnthreshold.host.exceeded

esx.problem.pageretire.selectedmpnthreshold.kernel.exceeded

esx.problem.pageretire.selectedmpnthreshold.userclient.exceeded

esx.problem.pageretire.selectedmpnthreshold.userprivate.exceeded

esx.problem.pageretire.selectedmpnthreshold.usershared.exceeded

esx.problem.pageretire.selectedmpnthreshold.vmmclient.exceeded

esx.problem.syslog.config

esx.problem.syslog.nonpersistent

esx.problem.vmsyslogd.unexpected

esx.problem.vpxa.core.dumped

HostInventoryFullEvent

TimedOutHostOperationEvent

Error

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Alert Message

EventDisplayNumber Equal 900

Error

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Critical Message

EventDisplayNumber Equal 900

Error

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Debug Message

EventDisplayNumber Equal 900

Information

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Emergency Message

EventDisplayNumber Equal 900

Error

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Error Message

EventDisplayNumber Equal 900

Error

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Information Message

EventDisplayNumber Equal 900

Information

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Notice Message

EventDisplayNumber Equal 900

Warning

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Syslog daemon service shutdown

EventDisplayNumber Equal 900

(syslogd shutdown succeeded)

Warning

yes

no

VMware vSphere Host Syslog

Veeam vSphere Host Syslog: Warning Message

EventDisplayNumber Equal 900

Warning

yes

no

VMware vCenter

Veeam VMware: Collect VC events

no

no


Veeam Base Discovery

Target | Rule/Alert Name | Event ID | Alert Level | Enabled | Overrides
 | Veeam Management Pack: Operations Manager Agent proxy not enabled | 33333 () | Error | yes | no
Veeam Virtualization Extensions Service | Veeam VMware Collector: Error from Veeam Extensions Service | EventDisplayNumber Equal 1600 | Error | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Error from Discovery Script | VMwareTopologyDiscovery* EventDisplayNumber Equal 999 OR EventDisplayNumber Equal 1010 OR EventDisplayNumber Equal 1011 OR EventDisplayNumber Equal 1012 OR EventDisplayNumber Equal 1013 OR EventDisplayNumber Equal 1014 OR EventDisplayNumber Equal 1015 | Error | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service agent restart error | EventDisplayNumber Equal 6024 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service cannot load configuration | EventDisplayNumber Equal 1230 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service delay in event processing | 26017 () | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service dropped data | EventDisplayNumber Equal 4506 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service send queue exceeded | EventDisplayNumber Equal 2023 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service state change flow stalled | EventDisplayNumber Equal 5300 OR EventDisplayNumber Equal 5302 OR EventDisplayNumber Equal 5304 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service version store error | EventDisplayNumber Equal 623 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service workflows failed | EventDisplayNumber Equal 1103 | Warning | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Warning from Discovery Script | VMwareTopologyDiscovery* EventDisplayNumber Equal 999 OR EventDisplayNumber Equal 1010 OR EventDisplayNumber Equal 1011 OR EventDisplayNumber Equal 1012 OR EventDisplayNumber Equal 1013 OR EventDisplayNumber Equal 1014 OR EventDisplayNumber Equal 1015 | Warning | yes | no


Veeam VMware Integration

Target | Rule/Alert Name | Event ID | Alert Level | Enabled | Overrides
VMware vSphere Host Maintenance Mode Sync | Veeam VMware: vSphere Host Maintenance Mode Tracker Rule | EventDisplayNumber Equal 550 |  | yes | no
VMware vSphere Host | vSphere Maintenance Mode Sync - Duration Extension Rule | SV130 () |  | no | no


Event Monitors

This section describes Veeam MP for VMware event monitors.

Veeam VMware vCenter Monitoring

Veeam VMware Monitoring

Veeam Base Discovery

Veeam VMware Integration


Veeam VMware vCenter Monitoring

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
VMware vCenter Server | Veeam vCenter: VirtualCenter Service Monitor |  | Service NotRunning | Service Running | yes | no
VMware vCenter Server | Veeam vCenter: VC Web Service Monitor - webAccess |  | Service NotRunning | Service Running | no | yes
VMware vCenter Server | Veeam vCenter: VirtualCenter Management Webservices Monitor |  | Service NotRunning | Service Running | no | yes


Veeam VMware Monitoring

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
 | Veeam VMware: Connection lost to VMware vCenter server |  |  |  | yes | no
 | Veeam VMware: Connection lost to VMware vSphere Host server |  | EventDisplayNumber Equal 1401 -AND- $Target/Property[Type="VeeamVEBaseDisc!Veeam.Virt.Extensions.VMware.EMTarget"]/target$ | EventDisplayNumber Equal 1400 -AND- $Target/Property[Type="VeeamVEBaseDisc!Veeam.Virt.Extensions.VMware.EMTarget"]/target$ | yes | no
 | Veeam VMware: Run As Account for vCenter Failover functionality failed validation for one or more hosts | EventDisplayNumber Equal 993 |  | EventDisplayNumber Equal 993 | yes | no
VMware Cluster | Veeam VMware: Host HA Agent Error in vSphere Cluster |  | HostDasErrorEvent | HostDasOkEvent | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster Expired Virtual SAN license Alarm |  | AlarmStatusChangedEvent (Alarm*Expired Virtual SAN license*to red*) | AlarmStatusChangedEvent (Alarm*Expired Virtual SAN license*from red*) | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster HA failover in progress Alarm | AlarmStatusChangedEvent (Alarm*vSphere HA failover in progress*to yellow*) |  | AlarmStatusChangedEvent (Alarm*vSphere HA failover in progress*from yellow*) | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster HA master agent not found Alarm |  | AlarmStatusChangedEvent (Alarm*Cannot find vSphere HA master agent*to red*) | AlarmStatusChangedEvent (Alarm*Cannot find vSphere HA master agent*from red*) | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster Insufficient HA Failover Resources Alarm | AlarmStatusChangedEvent (Alarm*Insufficient vSphere HA failover resources*to yellow*) |  | AlarmStatusChangedEvent (Alarm*Insufficient vSphere HA failover resources*from yellow*) | yes | no
VMware Connections | Veeam VMware Collector: Failed to gather Host hardware data via CIM | SV120 (Cannot collect hardware status via direct-from-Host CIM method for hosts '${arg1}'. Veeam Collector will fall back to using vCenter for hardware data.) |  | SV121 (Collecting hardware status via direct-from-Host CIM method for '${hostname}' completed) | yes | no
VMware Connections | Veeam VMware Collector: VMware connection is unavailable | VP510 (No metrics obtained for ESX hosts ${arg0} ${arg1}.) | VP210 (Datacomm connection lost to VC target ${arg0}. The VMware API error returned was '${arg1}'. No performance data will be obtained from this source until connection can be restored.) | VP211 (Datacomm connection restored to VC target ${arg0}. Performance data collection will be resumed.) | yes | no
VMware Datastore | Veeam VMware: Datastore Capability Alarm | AlarmStatusChangedEvent (Alarm*Datastore Capability*to yellow*) | AlarmStatusChangedEvent (Alarm*Datastore Capability*to red*) | AlarmStatusChangedEvent (Alarm*Datastore Capability*to green*) | yes | no
VMware Datastore | Veeam VMware: Datastore Compliance Alarm | AlarmStatusChangedEvent (Alarm*Datastore Compliance*to yellow*) | AlarmStatusChangedEvent (Alarm*Datastore Compliance*to red*) | AlarmStatusChangedEvent (Alarm*Datastore Compliance*to green*) | yes | no
VMware Datastore | Veeam VMware: Datastore Usage on Disk Alarm | AlarmStatusChangedEvent (Alarm*Datastore usage on disk*) | AlarmStatusChangedEvent (Alarm*Datastore usage on disk*) | AlarmStatusChangedEvent (Alarm*Datastore usage on disk*) | yes | yes
VMware Datastore | Veeam VMware: Thin-provisioned volume capacity exceeded Alarm | AlarmStatusChangedEvent (Alarm*Thin-provisioned LUN capacity exceeded*) (Alarm*'Thin-provisioned volume capacity threshold exceeded.*) | AlarmStatusChangedEvent (Alarm*Thin-provisioned LUN capacity exceeded*) (Alarm*'Thin-provisioned volume capacity threshold exceeded.*) | AlarmStatusChangedEvent (Alarm*Thin-provisioned LUN capacity exceeded*) (Alarm*'Thin-provisioned volume capacity threshold exceeded.*) | yes | no
VMware Datastore Cluster | Veeam VMware: Datastore Cluster is out of space Alarm | AlarmStatusChangedEvent (Alarm*Datastore cluster is out of space* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | AlarmStatusChangedEvent (Alarm*Datastore cluster is out of space* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | AlarmStatusChangedEvent (Alarm*Datastore cluster is out of space* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | yes | yes
VMware Datastore Cluster | Veeam VMware: Datastore Cluster Storage DRS Recommendation Alarm |  | AlarmStatusChangedEvent (Alarm*Storage DRS recommendation* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | AlarmStatusChangedEvent (Alarm*Storage DRS recommendation* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | yes | no
VMware Datastore Cluster | Veeam VMware: SRM Consistency Group Violation Alarm |  | AlarmStatusChangedEvent (Alarm*SRM Consistency Group Violation* $Target/Property[Type="System!System.Entity"]/DisplayName$ *) | AlarmStatusChangedEvent (Alarm*SRM Consistency Group Violation* $Target/Property[Type="System!System.Entity"]/DisplayName$ *) | yes | no
VMware Datastore Cluster | Veeam VMware: Storage DRS Not Supported On Host Alarm |  | AlarmStatusChangedEvent (Alarm*Storage DRS not supported on host* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) (Alarm*Storage DRS is not supported on Host.* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | AlarmStatusChangedEvent (Alarm*Storage DRS not supported on host* on $Target/Property[Type="System!System.Entity"]/DisplayName$ changed*) | yes | no
VMware Distributed Virtual Switch | Veeam VMware: Network connectivity problem on DVSwitch | SV133 () |  | SV132 () | yes | no
VMware SIOC/SDRS Datastore | Veeam VMware: Pre-4.1 host connected to SIOC-enabled datastore Alarm |  | AlarmStatusChangedEvent (Alarm*Pre-4.1 host connected to SIOC-enabled datastore*) | AlarmStatusChangedEvent (Alarm*Pre-4.1 host connected to SIOC-enabled datastore*) | yes | no
VMware SIOC/SDRS Datastore | Veeam VMware: Unmanaged workload detected on SIOC-enabled datastore Alarm |  | AlarmStatusChangedEvent (Alarm*Unmanaged workload detected on SIOC-enabled datastore*) | AlarmStatusChangedEvent (Alarm*Unmanaged workload detected on SIOC-enabled datastore*) | yes | no
VMware vCenter | Veeam VMware: Datastore is in multiple datacenters Alarm | AlarmStatusChangedEvent (Alarm*Datastore is in multiple datacenters*to yellow*) | AlarmStatusChangedEvent (Alarm*Datastore is in multiple datacenters*to red*) | AlarmStatusChangedEvent (Alarm*Datastore is in multiple datacenters*to green*) | yes | no
VMware vCenter | Veeam VMware: Health status changed Alarm | AlarmStatusChangedEvent (Alarm*Health status changed*to yellow*) | AlarmStatusChangedEvent (Alarm*Health status changed*to red*) | AlarmStatusChangedEvent (Alarm*Health status changed*to green*) | yes | no
VMware vCenter | Veeam VMware: License Error Alarm | AlarmStatusChangedEvent (Alarm*License Error*to yellow*) | AlarmStatusChangedEvent (Alarm*License Error*to red*) | AlarmStatusChangedEvent (Alarm*License Error*to green*) | yes | no
VMware vCenter | Veeam VMware: Repeated Login Failures | BadUsernameSessionEvent OR NoAccessUserEvent RepeatedEventCount: 10 RepeatedWaitInSeconds: 300 |  | AutoResolveInSeconds: 86400 | yes | no
VMware vCenter | Veeam VMware: The host license edition is not compatible with the vCenter Server license edition Alarm |  | AlarmStatusChangedEvent (Alarm*The host license edition is not compatible with the vCenter Server license edition*to red*) | AlarmStatusChangedEvent (Alarm*The host license edition is not compatible with the vCenter Server license edition*from red*) | yes | no
VMware vCenter | Veeam VMware: vCenter Health Status Monitoring Alarm | AlarmStatusChangedEvent (Alarm*Health status monitoring*to yellow*) | AlarmStatusChangedEvent (Alarm*Health status monitoring*to red*) | AlarmStatusChangedEvent (Alarm*Health status monitoring*to green*) | yes | no
VMware vCenter | Veeam VMware: vCenter License Capacity Monitoring Alarm |  | AlarmStatusChangedEvent (Alarm*License capacity monitoring*to red*) | AlarmStatusChangedEvent (Alarm*License capacity monitoring*from red*) | yes | yes
VMware vCenter | Veeam VMware: vCenter License Inventory Monitoring Alarm |  | AlarmStatusChangedEvent (Alarm*License inventory monitoring*to red*) | AlarmStatusChangedEvent (Alarm*License inventory monitoring*from red*) | yes | no
VMware vCenter | Veeam VMware: vCenter License User Threshold Alarm |  | AlarmStatusChangedEvent (Alarm*License user threshold monitoring*to red*) | AlarmStatusChangedEvent (Alarm*License user threshold monitoring*from red*) | yes | no
VMware Virtual Machine | Veeam VMware: Migration Error Alarm | AlarmStatusChangedEvent (Alarm*Migration Error*to yellow*) | AlarmStatusChangedEvent (Alarm*Migration Error*to red*) | AlarmStatusChangedEvent (Alarm*Migration Error*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Consolidation Needed status Alarm | AlarmStatusChangedEvent (Alarm*Virtual machine Consolidation Needed status*to yellow*) | AlarmStatusChangedEvent (Alarm*Virtual machine Consolidation Needed status*to red*) | AlarmStatusChangedEvent (Alarm*Virtual machine Consolidation Needed status*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Error Alarm | AlarmStatusChangedEvent (Alarm*Virtual Machine Error*to yellow*) | AlarmStatusChangedEvent (Alarm*Virtual Machine Error*to red*) | AlarmStatusChangedEvent (Alarm*Virtual Machine Error*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: VM DRS Rule Violation | DrsRuleViolationEvent | DrsRuleComplianceEvent |  | yes | no
VMware Virtual Machine | Veeam VMware: VM storage compliance Alarm | AlarmStatusChangedEvent (Alarm*VM storage compliance alarm*to yellow*) | AlarmStatusChangedEvent (Alarm*VM storage compliance alarm*to red*) | AlarmStatusChangedEvent (Alarm*VM storage compliance alarm*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: vShield Endpoint SVM status Alarm | AlarmStatusChangedEvent (Alarm*vShield Endpoint SVM*to yellow*) | AlarmStatusChangedEvent (Alarm*vShield Endpoint SVM*to red*) | AlarmStatusChangedEvent (Alarm*vShield Endpoint SVM*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: vShield VirtualMachine Alarm | AlarmStatusChangedEvent (Alarm*vShield VirtualMachine*to yellow*) | AlarmStatusChangedEvent (Alarm*vShield VirtualMachine*to red*) | AlarmStatusChangedEvent (Alarm*vShield VirtualMachine*to green*) | yes | no
VMware Virtual Machine | Veeam VMware: vSphere HA failover failed Alarm |  | AlarmStatusChangedEvent (Alarm*vSphere HA virtual machine failover failed*to red*) | AlarmStatusChangedEvent (Alarm*vSphere HA virtual machine failover failed*from red*) | yes | no
VMware Virtual Machine | Veeam VMware: vSphere HA virtual machine monitoring Alarm | AlarmStatusChangedEvent (Alarm*vSphere HA virtual machine monitoring action*to yellow*) | AlarmStatusChangedEvent (Alarm*vSphere HA virtual machine monitoring error*to red*) | AlarmAcknowledgedEvent (Acknowledged alarm*vSphere HA virtual machine monitoring action*) (Acknowledged alarm*vSphere HA virtual machine monitoring error*) | yes | no
VMware Virtual Machine (Fault Tolerant) | Veeam VMware: No Compatible Host for Secondary VM Alarm | AlarmStatusChangedEvent (Alarm*No compatible host for Secondary VM*to yellow*) | AlarmStatusChangedEvent (Alarm*No compatible host for Secondary VM*to red*) | AlarmStatusChangedEvent (Alarm*No compatible host for Secondary VM*to green*) | yes | no
VMware Virtual Machine (Fault Tolerant) | Veeam VMware: Timed Out Starting Secondary VM Alarm | AlarmStatusChangedEvent (Alarm*Timed out starting Secondary VM*to yellow*) | AlarmStatusChangedEvent (Alarm*Timed out starting Secondary VM*to red*) | AlarmStatusChangedEvent (Alarm*Timed out starting Secondary VM*to green*) | yes | no
VMware Virtual Machine (Fault Tolerant) | Veeam VMware: Virtual Machine Fault Tolerance State Changed Alarm | AlarmStatusChangedEvent (Alarm*Virtual machine Fault Tolerance state changed*to yellow*) | AlarmStatusChangedEvent (Alarm*Virtual machine Fault Tolerance state changed*to red*) | AlarmStatusChangedEvent (Alarm*Virtual machine Fault Tolerance state changed*to green*) | yes | no
VMware Virtual Machine (Fault Tolerant) | Veeam VMware: Virtual Machine Fault Tolerance vLockstep Interval Status Changed Alarm | AlarmStatusChangedEvent (Alarm*Virtual Machine Fault Tolerance vLockStep interval Status Changed*to yellow*) | AlarmStatusChangedEvent (Alarm*Virtual Machine Fault Tolerance vLockStep interval Status Changed*to red*) | AlarmStatusChangedEvent (Alarm*Virtual Machine Fault Tolerance vLockStep interval Status Changed*to green*) | yes | no
VMware Virtual Switch | Veeam VMware: Network connectivity problem on VSwitch | SV138 () |  | SV139 () | yes | no
VMware vSphere Host | Veeam VMware: Host Baseboard Management Controller Status Alarm | AlarmStatusChangedEvent (Alarm*Host Baseboard Management Controller status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host Baseboard Management Controller status*to red*) | AlarmStatusChangedEvent (Alarm*Host Baseboard Management Controller status*to green*) | yes | yes
VMware vSphere Host | Veeam VMware: Host connection failure Alarm | AlarmStatusChangedEvent (Alarm*Host connection failure*to yellow*) | AlarmStatusChangedEvent (Alarm*Host connection failure*to red*) | AlarmStatusChangedEvent (Alarm*Host connection failure*to green*) | yes | no
VMware vSphere Host | Veeam VMware: Host Connection Status | HostDisconnectedEvent|HostConnectionLostEvent|HostCnxFailed* | HostConnectedEvent |  | yes | no
VMware vSphere Host | Veeam VMware: Host CPU Usage Alarm | AlarmStatusChangedEvent (Alarm*Host CPU usage*to yellow*) | AlarmStatusChangedEvent (Alarm*Host CPU usage*to red*) | AlarmStatusChangedEvent (Alarm*Host CPU usage*to green*) | yes | yes
VMware vSphere Host | Veeam VMware: Host error Alarm | AlarmStatusChangedEvent (Alarm*Host error*to yellow*) | AlarmStatusChangedEvent (Alarm*Host error*to red*) | AlarmStatusChangedEvent (Alarm*Host error*to green*) | yes | no
VMware vSphere Host | Veeam VMware: Host IPMI System Event Log Status Alarm | AlarmStatusChangedEvent (Alarm*Host IPMI System Event Log status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host IPMI System Event Log status*to red*) | AlarmStatusChangedEvent (Alarm*Host IPMI System Event Log status*to green*) | yes | yes
VMware vSphere Host | Veeam VMware: Host Memory Usage Alarm | AlarmStatusChangedEvent (Alarm*Host memory usage*to yellow*) | AlarmStatusChangedEvent (Alarm*Host memory usage*to red*) | AlarmStatusChangedEvent (Alarm*Host memory usage*to green*) | yes | yes
VMware vSphere Host | Veeam VMware: Host Service Console Swap Rates Alarm | AlarmStatusChangedEvent (Alarm*Host service console swap rates*to yellow*) | AlarmStatusChangedEvent (Alarm*Host service console swap rates*to red*) | AlarmStatusChangedEvent (Alarm*Host service console swap rates*to green*) | yes | yes
VMware vSphere Host | Veeam VMware: Host SSD capacity exceeds the licensed limit for Virtual SAN Alarm | AlarmStatusChangedEvent (Alarm*Host SSD capacity exceeds the licensed limit for Virtual SAN*to yellow*) | AlarmStatusChangedEvent (Alarm*Host SSD capacity exceeds the licensed limit for Virtual SAN*to red*) | AlarmStatusChangedEvent (Alarm*Host SSD capacity exceeds the licensed limit for Virtual SAN*to green*) | yes | no
VMware vSphere Host | Veeam VMware: Host vendor provider registration Alarm | AlarmStatusChangedEvent (Alarm*Host vendor provider registration*to yellow*) | AlarmStatusChangedEvent (Alarm*Host vendor provider registration*to red*) | AlarmStatusChangedEvent (Alarm*Host vendor provider registration*to green*) | yes | no
VMware vSphere Host | Veeam VMware: Host vSphere Flash resource status Alarm | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource status*to red*) | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource status*to green*) | yes | no
VMware vSphere Host | Veeam VMware: Host vSphere Flash resource usage Alarm | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource usage*to yellow*) | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource usage*to red*) | AlarmStatusChangedEvent (Alarm*Host vSphere Flash resource usage*to green*) | yes | no
VMware vSphere Host | Veeam VMware: vShield endpoint host status Alarm | AlarmStatusChangedEvent (Alarm*vShield endpoint host status*to yellow*) | AlarmStatusChangedEvent (Alarm*vShield endpoint host status*to red*) | AlarmStatusChangedEvent (Alarm*vShield endpoint host status*to green*) | yes | no
VMware vSphere Host | Veeam VMware: vSphere HA Host Status Alarm |  | AlarmStatusChangedEvent (Alarm*vSphere HA host status*to red*) | AlarmStatusChangedEvent (Alarm*vSphere HA host status*from red*) | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Exit standby error Alarm | AlarmStatusChangedEvent (Alarm*Exit standby*to yellow*) | AlarmStatusChangedEvent (Alarm*Exit standby*to red*) | AlarmStatusChangedEvent (Alarm*Exit standby*to green*) | yes | no
VMware vSphere Host Fan Sensors | Veeam VMware: Host Hardware Fan Status Alarm | AlarmStatusChangedEvent (Alarm*Host hardware fan status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host hardware fan status*to red*) | AlarmStatusChangedEvent (Alarm*Host hardware fan status*to green*) | yes | yes
VMware vSphere Host Fan Sensors | Veeam VMware: vSphere Host Hardware Fan Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host Hardware Sensors | Veeam VMware: vSphere Host Hardware Sensor Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host Hardware Sensors Container | Veeam VMware: Host Hardware System Board Status Alarm | AlarmStatusChangedEvent (Alarm*Host hardware system board status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host hardware system board status*to red*) | AlarmStatusChangedEvent (Alarm*Host hardware system board status*to green*) | yes | yes
VMware vSphere Host Hardware Sensors Container | Veeam VMware: Status of Other Host Hardware Objects Alarm | AlarmStatusChangedEvent (Alarm*Status of other host hardware objects*to yellow*) | AlarmStatusChangedEvent (Alarm*Status of other host hardware objects*to red*) | AlarmStatusChangedEvent (Alarm*Status of other host hardware objects*to green*) | yes | yes
VMware vSphere Host HBA Container | Veeam VMware: Host Storage connectivity problem | SV135 () | SV135 () | SV136 () | yes | no
VMware vSphere Host Local Disk Sensors | Veeam VMware: Host Storage Status Alarm | AlarmStatusChangedEvent (Alarm*Host storage status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host storage status*to red*) | AlarmStatusChangedEvent (Alarm*Host storage status*to green*) | yes | yes
VMware vSphere Host Local Disk Sensors | Veeam VMware: vSphere Host Hardware Disk Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host Network Card | Veeam VMware: Host Network Adapter Status |  | vprob.net.redundancy.degraded OR vprob.net.redundancy.lost OR esx.problem.net.redundancy.lost OR esx.problem.net.redundancy.degraded OR esx.problem.net.dvport.redundancy.degraded OR esx.problem.net.dvport.redundancy.lost OR vprob.net.connectivity.lost OR esx.problem.net.connectivity.lost OR esx.problem.net.dvport.connectivity.lost OR esx.problem.net.vmnic.linkstate.down (*Physical NIC $Target/Property[Type="System!System.Entity"]/DisplayName$ is down*) (*Physical NIC $Target/Property[Type="System!System.Entity"]/DisplayName$ linkstate is down*) | esx.clear.net.redundancy.restored OR esx.clear.net.dvport.redundancy.restored OR esx.clear.net.connectivity.restored OR esx.clear.net.dvport.connectivity.restored OR esx.clear.net.vmnic.linkstate.up (*Physical NIC $Target/Property[Type="System!System.Entity"]/DisplayName$ is up*) (*Physical NIC $Target/Property[Type="System!System.Entity"]/DisplayName$ linkstate is up*) | yes | yes
VMware vSphere Host NIC Container | Veeam VMware: Host Network Connectivity Lost Alarm |  | AlarmStatusChangedEvent (Alarm*Network connectivity lost*to red*) | AlarmStatusChangedEvent (Alarm*Network connectivity lost*from red*) | yes | yes
VMware vSphere Host NIC Container | Veeam VMware: Host Network Uplink Redundancy Lost Alarm |  | AlarmStatusChangedEvent (Alarm*Network uplink redundancy lost*to red*) | AlarmStatusChangedEvent (Alarm*Network uplink redundancy lost*from red*) | yes | yes
VMware vSphere Host NIC Container | Veeam VMware: VMKernel network not configured correctly Alarm | AlarmStatusChangedEvent (Alarm*VMKernel NIC not configured correctly*to yellow*) | AlarmStatusChangedEvent (Alarm*VMKernel NIC not configured correctly*to red*) | AlarmStatusChangedEvent (Alarm*VMKernel NIC not configured correctly*to green*) | yes | no
VMware vSphere Host Power Sensors | Veeam VMware: Host Battery Status Alarm | AlarmStatusChangedEvent (Alarm*Host battery status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host battery status*to red*) | AlarmStatusChangedEvent (Alarm*Host battery status*to green*) | yes | yes
VMware vSphere Host Power Sensors | Veeam VMware: Host Hardware Power Status Alarm | AlarmStatusChangedEvent (Alarm*Host hardware power status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host hardware power status*to red*) | AlarmStatusChangedEvent (Alarm*Host hardware power status*to green*) | yes | yes
VMware vSphere Host Power Sensors | Veeam VMware: Host Hardware Voltage Alarm | AlarmStatusChangedEvent (Alarm*Host hardware voltage*to yellow*) | AlarmStatusChangedEvent (Alarm*Host hardware voltage*to red*) | AlarmStatusChangedEvent (Alarm*Host hardware voltage*to green*) | yes | yes
VMware vSphere Host Power Sensors | Veeam VMware: vSphere Host Hardware Power Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host Processor Sensors | Veeam VMware: Host Processor Status Alarm | AlarmStatusChangedEvent (Alarm*Host processor status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host processor status*to red*) | AlarmStatusChangedEvent (Alarm*Host processor status*to green*) | yes | yes
VMware vSphere Host Processor Sensors | Veeam VMware: vSphere Host Hardware Processor Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host RAM DIMM Sensors | Veeam VMware: Host Memory Status Alarm | AlarmStatusChangedEvent (Alarm*Host memory status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host memory status*to red*) | AlarmStatusChangedEvent (Alarm*Host memory status*to green*) | yes | yes
VMware vSphere Host RAM DIMM Sensors | Veeam VMware: vSphere Host Hardware Ram DIMM Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host Temperature Sensors | Veeam VMware: Host Hardware Temperature Status Alarm | AlarmStatusChangedEvent (Alarm*Host hardware temperature status*to yellow*) | AlarmStatusChangedEvent (Alarm*Host hardware temperature status*to red*) | AlarmStatusChangedEvent (Alarm*Host hardware temperature status*to green*) | yes | yes
VMware vSphere Host Temperature Sensors | Veeam VMware: vSphere Host Hardware Temperature Sensor Status | EventDisplayNumber Equal 101 | EventDisplayNumber Equal 102 | EventDisplayNumber Equal 100 | yes | no
VMware vSphere Host VMHBA | Veeam VMware: Host HBA Path Status |  | SV135 () | SV135 () | yes | yes


Veeam Base Discovery

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
Monitoring Group | Veeam VMware Collector: Monitoring Group has no available Collector(s) |  | EventDisplayNumber Equal 1305 AND $Target/Property[Type="System!System.Entity"]/DisplayName$ | EventDisplayNumber Equal 1207 | yes | no
Veeam Collector Heartbeat | Veeam VMware Collector: Heartbeat Status of Collector Service |  | EventDisplayNumber Equal 1203 | EventDisplayNumber Equal 1207 | yes | no
Veeam Virtualization Extensions Service | Veeam Management Pack: License Alert | EventDisplayNumber Equal 1100 | EventDisplayNumber Equal 1101 | EventDisplayNumber Equal 1103 | yes | no
Veeam Virtualization Extensions Service | Veeam VMware Collector: Extensions Service status |  | Service NotRunning | Service Running | yes | no
Veeam Virtualization Extensions Service | Veeam VMware Collector: Licensed socket count exceeded |  | EventDisplayNumber Equal 1102 | EventDisplayNumber Equal 1104 | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Application Error |  |  | TimerWaitInSeconds: 86400 | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Application Warning |  |  | TimerWaitInSeconds: 86400 | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Cannot connect to Veeam Extensions service |  | SV222 (Failed to connect to Virtualization Extensions '${arg0}' at '${arg1}'.) | SV223 (Connection to Virtualization Extensions '${arg0}' has been restored.) | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Service status |  | Service NotRunning | Service Running | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: VMware events have been throttled |  | VC220 (The internal events queue for the Veeam VMware Collector has reached its limit. vCenter ${arg0} has generated more than the current Collector capacity of ${arg1} events per 30 seconds, therefore some events could be lost. Check for an event storm in vCenter. If a large number of events is a regular situation for your environment, use instructions on changing the event queue size.) | TimerWaitInSeconds: 86400 | yes | no


Veeam VMware Integration

Target | Monitor/Alert Name | Warning event ID | Error event ID | Close Event ID | Enabled | Overrides
VMware vSphere Host Maintenance Mode Sync | Veeam VMware: vSphere Host Maintenance Mode Tracker |  |  |  | yes | no


Performance Monitors

This section describes Veeam MP for VMware performance monitors.

Veeam VMware Monitoring

Veeam Base Discovery


Veeam VMware Monitoring

Target | Monitor/Alert Name | Metric Class | Metric Name | Threshold (Warning) | Threshold (Error) | Enabled | Overrides
 | Veeam VMware: Run As Account for vCenter Failover functionality is not configured |  |  | - | - | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster CPU Overcommit Analysis |  |  | 150 | - | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster CPU Usage Analysis | Cluster | cpuUsedPct | 90 | 95 | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster Memory Overcommit Analysis | Cluster | memoryPressure | 150 | - | yes | no
VMware Cluster | Veeam VMware: vSphere Cluster Memory Usage Analysis | Cluster | memoryUsedPct | 90 | 95 | yes | no
VMware Datastore | Veeam VMware: Datastore Free Space Analysis |  |  | - | - | yes | no
VMware Datastore | Veeam VMware: Datastore Latency Analysis | DatastoreStats | maxDeviceLatency | - | - | yes | no
VMware Datastore | Veeam VMware: Datastore Provisioning Analysis |  |  | - | - | yes | no
VMware Datastore | Veeam VMware: Datastore Unknown Files Analysis |  |  | - | - | yes | no
VMware Datastore Cluster | Veeam VMware: Datastore Cluster Free Space Analysis |  |  | - | - | yes | no
VMware Resource Pool | Veeam VMware: Resource Pool CPU Usage Analysis |  |  | - | - | yes | no
VMware Resource Pool | Veeam VMware: Resource Pool Memory Usage Analysis |  |  | - | - | yes | no
VMware Virtual Application | Veeam VMware: vAPP CPU Usage Analysis |  |  | - | - | yes | no
VMware Virtual Application | Veeam VMware: vAPP Memory Usage Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Compute Latency Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine CPU Scheduling Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine CPU Usage Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Disk Space Analysis |  |  | NaN | NaN | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Memory Ballooning and Swapping Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Memory Usage Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Snapshot Usage Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Storage Latency Analysis |  |  | - | - | yes | no
VMware Virtual Machine | Veeam VMware: Virtual Machine Uptime Monitor |  |  | - | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host CPU Overcommit Analysis |  |  | - | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host CPU Ready Time Analysis | HostStats | cpuReadyPct | 15 | 25 | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host CPU Usage Analysis | HostStats | cpuUsedPct | 90 | 95 | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Kernel Latency Analysis |  |  | - | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Memory Ballooning Analysis | HostStats | memoryBalloonPct | 50 | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Memory Overcommit Analysis | HostStats | memoryPressure | 150 | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Memory Swapping Analysis | HostStats | memorySwapRate | - | 1,000 | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Memory Usage Analysis |  |  | - | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Network Packet Loss Analysis | HostStats | droppedPacketsTotal | - | - | yes | no
VMware vSphere Host | Veeam VMware: vSphere Host Storage Commands Failed Analysis |  |  | - | - | yes | no
VMware vSphere Host COS Partition | Veeam VMware: vSphere Host COS Partition Free Space Analysis |  |  | - | - | yes | no


Veeam Base Discovery

Target | Monitor/Alert Name | Metric Class | Metric Name | Threshold (Warning) | Threshold (Error) | Enabled | Overrides
Veeam VMware Collector Service | Veeam VMware Collector: Health Service (Monitoring Host) Handle Count threshold |  |  | - | - | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service (Monitoring Host) Private Bytes threshold |  |  | - | - | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service Handle Count threshold |  |  | - | - | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service Private Bytes threshold |  |  | - | - | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service recommended configuration monitor |  |  | - | - | yes | no
Veeam VMware Collector Service | Veeam VMware Collector: Health Service recommended workflow load monitor |  |  | - | - | yes | no


Dependency Monitors

This section describes Veeam MP for VMware dependency monitors.

Veeam VMware Monitoring

Veeam Base Discovery


Veeam VMware Monitoring

Target | Monitor/Alert Name | Category | Parent Monitor | Member Monitor | Enabled | Overrides
 | Rollup VMware Connection Availability to VMware Collector | Availability | Availability | Availability | yes | no
 | Rollup VMware Connection Configuration to VMware Collector | Availability | Configuration | Configuration | yes | no
VM Container | Rollup VMGuest Availability to VMGuestContainer | Availability | Availability | Availability | yes | no
VM Container | Rollup VMGuest Configuration to VMGuestContainer | Configuration | Configuration | Configuration | yes | no
VM Container | Rollup VMGuest Performance to VMGuestContainer | Performance | Performance | Performance | yes | no
VMware Cluster | Rollup vSphere Host Availability to Cluster | Availability | Availability | Availability | yes | no
VMware Cluster | Rollup vSphere Host Configuration to Cluster | Configuration | Configuration | Configuration | yes | no
VMware Cluster | Rollup vSphere Host Performance to Cluster | Performance | Performance | Performance | yes | no
VMware Clusters | Rollup Cluster Availability to ClusterGroup | Availability | Availability | Availability | yes | no
VMware Clusters | Rollup Cluster Configuration to ClusterGroup | Configuration | Configuration | Configuration | yes | no
VMware Clusters | Rollup Cluster Performance to ClusterGroup | Performance | Performance | Performance | yes | no
VMware Datacenter | Rollup Cluster Availability to Datacenter | Availability | Availability | Availability | yes | no
VMware Datacenter | Rollup Cluster Configuration to Datacenter | Configuration | Configuration | Configuration | yes | no
VMware Datacenter | Rollup Cluster Performance to Datacenter | Performance | Performance | Performance | yes | no
VMware Datacenter | Rollup Host Availability to Datacenter | Availability | Availability | Availability | yes | no
VMware Datacenter | Rollup Host Configuration to Datacenter | Configuration | Configuration | Configuration | yes | no
VMware Datacenter | Rollup Host Performance to Datacenter | Performance | Performance | Performance | yes | no
VMware Datacenter - Network | Rollup VMware Distributed Virtual Switch Availability to VMware Datacenter - Network | Availability | Availability | Availability | yes | no
VMware Datacenter - Network | Rollup VMware Virtual Switch Availability to VMware Datacenter - Network | Availability | Availability | Availability | yes | no
VMware Datacenter - Storage | Rollup Datastore Cluster Availability to Datacenter - Storage | Availability | Availability | Availability | yes | no
VMware Datacenter - Storage | Rollup Datastore Cluster Configuration to Datacenter - Storage | Configuration | Configuration | Configuration | yes | no
VMware Datacenter - Storage | Rollup Datastore Cluster Performance to Datacenter - Storage | Performance | Performance | Performance | yes | no
VMware Datacenter - Storage | Rollup Shared Datastore Availability to VMware Datacenter - Storage | Availability | Availability | Availability | yes | no
VMware Datacenter - Storage | Rollup Shared Datastore Configuration to VMware Datacenter - Storage | Configuration | Configuration | Configuration | yes | no
VMware Datacenter - Storage | Rollup Shared Datastore Performance to VMware Datacenter - Storage | Performance | Performance | Performance | yes | no
VMware Datacenters | Rollup Datacenter Availability to Group | Availability | Availability | Availability | yes | no
VMware Datacenters | Rollup Datacenter Configuration to Group | Configuration | Configuration | Configuration | yes | no
VMware Datacenters | Rollup Datacenter Performance to Group | Performance | Performance | Performance | yes | no
VMware Datastore Cluster | Rollup Shared Datastore Availability to Datastore Cluster | Availability | Availability | Availability | yes | no
VMware Datastore Cluster | Rollup Shared Datastore Configuration to Datastore Cluster | Configuration | Configuration | Configuration | yes | no
VMware Datastore Cluster | Rollup Shared Datastore Performance to Datastore Cluster | Performance | Performance | Performance | yes | no
VMware Datastores | Rollup Datastore to Datastore Group | Availability | Availability | Entity | yes | no
VMware Resource Pool | Rollup Resource Pool to parent Pool | Configuration | Configuration | Entity | yes | no
VMware Resource Pool | Rollup Virtual Application to parent Resource Pool | Configuration | Configuration | Entity | yes | no
VMware Resource Pool | Rollup VMware Virtual Machine availability to VMware Resource Pool | Availability | Availability | Availability | yes | no
VMware Resource Pool | Rollup VMware Virtual Machine configuration to VMware Resource Pool | Configuration | Configuration | Configuration | yes | no
VMware Resource Pool | Rollup VMware Virtual Machine performance to VMware Resource Pool | Performance | Performance | Performance | yes | no
VMware Resource Pools | Rollup Resource Pool Configuration to ResourcePoolGroup | Configuration | Configuration | Configuration | yes | no
VMware vCenter | Rollup Datacenter Availability to vCenter Events | Availability | Availability | Availability | yes | no
VMware vCenter | Rollup Datacenter Configuration to vCenter Events | Configuration | Configuration | Configuration | yes | no
VMware vCenter | Rollup Datacenter Performance to vCenter Events | Performance | Performance | Performance | yes | no
VMware vCenter - Network | Rollup VMware Datacenter - Network Availability to VMware vCenter - Network | Availability | Availability | Availability | yes | no
VMware vCenter - Network Group | Rollup VMware vCenter - Network Availability to VMware vCenter - Network Group | Availability | Availability | Availability | yes | no
VMware vCenter - Storage | Rollup Datacenter - Storage Availability to VMware vCenter - Storage | Availability | Availability | Availability | yes | no
VMware vCenter - Storage | Rollup Datacenter - Storage Configuration to VMware vCenter - Storage | Configuration | Configuration | Configuration | yes | no
VMware vCenter - Storage | Rollup Datacenter - Storage Performance to VMware vCenter - Storage | Performance | Performance | Performance | yes | no
VMware vCenter - Storage Group | Rollup VMware vCenter - Storage Availability to VMware vCenter - Storage Group | Availability | Availability | Availability | yes | no
VMware vCenter - Storage Group | Rollup VMware vCenter - Storage Configuration to VMware vCenter - Storage Group | Configuration | Configuration | Configuration | yes | no
VMware vCenter - Storage Group | Rollup VMware vCenter - Storage Performance to VMware vCenter - Storage Group | Performance | Performance | Performance | yes | no
VMware vCenter Group | Rollup vCenter Events Availability to Group | Availability | Availability | Availability | yes | no
VMware vCenter Group | Rollup vCenter Events Configuration to Group | Configuration | Configuration | Configuration | yes | no
VMware vCenter Group | Rollup vCenter Events Performance to Group | Performance | Performance | Performance | yes | no
VMware vCenter Group | Rollup vCenter Events Security State to Group | Security | Security | Security | yes | no
VMware Virtual Application | Rollup Resource Pool to parent Virtual Application | Configuration | Configuration | Entity | yes | no
VMware Virtual Application | Rollup Virtual Application to parent Virtual Application | Configuration | Configuration | Entity | yes | no
VMware Virtual Application | Rollup VMware Virtual Machine availability to VMware Virtual Application | Availability | Availability | Availability | yes | no
VMware Virtual Application | Rollup VMware Virtual Machine configuration to VMware Virtual Application | Configuration | Configuration | Configuration | yes | no
VMware Virtual Application | Rollup VMware Virtual Machine performance to VMware Virtual Application | Performance | Performance | Performance | yes | no
VMware Virtual Applications | Rollup Virtual Application Availability to VirtualApplicationGroup | Availability | Availability | Availability | yes | no
VMware Virtual Applications | Rollup Virtual Application Configuration to VirtualApplicationGroup | Configuration | Configuration | Configuration | yes | no
VMware Virtual Applications | Rollup Virtual Application Performance to VirtualApplicationGroup | Performance | Performance | Performance | yes | no
VMware Virtual Machine Group | Rollup VMGuest Performance to VMGuestGroup | Performance | Performance | Performance | yes | no
VMware Virtual Machine Group | Rollup VMGuests Availability to VMGuestGroup | Availability | Availability | Availability | yes | no
VMware Virtual Machine Group | Rollup VMGuests Configuration to VMGuestGroup | Configuration | Configuration | Configuration | yes | no
VMware vSphere Host | Rollup HBACONTAINER to HOST Availability | Availability | Availability | Availability | yes | no
VMware vSphere Host | Rollup NETWORK to HOST Availability | Availability | Availability | Availability | yes | no
VMware vSphere Host | Rollup SENSORCONTAINER Configuration to VMHOST | Configuration | Configuration | Configuration | yes | no
VMware vSphere Host COS Partitions | Rollup COS PARTITION to STORAGE | Availability | Availability | Availability | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup FANCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup MEMORYCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup POWERCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup PROCESSORSCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup SENSORSCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup STORAGECONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host Hardware Sensors Container | Rollup TEMPCONTAINER to SENSORCONTAINER | Configuration | Configuration | Entity | yes | no
VMware vSphere Host HBA Container | Rollup HBA to HBACONTAINER Availability | Availability | Availability | Availability | yes | no
VMware vSphere Host NIC Container | Rollup NET to NETCONTAINER Availability | Availability | Availability | Availability | yes | no
VMware vSphere Hosts | Rollup Host Availability to HostGroup | Availability | Availability | Availability | yes | no
VMware vSphere Hosts | Rollup Host Configuration to HostGroup | Configuration | Configuration | Configuration | yes | no
VMware vSphere Hosts | Rollup Host Performance to HostGroup | Performance | Performance | Performance | yes | no


Veeam Base Discovery

Target | Monitor/Alert Name | Category | Parent Monitor | Member Monitor | Enabled | Overrides
Monitoring Group | Rollup Collector Heartbeat status to Monitoring Group | Availability | Availability | Availability | yes | no
Monitoring Group | Rollup VMware Connection Availability to Monitoring Group |  | Availability | Availability | yes | no
Veeam Virtualization Extensions Service | Rollup Monitoring Group status to VES |  | Availability | Availability | yes | no
Veeam Virtualization Extensions Service Group | Rollup Veeam Extensions Service Availability to Group | Availability | Availability | Availability | yes | no
Veeam VMware Collector Applications | Rollup Collectors Availability to CollectorGroup | Availability | Availability | Availability | yes | no
Veeam VMware Collector Applications | Rollup Collectors Configuration to CollectorGroup | Configuration | Configuration | Configuration | yes | no


Overrides

This section describes Veeam MP for VMware monitor property overrides.

Veeam VMware vCenter Monitoring

Veeam VMware Monitoring

Veeam Base Discovery

Veeam VMware High-Granularity

Veeam VMware Required Overrides


Veeam VMware vCenter Monitoring

Monitor Property Overrides

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.VMware.vCenter.ServiceMonitor.vctomcat.Enable | Veeam vCenter: VirtualCenter Management Webservices Monitor | VMware vCenter Servers version 4.0 and 4.1 | Enabled | true
Veeam.Virt.Extensions.VMware.vCenter.ServiceMonitor.vctomcat.VC5.Enable | Veeam vCenter: VirtualCenter Management Webservices Monitor | VMware vCenter Servers version 5.0 and 5.1 | Enabled | true
Veeam.Virt.Extensions.VMware.vCenter.ServiceMonitor.webAccess.Enable | Veeam vCenter: VC Web Service Monitor - webAccess | VMware vCenter Servers version 2.5 | Enabled | true

Rule Property Overrides

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.VMware.vCenter.tomcat.cpuUsed.VC2.Enable | Veeam vCenter: Collect vCenter Web Service % Processor Time | VMware vCenter Servers version 2.5 | Enabled | true
Veeam.Virt.Extensions.VMware.vCenter.tomcat.cpuUsed.VC4.Enable | Veeam vCenter: Collect vCenter Web Service % Processor Time | VMware vCenter Servers version 4.0 and 4.1 | Enabled | true
Veeam.Virt.Extensions.VMware.vCenter.tomcat.memoryUsed.VC2.Enable | Veeam vCenter: Collect vCenter Web Service Private Bytes | VMware vCenter Servers version 2.5 | Enabled | true
Veeam.Virt.Extensions.VMware.vCenter.tomcat.memoryUsed.VC4.Enable | Veeam vCenter: Collect vCenter Web Service Private Bytes | VMware vCenter Servers version 4.0 and 4.1 | Enabled | true


Veeam VMware Monitoring

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.VMware.VC41Alarm.HOST.BMCStatus.AlertOverride | Veeam VMware: Host Baseboard Management Controller Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC41Alarm.HOST.IPMISystemEventLogStatus.AlertOverride | Veeam VMware: Host IPMI System Event Log Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.DATASTORE.UsageOnDisk.AlertOverride | Veeam VMware: Datastore Usage on Disk Alarm | VMware Datastore | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.BatteryStatus.AlertOverride | Veeam VMware: Host Battery Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HardwareFanStatus.AlertOverride | Veeam VMware: Host Hardware Fan Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HardwarePowerStatus.AlertOverride | Veeam VMware: Host Hardware Power Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HardwareSystemBoardStatus.AlertOverride | Veeam VMware: Host Hardware System Board Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HardwareTemperatureStatus.AlertOverride | Veeam VMware: Host Hardware Temperature Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HardwareVoltageStatus.AlertOverride | Veeam VMware: Host Hardware Voltage Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.HostMemoryStatus.AlertOverride | Veeam VMware: Host Memory Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.NetworkConnectivityLost.AlertOverride | Veeam VMware: Host Network Connectivity Lost Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.NetworkUplinkRedundancyLost.AlertOverride | Veeam VMware: Host Network Uplink Redundancy Lost Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.OtherHostHardwareStatus.AlertOverride | Veeam VMware: Status of Other Host Hardware Objects Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.ProcessorStatus.AlertOverride | Veeam VMware: Host Processor Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.ServiceConsoleSwapRates.AlertOverride | Veeam VMware: Host Service Console Swap Rates Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC4Alarm.HOST.StorageStatus.AlertOverride | Veeam VMware: Host Storage Status Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC55Alarm.HOST.CpuUsage.AlertOverride | Veeam VMware: Host CPU Usage Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC55Alarm.HOST.MemoryUsage.AlertOverride | Veeam VMware: Host Memory Usage Alarm | VMware vSphere Host | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC5Alarm.DSCLUSTER.OutOfSpace.AlertOverride | Veeam VMware: Datastore Cluster is out of space Alarm | VMware Datastore Cluster | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Monitor.PathStatus.AlertOverride | Veeam VMware: Host HBA Path Status | VMware vSphere Host VMHBA | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VMHOSTNET.Monitor.AvailabilityIssue.AlertOverride | Veeam VMware: Host Network Adapter Status | VMware vSphere Host Network Card | GenerateAlert | false
Veeam.Virt.Extensions.VMware.VC5Alarm.vCenter.LicenseCapacityMonitoring.AlertOverride | Veeam VMware: vCenter License Capacity Monitoring Alarm | VMware vCenter | GenerateAlert | false


Veeam Base Discovery

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.HealthService.HandleCountThreshold.Override |  | Veeam VMware Collector Servers | Enabled | FALSE
Veeam.Virt.Extensions.HealthService.PrivateBytesThreshold.Override |  | Veeam VMware Collector Servers | Enabled | FALSE
Veeam.Virt.Extensions.MonitoringHost.HandleCountThreshold.Override |  | Veeam VMware Collector Servers | Enabled | FALSE
Veeam.Virt.Extensions.MonitoringHost.PrivateBytesThreshold.Override |  | Veeam VMware Collector Servers | Enabled | FALSE


Veeam VMware High-Granularity

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.VMware.VMDATASTORE.Collect.deviceReadLatency.EnableOverride | DATASTORE.Collect.deviceReadLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.Collect.deviceWriteLatency.EnableOverride | DATASTORE.Collect.deviceWriteLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTCOSPARTITION.Collect.freeMB.EnableOverride | HOSTCOSPARTITION.Collect.diskFree (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.Collect.diskIOPS.EnableOverride | DATASTORE.Collect.diskIOPS (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsNormalizedReadLatency.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsNormalizedReadLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsNormalizedWriteLatency.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsNormalizedWriteLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsOutstandingReadRequests.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsOutstandingReadRequests (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsOutstandingWriteRequests.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsOutstandingWriteRequests (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsReadIOPS.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsReadIOPS (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.sdrsWriteIOPS.EnableOverride | DATASTORE.SIOCSDRS.Collect.sdrsWriteIOPS (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.SIOCSDRS.Collect.siocMaxQueueDepth.EnableOverride | DATASTORE.SIOCSDRS.Collect.siocMaxQueueDepth (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMDATASTORE.Collect.VMObservedLatency.EnableOverride | DATASTORE.Collect.VMObservedLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.cpuIdlePct.EnableOverride | VMGUEST.Collect.cpuIdlePct (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.cpuWaitPct.EnableOverride | VMGUEST.Collect.cpuWaitPct (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.freePct.EnableOverride | VMGUEST.Collect.freePct (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Disk.Collect.outstandingIOs.EnableOverride | VMGUEST.Disk.Collect.outstandingIOs (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.usageRateKB.EnableOverride | VMGUEST.Collect.usageRateKB (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.memoryShared.EnableOverride | VMGUEST.Collect.memoryShared (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.receiveRate.EnableOverride | VMGUEST.Collect.receiveRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMGUEST.Collect.transmitRate.EnableOverride | VMGUEST.Collect.transmitRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.cpuIdlePct.EnableOverride | HOST.Collect.cpuIdlePct (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.commandsFailed.EnableOverride |  | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.kernelLatency.EnableOverride | HOSTADAPTER.Collect.kernelLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.kernelReadLatency.EnableOverride | HOSTADAPTER.Collect.kernelReadLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.kernelWriteLatency.EnableOverride | HOSTADAPTER.Collect.kernelWriteLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.maxQueueDepth.EnableOverride | HOSTADAPTER.Collect.maxQueueDepth (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.diskReadRate.EnableOverride | HOSTADAPTER.Collect.diskReadRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.diskUsageRate.EnableOverride | HOSTADAPTER.Collect.diskUsageRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.diskWriteRate.EnableOverride | HOSTADAPTER.Collect.diskWriteRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.totalReadLatency.EnableOverride | HOSTADAPTER.Collect.totalReadLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.readRate.EnableOverride | HOSTADAPTER.Collect.readRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.totalWriteLatency.EnableOverride | HOSTADAPTER.Collect.totalWriteLatency (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTADAPTER.Collect.writeRate.EnableOverride | HOSTADAPTER.Collect.writeRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.memoryActive.EnableOverride | HOST.Collect.memoryActive (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.memoryAvailPct.EnableOverride | HOST.Collect.memoryAvailPct (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.memorySwapped.EnableOverride | HOST.Collect.memorySwapped (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOST.Collect.memoryShared.EnableOverride | HOST.Collect.memoryShared (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTNET.Collect.droppedRx.EnableOverride | HOSTNET.Collect.droppedRx (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTNET.Collect.droppedTx.EnableOverride | HOSTNET.Collect.droppedTx (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTNET.Collect.receiveRate.EnableOverride | HOSTNET.Collect.receiveRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMHOSTNET.Collect.transmitRate.EnableOverride | HOSTNET.Collect.transmitRate (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.POWER.Collect.actualValue.Amps.EnableOverride | SENSOR.POWER.Collect.actualValue.Amps (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.POWER.Collect.actualValue.Percentage.EnableOverride | SENSOR.POWER.Collect.actualValue.Percentage (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.POWER.Collect.actualValue.Volts.EnableOverride | SENSOR.POWER.Collect.actualValue.Volts (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.POWER.Collect.actualValue.Watts.EnableOverride | SENSOR.POWER.Collect.actualValue.Watts (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.TEMPERATURE.Collect.actualValue.DegreeC.EnableOverride | SENSOR.TEMPERATURE.Collect.actualValue.DegreeC (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMSENSOR.TEMPERATURE.Collect.actualValue.Percentage.EnableOverride | SENSOR.TEMPERATURE.Collect.actualValue.Percentage (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMPOOL.Collect.vmShutdown.EnableOverride | POOL.Collect.vmShutdown (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMPOOL.Collect.vmSuspended.EnableOverride | POOL.Collect.vmSuspended (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMVAPP.Collect.vmShutdown.EnableOverride | VAPP.Collect.vmShutdown (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true
Veeam.Virt.Extensions.VMware.VMVAPP.Collect.vmSuspended.EnableOverride | VAPP.Collect.vmSuspended (High-Granularity MP) | Veeam VMware objects for high-granularity performance collection | Enabled | true


Veeam VMware Required Overrides

Override ID | Object Name | Context | Property | Value
Veeam.Virt.Extensions.VMware.Topology.Discovery.Datastore.BackupDatastore.Override | Veeam Stage 2 - Datastore discovery | VMware Datastore Container | ExcludeDatastoresByDatastoreName | Veeambackup*
Veeam.Virt.Extensions.VMware.Topology.Discovery.VM.BackupDatastore.Override | Veeam Stage 2 - Virtual Machine discovery | VM Discovery Container | ExcludeVMsByDatastoreName | Veeambackup*
Veeam.Virt.Extensions.VMware.VMGUEST.Monitor.snapshotAgeAndSize.Disable | Veeam VMware: Virtual Machine Snapshot Usage Analysis | Veeam Backup and Replication replica VMs | Enabled | false
Veeam.Virt.Extensions.VMware.GroupEvents.VM.Error.Replica.Override | Veeam VMware: Virtual Machine Error | Veeam Backup and Replication replica VMs | ExcludeEvents | com.vmware.vc.sms.datastore. ComplianceStatusNonCompliantEvent |VmMacConflictEvent


Veeam MP for VMware Metric Definitions

This section describes performance metrics collected from VMware vSphere systems and unique Veeam MP for VMware metrics.

Cluster

Resource Pool/vApp

Host

Host Hardware

Virtual Machine

Datastore

Datastore Cluster

Collector

vCenter Server

Guest OS


Cluster

Object

Counter

Instance

Definition

VMCluster-cpu

cpuPressure

_Total

CPU Pressure is a percentage which expresses CPU overcommitment, by showing the ratio of virtual machine vCPU count versus the number of host physical CPU cores. This metric is unique to the Veeam MP for VMware and can not be seen in vCenter.

This metric is based on the setting available in the Veeam Extensions UI named 'RecommendedvCPUPerCore'. This setting can be changed in the Veeam Extensions UI, on the Veeam Collectors tab, using Collector Settings link.

This setting is used to calculate the cpuPressure metric per vSphere host by converting the ratio to a percentage. When the host is running total vCPUs (for powered-on VMs) on all host cores equal to the 'RecommendedvCPUPerCore' setting, then the cpuPressure metric will be equal to 100%.

If the number of vCPU per Core is exceeded, then this metric can be greater than 100%.

The metric per-host is rolled up to calculate a total percentage of CPU overcommit for the cluster.

VMCluster-cpu

cpuUsageMHz

_Total

The current CPU usage for the vSphere cluster (in MHz).

VMCluster-cpu

cpuUsedPct

_Total

The average of the physical CPU usage of each vSphere host in the cluster. For example, if a cluster was composed of 2 vSphere hosts and HostStats.cpuUsedPct values were 50% and 60%, then this value would show 55%.

VMCluster-disk

freeStorageTB

_Total

Total amount of free space for all datastores in the cluster.

VMCluster-memory

memoryPressure

_Total

Rolled up total of memoryPressure for all vSphere hosts in the cluster. It is expressed as a percentage, which can go above 100%. It shows potential memory over-commitment issues in the cluster. This value is calculated internally in the Collector, so is not visible in vCenter. Factors used in the calculation include - Total allocated memory for powered-on VMs, Memory overhead , the effects of TPS (Transparent Page Sharing), and total available physical memory in all hosts.

VMCluster-memory

memoryUsedMB

_Total

Physical memory usage on hosts in the cluster (in MB). The metric is equivalent to the VMware memory consumed.

VMCluster-memory

memoryUsedPct

_Total

This value is calculated as ratio of the sum of cluster memoryUsedMB and memory overhead for all VMs in the cluster vs. the amount of memory available in the cluster and is expressed as a percentage.

VMCluster-disk

usageRateKB/s

_Total

Sum of totalDiskUsageRate values for all hosts in this cluster.

VMCluster-net

usageRateKB/s

_Total

Network utilization, total usage rate at which data is received and transmitted across all physical NIC instances in the cluster.

VMCluster

vCPU Count

_Total

Total number of configured vCPUs for all VMs in this cluster.

VMCluster

vmActive

_Total

Number of active (i.e., powered up) virtual machines belonging to this cluster.

VMCluster

vMotions

_Total

Total number of migrations with vMotion that occurred in the cluster over the collection interval.

VMCluster

vmShutdown

_Total

Number of virtual machines in a shutdown (i.e., powered off) state belonging to this cluster.

VMCluster

vmSuspended

_Total

Number of virtual machines in a suspended state belonging to this cluster.

VMCluster

vmTotal

_Total

Total number of virtual machines in all states belonging to this cluster.


Resource Pool/vApp

Object | Counter | Instance | Definition
VMPool-cpu/ VmvApp-cpu | cpuUsageMHz | _Total | The current CPU usage for the pool/vApp (in MHz).
VMPool-cpu/ VmvApp-cpu | cpuUsedPct | _Total | CPU used by the resource pool/vApp, as a percentage of the available Limit. If the pool/vApp is set 'Unlimited' then this will be a percentage of total CPU available in the cluster.
VMPool-memory/ VmvApp-memory | memoryUsedMB | _Total | The current memory usage for the pool/vApp (in MB).
VMPool-memory/ VmvApp-memory | memoryUsedPct | _Total | Memory used by the resource pool/vApp, as a percentage of the available Limit. If the pool/vApp is set "Unlimited" then this will be a percentage of total memory available in the cluster.
VMPool/VmvApp | vmActive | _Total | Number of active (i.e., powered up) virtual machines belonging to this resource pool/vApp.
VMPool/VmvApp | vmShutdown | _Total | Number of virtual machines in a shutdown (i.e., powered off) state belonging to this resource pool/vApp.
VMPool/VmvApp | vmSuspended | _Total | Number of virtual machines in a suspended state belonging to this resource pool/vApp.
VMPool/VmvApp | vmTotal | _Total | Total number of virtual machines in all states belonging to this resource pool/vApp.


Host

Object

Counter

Instance

Definition

VMHost-hba

commands/sec

_Total

Average number of commands issued per second on the storage adapter during the collection interval.

VMHost-hba

commandsFailed

_Total

Number of aborted and reset SCSI commands for disks on this host in the last interval.

VMHost-cpu

cpuCoStopPct

_Total

Rolled up total of CPU Co-Stop metric for all virtual machines on the host, expressed as a percentage.

VMHost-cpu

cpuIdlePct

_Total

Time that the CPU spent in an idle state.

VMHost-cpu

cpuLatencyPct

_Total

Rolled up total of CPU latency for all virtual machines on the host, expressed as a percentage.

VMHost-cpu

cpuPressure

_Total

CPU Pressure is a percentage which expresses CPU overcommitment, by showing the ratio of virtual machine vCPU count versus the number of host physical CPU cores. This metric is unique to the Veeam MP for VMware and can not be seen in vCenter.

This metric is based on the setting available in the Veeam Extensions UI named 'RecommendedvCPUPerCore'. This setting can be changed in the Veeam Extensions UI, on the Veeam Collectors tab, using Collector Settings link.

This setting is used to calculate the cpuPressure metric per vSphere host by converting the ratio to a percentage. When the host is running total vCPUs (for powered-on VMs) on all host cores equal to the 'RecommendedvCPUPerCore' setting, then the cpuPressure metric will be equal to 100%.

If the number of vCPU per Core is exceeded, then this metric can be greater than 100%.

The metric per-host is rolled up to calculate a total percentage of CPU overcommit for the cluster.

VMHost-cpu

cpuReadyPct

_Total

Rolled up total of CPU Ready time for all virtual machines on the host, expressed as a percentage.

VMHost-cpu

cpuUsageMHz

_Total

Aggregated CPU usage across all cores on the host (in MHz).

VMHost-cpu

cpuUsedPct

_Total

The percentage of the last interval (0-100%) that the physical server's CPU was busy.

VMHost-net

droppedPackets

_Total

Total number of dropped network packets during the collection interval.

VMHost-hba

MaxKernelLatency

_Total

Maximum amount of time, in milliseconds, spent by VMKernel processing each SCSI command. It is the maximum of read, write and command latency.

VMHost-hba

MaxTotalLatency

_Total

Highest total latency value across all disks used by the host.

VMHost-memory

memoryActiveMB

_Total

Amount of memory that is actively used by the host, as estimated by VMkernel based on recently touched memory pages.

VMHost-memory

memoryAvailMB

_Total

Total amount of memory (in MB) still available. This is the difference between the system's total memory and memory currently being consumed. Refer to VMware Resource Management Guide for more information on VMware's memory usage.

VMHost-memory

memoryAvailPct

_Total

Available memory relative to total memory installed on the host (in percent).

VMHost-memory

memoryBalloonPct

_Total

Amount of memory processed by the virtual machine memory control driver (vmmemctl) for all VMs running on the host, expressed as a percentage.

VMHost-memory

memoryLatencyPct

_Total

Percentage of time the VMs on the host are waiting to access swapped or compressed memory.

VMHost-memory

memoryPressure

_Total

This metric is expressed as a percentage, which can go above 100%. It shows potential memory over-commitment issues on the vSphere host. This value is calculated internally in the Veeam Collector, so is not visible in vCenter. Factors used in the calculation include - Total allocated memory for powered-on VMs, memory overhead, the effects of TPS (Transparent Page Sharing), and total available physical memory in the host.

VMHost-memory

memorySharedMB

_Total

The average amount of shared memory. Shared memory represents the entire pool of memory from which sharing savings are possible.

VMHost-memory

memorySwappedMB

_Total

Total amount of virtual machines' memory swapped out to disk.

VMHost-memory

memorySwapRateKB/s

_Total

The rate of KB swapped (in plus out) per second during the interval.

VMHost-memory

memoryUsedMB

_Total

Physical memory usage on the host in MB. The metric is equivalent to the VMware metric memory consumed.

VMHost-memory

memoryUsedPct

_Total

Memory used divided by total physical memory, as a percentage.

VMHost-hba

totalNumPaths

_Total

Total number of paths to storage on the host.

VMHost-net

usageRateKB/s

_Total

Rolled up total in KB for all network traffic through all vmnic on the host.

VMHost-hba

usageRateKB/s

_Total

Rolled up total in KB for all disk traffic through all vmhba on the host.

VMHost

vCpuCount

_Total

Total number of configured vCPUs for all VMs on this host.

VMHost

vmActive

_Total

Number of active (i.e., powered up) virtual machines running on this host.

VMHost

vmShutdown

_Total

Number of virtual machines in a shutdown (i.e., powered off) state on this host.

VMHost

vmSuspended

_Total

Number of virtual machines in a suspended state on this host.

VMHost

vmTotal

_Total

Total number of all virtual machines on this host.

Host HBAs

Object | Counter | Instance | Definition
VMHost-hba | commands/sec | vmhba name | Average number of commands issued per second on the storage adapter during the collection interval.
VMHost-hba | commandsFailed | vmhba name | Number of aborted and reset SCSI commands for all disks connected via this storage adapter.
VMHost-disk | commandsFailed | Datastore name: Disk name | Number of aborted and reset SCSI commands for all disks assigned to this storage adapter.
VMHost-disk | kernelLatency | Datastore name: Disk name | Maximum amount of time (in milliseconds) spent by VMKernel processing each SCSI command.
VMHost-disk | kernelReadLatency | Datastore name: Disk name | Average amount of time (in milliseconds) spent by VMKernel processing each SCSI read command.
VMHost-disk | kernelWriteLatency | Datastore name: Disk name | Average amount of time (in milliseconds) spent by VMKernel processing each SCSI write command.
VMHost-hba | MaxKernelLatency | vmhba name | Maximum amount of time (in milliseconds) spent by VMKernel processing each SCSI command.
VMHost-disk | maxQueueDepth | Datastore name: Disk name | Maximum queue depth.
VMHost-hba | MaxTotalLatency | vmhba name | Highest latency value across all disks used by the host.
VMHost-hba | OIOsPct | vmhba name | The percent of I/Os that have been issued but have not yet completed.
VMHost-hba | readLatency | vmhba name | Average amount of time that taken for a read on the storage path.
VMHost-hba | readRateKB/s | vmhba name | Rate at which data is read on the storage path.
VMHost-disk | readRateKB/s | Datastore name: Disk name | Rate at which data is read from the datastore.
VMHost-hba | usageRateKB/s | vmhba name | Rate at which data is read and written on the storage path.
VMHost-disk | usageRateKB/s | Datastore name: Disk name | Sum of read and write rates to the datastore.
VMHost-hba | writeLatency | vmhba name | Average amount of time taken for a write on the storage path.
VMHost-hba | writeRateKB/s | vmhba name | Rate at which data is written on the storage path.
VMHost-disk | writeRateKB/s | Datastore name: Disk name | Rate at which data is written to the datastore.

Host NET

Object | Counter | Instance | Definition
VMHost-net | droppedPackets | Vmnic name | Total number of dropped network packets during the collection interval.
VMHost-net | droppedRx | Vmnic name | Number of receive network packets dropped in the last interval.
VMHost-net | droppedTx | Vmnic name | Number of transmit network packets dropped in the last interval.
VMHost-net | receiveRateKB/s | Vmnic name | Average rate at which data was received in the last interval.
VMHost-net | transmitRateKB/s | Vmnic name | Average rate at which data was transmitted in the last interval.
VMHost-net | usageRateKB/s | Vmnic name | Rate at which data is transmitted across each physical NIC instance on the host.


Host Hardware

Object | Counter | Instance | Definition
VMHost-sensor | Amps | Sensor name | Metrics from Power sensors where the metric is delivered as Amps. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.
VMHost-sensor | Degrees C | Sensor name | Metrics from Temperature sensors where the metric is delivered as Degree C. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.
VMHost-sensor power | Percentage | Sensor name | Metrics from Power sensors where the metric is delivered as Percentage. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.
VMHost-sensor temperature | Percentage | Sensor name | Metrics from Temperature sensors where the metric is delivered as Percentage. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.
VMHost-sensor | Volts | Sensor name | Metrics from Power sensors where the metric is delivered as Volts. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.
VMHost-sensor | Watts | Sensor name | Metrics from Power sensors where the metric is delivered as Watts. The current reading of the element indicated by the sensor current reading multiplied by the scale factor.


Virtual Machine

Object

Counter

Instance

Definition

VMGuest-disk

commands/sec

Datastore name: Virtual disk name

Total number of SCSI commands issued to the virtual disk.

VMGuest-disk

commands/sec

_Total

Rolled up total IOPS (reads+ writes per second) for all vmhba storage connections in this virtual machine.

VMGuest-disk

commandsFailed

_Total

Number of aborted and reset SCSI commands in the last interval.

VMGuest-cpu

cpuCoStopPct

_Total

Time the VM is ready to run but is unable due to co-scheduling constraints.

VMGuest-cpu

cpuIdlePct

_Total

Percent of time that the CPU was idle for this virtual machine during the last interval. For ESX 3.x systems, this value is in milliseconds.

VMGuest-cpu

cpuLatencyPct

_Total

Percent of time the VM is unable to run because it is contending for access to the physical CPU(s).

VMGuest-cpu

cpuReadyPct

_Total

Percentage of time during the last sample that the virtual machine CPU resources were in the ready state.

VMGuest-cpu

cpuSwapWaitPct

_Total

Percentage of the time during the last sample spent waiting for swap-in.

VMGuest-cpu

cpuUsageMHz

_Total

CPU usage (in MHz) over the interval of collection.

VMGuest-cpu

cpuUsedPct

_Total

Percentage of the potential physical server's CPU time that this virtual machine was busy during the last interval. For example, consider an 8-core vSphere host with a single 2-core VM. If each core is rated at 3.000 Mhz and the VM consumes an average of 5.400 MHz over the interval, then the cpuUsedPct would be 90% (since 6,000 is the maximum that a 2-core VM could consume).

Correspondly, 5.400 MHz represents 23% of the vSphere host's total capability of 24,000 Mhz. Refer to cpuUsedPct for this server percentage.

VMGuest-cpu

cpuWaitPct

_Total

Percentage of time during the last sample that the virtual machine CPU resources were in the 'wait' state. For example, on a physical server with 2 CPU threads, during a 300 second interval 600 seconds of CPU resources are available. If the VM was in a "wait" state for 60 seconds the cpuWaitPct would be 10%.

VMGuest-disk

diskLatency

_Total

Highest latency value across all disks used by the VM.

VMGuest-net

droppedPackets

_Total

Total number of dropped network packets for the VM.

VMGuest-disk

freeMB

Disk partition name

The amount of free space (in MB) on this virtual disk.

VMGuest-disk

freePct

Disk partition name

The percentage of disk space available on this virtual disk.

VMGuest-memory

memoryActiveMB

_Total

Current amount of memory that is being 'actively used' by this virtual machine (in MB), as estimated by VMKernel based on recently touched memory pages.

VMGuest-memory

memoryActivePct

_Total

The current percentage of memoryActiveMB vs. memoryConsumedMB for this virtual machine.

VMGuest-memory

memoryBalloonPct

_Total

Amount of memory allocated to the virtual machine memory control driver (vmmemctl).

VMGuest-memory

memoryConsumedMB

_Total

The current maximum amount of memory assigned to this virtual machine (in MB). VMware refers to this as the 'memory consumed'.

VMGuest-memory

memoryLatencyPct

_Total

Percentage of time the VM is waiting to access swapped or compressed memory.

VMGuest-memory

memorySharedKB

_Total

The average amount of shared memory (in KB) for this virtual machine.

VMGuest-memory

memorySwapRateKB/s

_Total

The rate of KB swapped in or out per second for this VM during the interval.

VMGuest-memory

memoryUsedPct

_Total

Memory consumed as percentage of allocated memory for the VM.

VMGuest-disk

outstandingIOs

_Total

Average number of outstanding I/O requests to the virtual disk during the collection interval.

VMGuest-disk

outstandingIOs

Datastore name: Virtual disk name

Average number of outstanding I/O requests to the virtual disk during the collection interval.

VMGuest-disk

readLatency

Datastore name: Virtual disk name

Average amount of time that takes a read from the virtual disk.

VMGuest-net

receiveRateKB/s

_Total

Rate at which data is received across each vNIC instance on the VM.

VMGuest

snapshotAgeHours

_Total

The age of the oldest snapshot.

VMGuest

snapshotsSizeMB

_Total

Total size of snapshot files for the VM.

VMGuest-net

transmitRateKB/s

vNIC name

Rate at which data is transmitted across each vNIC instance on the VM.

VMGuest-net

usageRateKB/s

_Total

Rate at which data is sent and received across each vNIC instance on the VM.

VMGuest-disk

usageRateKB/s

Datastore name: Virtual disk name

Rate at which data is read and written to/from the virtual disk.

VMGuest-disk

usageRateKB/s

_Total

Rate at which data is read and written from/to the virtual disk for all disks of the virtual machine.

VMGuest-disk

usedStorageGB

_Total

Total storage space, in GB, committed to this virtual machine across all datastores.

VMGuest-disk

usedStorageGB

Datastore name

Storage space, in GB, committed to this virtual machine on this datastore.

VMGuest-disk

writeLatency

Datastore name: Virtual disk name

Average amount of time that takes a write to the virtual disk.

VM Template

Object | Counter | Instance | Definition
VMGuest-disk | usedStorageGB | Datastore name | Total storage space, in GB, committed to this VM template across all datastores.
VMGuest-disk | usedStorageGB | _Total | Total storage space, in GB, committed to this VM template.


Datastore

Object | Counter | Instance | Definition
VMDatastore | deviceReadLatency | Host name:disk name | The average amount of time taken to complete a read from the physical device. This is the time from the device to the host HBA (in milliseconds).
VMDatastore | deviceWriteLatency | Host name:disk name | The average amount of time taken to complete a write to the physical device. This is the time from the host HBA to the device (in milliseconds).
VMDatastore | diskPressure | _Total | The ratio of allocated storage to storage capacity, expressed as a percentage. This percentage can be greater than 100 if thin-provisioning (storage overcommit) is used extensively. See related metric ProvisionedGB.
VMDatastore | freeGB | _Total | Amount of datastore space that is not currently used.
VMDatastore | IOPS | Host name | Aggregate number of I/O operations on the datastore per host.
VMDatastore | IOPS | _Total | Number of input/output operations per second, calculated as total of (reads + writes) divided by the collection interval.
VMDatastore | IOPS | Host name:disk name | Aggregate number of I/O operations on the datastore per second.
VMDatastore | MaxDeviceLatency | _Total | Highest physical device latency value on the datastore during the collection interval.
VMDatastore | MaxDeviceReadLatency | _Total | Highest physical device latency value on the datastore (in milliseconds) for read operations.
VMDatastore | MaxDeviceWriteLatency | _Total | Highest physical device latency value on the datastore (in milliseconds) for write operations.
VMDatastore | ProvisionedGB | _Total | Amount of space in GB that is provisioned (allocated) on the datastore. This can exceed the actual capacity of the datastore if thin-provisioning is used extensively (storage overcommit).
VMDatastore | readRateKB/s | _Total | Average read rate per second for the datastore (in KB).
VMDatastore | unknownFilesGB | _Total | Amount of storage space (in GB) occupied by files unknown to vCenter (orphaned snapshots, orphaned VMs, or manually uploaded files such as ISO, etc.) on the datastore.
VMDatastore | usedPct | _Total | Percentage of space in use on the VMFS. That is, diskUse vs. diskSize.
VMDatastore | VMObservedLatency | _Total | The average datastore latency as seen by virtual machines.
VMDatastore | vmTotal | _Total | Number of VMs whose disks reside on the datastore. This number includes both virtual machines and VM templates.
VMDatastore | writeRateKB/s | _Total | Average write rate per second for the datastore (in KB).

SIOC/SDRS-Datastore

Object | Counter | Instance | Definition
VMDatastore | SDRS Normalized Read Latency | _Total | Storage DRS datastore normalized read latency.
VMDatastore | SDRS Normalized Write Latency | _Total | Storage DRS datastore normalized write latency.
VMDatastore | SDRS Outstanding Read Requests | _Total | Average number of outstanding read requests to the datastore during the collection interval.
VMDatastore | SDRS Outstanding Write Requests | _Total | Average number of outstanding write requests to the datastore during the collection interval.
VMDatastore | SDRS Read IOPS | _Total | Average number of disk read commands completed on each datastore, per second.
VMDatastore | SDRS Write IOPS | _Total | Average number of disk write commands completed on each datastore, per second.
VMDatastore | SIOC Aggregated IOPS | _Total | Average number of I/O operations per second on the datastore, aggregated across all hosts and virtual machines accessing the datastore.
VMDatastore | SIOC Max Queue Depth | _Total | Maximum queue depth set in the HBA driver of all the hosts.
VMDatastore | SIOC Normalized Latency | _Total | Latency that is monitored by Storage I/O Control to detect congestion on the datastore.

Host COS Partition

Object | Counter | Instance | Definition
VMDatastore | freeMB | partition name | The amount of free space in MB on the COS partition.
VMDatastore | usedPct | partition name | The amount of free space in percent on the COS partition.


Datastore Cluster

Object | Counter | Instance | Definition
VMDatastoreCluster | diskPressure | _Total | The ratio of allocated storage to storage capacity, expressed as a percentage. This percentage can be greater than 100 if thin-provisioning (storage overcommit) is used extensively.
VMDatastoreCluster | freeGB | _Total | Amount of disk space (in GB) that is not currently used for this datastore cluster.
VMDatastoreCluster | freePct | _Total | Amount of disk space (in percent) that is not currently used for this datastore cluster.
VMDatastoreCluster | usedPct | _Total | Amount of space in use for this datastore cluster (in percent).
VMDatastoreCluster | vmTotal | _Total | Number of VMs whose disks reside on the datastore cluster. This number includes both virtual machines and VM templates.


Collector

Object | Counter | Instance | Definition
Veeam VMware Collector | % Monitoring Load | _Total | Number of workflows that Veeam VMware Collector should process against the maximum number of workflows that the Health Service can handle, expressed in percent.
Process | % Processor Time | HealthService | Percentage of elapsed time that Health Service threads used the processor to execute data processing instructions.
Process | % Processor Time | MonitoringHost #n | Percentage of elapsed time that Monitoring Host process threads used the processor to execute data processing instructions.
Process | Private Bytes | HealthService | Current size, in bytes, of memory that is allocated to the Health Service and that cannot be shared with other processes.
Process | Private Bytes | MonitoringHost #n | Current size, in bytes, of memory that is allocated to the Monitoring Host process and that cannot be shared with other processes.
Veeam VMware Collector | Workflow Count | _Total | Number of workflows running in the Health Service that is processing data received from Veeam VMware Collector.

Collector Heartbeat

Object | Counter | Instance | Definition
Veeam VMware Collector | Monitored Clusters | Collector Name (guid) | Number of vSphere clusters monitored by Veeam VMware Collector.
Veeam VMware Collector | Monitored Datastores | Collector Name (guid) | Number of datastores monitored by Veeam VMware Collector.
Veeam VMware Collector | Monitored Hosts | Collector Name (guid) | Number of hosts monitored by Veeam VMware Collector.
Veeam VMware Collector | Monitored VMs | Collector Name (guid) | Number of virtual machines monitored by Veeam VMware Collector.
Veeam VMware Collector | Total Veeam Workflows | Collector Name (guid) | Number of workflows running in the Health Service that is processing data received from Veeam VMware Collector.


vCenter Server

Object | Counter | Instance | Definition
Process | % Processor Time | Vpxd | Amount of CPU resources utilized by the vpxd process, as a percentage of available CPU resources.
Process | % Processor Time | Tomcat5 | Amount of CPU resources utilized by the tomcat process, as a percentage of available CPU resources.
Process | % Processor Time | Tomcat6 | Amount of CPU resources utilized by the tomcat process, as a percentage of available CPU resources.
Process | % Processor Time | Java | Amount of CPU resources utilized by the Java process, as a percentage of available CPU resources.
Process | Private Bytes | Vpxd | Current size, in bytes, of memory that is allocated to the Vpxd process and that cannot be shared with other processes.
Process | Private Bytes | Tomcat5 | Current size, in bytes, of memory that is allocated to the tomcat process and that cannot be shared with other processes.
Process | Private Bytes | Tomcat6 | Current size, in bytes, of memory that is allocated to the tomcat process and that cannot be shared with other processes.
Process | Private Bytes | Java | Current size, in bytes, of memory that is allocated to the Java process and that cannot be shared with other processes.


Guest OS

Object | Counter | Instance | Definition
VMGuest-net | % Bandwidth Used | _Total | % of bandwidth of all network adapters that is currently being used.
VMGuest-disk | % Disk Time | _Total | % Disk Time is the percentage of elapsed time that the guest disk drives was busy servicing read or write requests.
VMGuest-memory | % Memory Used | _Total | Physical memory in use. Total physical memory – memory immediately available for allocation to a process or for system use.
VMGuest-memory | % Page File Used | _Total | The total amount of all Page Files usage in percent.
VMGuest-cpu | % Processor Time | _Total | Percentage of elapsed time that the processor spends to execute a non-Idle thread of guest OS.
VMGuest-memory | Pages/sec | _Total | Pages/sec is the rate at which pages are read from or written to disk to resolve hard page faults. This counter is a primary indicator of the kinds of faults that cause system-wide delays.


Topology Agenda

This appendix provides a full list of icons used in the Veeam MP for VMware Topology Views:

Icon | Topology Object
 | VMware vCenter Server
 | vSphere Datacenter
 | vSphere Cluster
 | vSphere Host
 | Security Profile
 | Resource Pool
 | vApp
 | Virtual Machines Container
 | Host Hardware Container
 | Host Maintenance Mode Tracker
 | Host HBAs
 | Host NET
 | Host HBA
 | Host VMNIC
 | Virtual Switch
 | Distributed Virtual Switch
 | Datastore Cluster
 | Datastore
 | SIOC/SDRS-Datastore
 | COS Partitions
 | Virtual Machine
 | VM Template
 | Fault-Tolerant Virtual Machines
 | Virtualization Extensions object — Windows
 | FAN
 | SENSOR
 | RAM
 | POWER
 | PROC
 | DISK
 | TEMP
 | SYSLOG
 | Veeam VMware Collector
 | Virtualization Extensions Service
 | vSphere Server Connection


vCenter Events

 Top Previous
ID | Severity | Group | Message Catalog Text
AccountCreatedEvent | info | VC | An account was created on host {host.name} Since 2.0 Reference
AccountRemovedEvent | info | VC | Account {account} was removed on host {host.name} Since 2.0 Reference
AccountUpdatedEvent | info | VC | An account was updated on host {host.name} Since 2.0 Reference
ad.event.ImportCertEvent | info | VC | ad.event.ImportCertEvent| Import certificate succeeded. Since 5.0 Reference
ad.event.ImportCertFailedEvent | error | VC | ad.event.ImportCertFailedEvent| Import certificate failed. Since 5.0 Reference
ad.event.JoinDomainEvent | info | VC | ad.event.JoinDomainEvent| Join domain succeeded. Since 5.0 Reference
ad.event.JoinDomainFailedEvent | error | VC | ad.event.JoinDomainFailedEvent| Join domain failed. Since 5.0 Reference
ad.event.LeaveDomainEvent | info | VC | ad.event.LeaveDomainEvent| Leave domain succeeded. Since 5.0 Reference
ad.event.LeaveDomainFailedEvent | error | VC | ad.event.LeaveDomainFailedEvent| Leave domain failed. Since 5.0 Reference
AdminPasswordNotChangedEvent | info | VC | The default password for the root user on the host {host.name} has not been changed Since 2.5 Reference
AlarmAcknowledgedEvent | info | VC | Acknowledged alarm '{alarm.name}' on {entity.name} Since 5.0 Reference
AlarmActionTriggeredEvent | info | VC | Alarm '{alarm.name}' on {entity.name} triggered an action Since 2.0 Reference
AlarmClearedEvent | info | VC | Manually cleared alarm '{alarm.name}' on {entity.name} from {from.@enum.ManagedEntity.Status} Since 5.0 Reference
AlarmCreatedEvent | info | VC | Created alarm '{alarm.name}' on {entity.name} Since 2.0 Reference
AlarmEmailCompletedEvent | info | VC | Alarm '{alarm.name}' on {entity.name} sent email to {to} Since 2.0 Reference
AlarmEmailFailedEvent | error | VC | Alarm '{alarm.name}' on {entity.name} cannot send email to {to} Since 2.0 Reference
AlarmReconfiguredEvent | info | VC | Reconfigured alarm '{alarm.name}' on {entity.name} Since 2.0 Reference
AlarmRemovedEvent | info | VC | Removed alarm '{alarm.name}' on {entity.name} Since 2.0 Reference
AlarmScriptCompleteEvent | info | VC | Alarm '{alarm.name}' on {entity.name} ran script {script} Since 2.0 Reference
AlarmScriptFailedEvent | error | VC | Alarm '{alarm.name}' on {entity.name} did not complete script: {reason.msg} Since 2.0 Reference
AlarmSnmpCompletedEvent | info | VC | Alarm '{alarm.name}' on entity {entity.name} send SNMP trap Since 2.0 Reference
AlarmSnmpFailedEvent | error | VC | Alarm '{alarm.name}' on entity {entity.name} did not send SNMP trap: {reason.msg} Since 2.0 Reference
AlarmStatusChangedEvent | info | VC | Alarm '{alarm.name}' on {entity.name} changed from {from.@enum.ManagedEntity.Status} to {to.@enum.ManagedEntity.Status} Since 2.0 Reference
AllVirtualMachinesLicensedEvent | info | VC | All running virtual machines are licensed Since 2.5 Reference
AlreadyAuthenticatedSessionEvent | info | VC | User cannot logon since the user is already logged on Since 2.0 Reference
BadUsernameSessionEvent | warning | VC | Cannot login {userName}@{ipAddress} Since 2.0 Reference
CanceledHostOperationEvent | info | VC | The operation performed on host {host.name} in {datacenter.name} was canceled Since 2.0 Reference
ChangeOwnerOfFileEvent | info | VC | Changed ownership of file name {filename} from {oldOwner} to {newOwner} on {host.name} in {datacenter.name}. Since 5.1 Reference
ChangeOwnerOfFileFailedEvent | error | VC | Cannot change ownership of file name {filename} from {owner} to {attemptedOwner} on {host.name} in {datacenter.name}. Since 5.1 Reference
ClusterComplianceCheckedEvent | info | VC | Checked cluster for compliance Since 4.0 Reference
ClusterCreatedEvent | info | VC | Created cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
ClusterDestroyedEvent | info | VC | Removed cluster {computeResource.name} in datacenter {datacenter.name} Since 2.0 Reference
ClusterOvercommittedEvent | warning | Cluster | Insufficient capacity in cluster {computeResource.name} to satisfy resource configuration in {datacenter.name} Since 2.0 Reference
ClusterReconfiguredEvent | info | VC | Reconfigured cluster {computeResource.name} in datacenter {datacenter.name} Since 2.0 Reference
ClusterStatusChangedEvent | info | VC | Configuration status on cluster {computeResource.name} changed from {oldStatus.@enum.ManagedEntity.Status} to {newStatus.@enum.ManagedEntity.Status} in {datacenter.name} Since 2.0 Reference
com.vmware.license.AddLicenseEvent | info | VC | com.vmware.license.AddLicenseEvent| License {licenseKey} added to VirtualCenter Since 4.0 Reference
com.vmware.license.AssignLicenseEvent | info | VC | com.vmware.license.AssignLicenseEvent| License {licenseKey} assigned to asset {entityName} Since 4.0 Reference
com.vmware.license.DLFDownloadFailedEvent | warning | VC | com.vmware.license.DLFDownloadFailedEvent| Failed to download license information from the host {hostname} due to {errorReason.@enum.com.vmware.license.DLFDownloadFailedEvent.DLFDownloadFailedReason} Since 4.1 Reference
com.vmware.license.LicenseAssignFailedEvent | error | VC | com.vmware.license.LicenseAssignFailedEvent| License assignment on the host fails. Reasons: {errorMessage.@enum.com.vmware.license.LicenseAssignError}. Since 4.0 Reference
com.vmware.license.LicenseCapacityExceededEvent | warning | VC | com.vmware.license.LicenseCapacityExceededEvent| The current license usage ({currentUsage} {costUnitText}) for {edition} exceeds the license capacity ({capacity} {costUnitText}) Since 5.0 Reference
com.vmware.license.LicenseExpiryEvent | error | VC | com.vmware.license.LicenseExpiryEvent| Your host license will expire in {remainingDays} days. The host will be disconnected from VC when its license expires. Since 4.0 Reference
com.vmware.license.LicenseUserThresholdExceededEvent | warning | VC | com.vmware.license.LicenseUserThresholdExceededEvent| Current license usage ({currentUsage} {costUnitText}) for {edition} exceeded the user-defined threshold ({threshold} {costUnitText}) Since 4.1 Reference
com.vmware.license.RemoveLicenseEvent | info | VC | com.vmware.license.RemoveLicenseEvent| License {licenseKey} removed from VirtualCenter Since 4.0 Reference
com.vmware.license.UnassignLicenseEvent | info | VC | com.vmware.license.UnassignLicenseEvent| License unassigned from asset {entityName} Since 4.0 Reference
com.vmware.vc.cim.CIMGroupHealthStateChanged | info | VC | com.vmware.vc.cim.CIMGroupHealthStateChanged| Health of [data.group] changed from [data.oldState] to [data.newState]. Since 4.0 Reference
com.vmware.vc.datastore.UpdatedVmFilesEvent | info | VC | com.vmware.vc.datastore.UpdatedVmFilesEvent| Updated VM files on datastore {ds.name} using host {hostName} Since 4.1 Reference
com.vmware.vc.datastore.UpdateVmFilesFailedEvent | error | VC | com.vmware.vc.datastore.UpdateVmFilesFailedEvent| Failed to update VM files on datastore {ds.name} using host {hostName} Since 4.1 Reference
com.vmware.vc.datastore.UpdatingVmFilesEvent | info | VC | com.vmware.vc.datastore.UpdatingVmFilesEvent| Updating VM files on datastore {ds.name} using host {hostName} Since 4.1 Reference
com.vmware.vc.dvs.LacpConfigInconsistentEvent | info | VC | com.vmware.vc.dvs.LacpConfigInconsistentEvent| Single Link Aggregation Control Group is enabled on Uplink Port Groups while enhanced LACP support is enabled. Since 5.5 Reference
com.vmware.vc.ft.VmAffectedByDasDisabledEvent | warning | VirtualMachine | com.vmware.vc.ft.VmAffectedByDasDisabledEvent| VMware HA has been disabled in cluster {computeResource.name} of datacenter {datacenter.name}. HA will not restart VM {vm.name} or its Secondary VM after a failure. Since 4.1 Reference
com.vmware.vc.guestOperations.GuestOperation | info | VC | com.vmware.vc.guestOperations.GuestOperation| Guest operation {operationName.@enum.com.vmware.vc.guestOp} performed on Virtual machine {vm.name}. Since 5.0 Reference
com.vmware.vc.guestOperations.GuestOperationAuthFailure | warning | VirtualMachine | com.vmware.vc.guestOperations.GuestOperationAuthFailure| Guest operation authentication failed for operation {operationName.@enum.com.vmware.vc.guestOp} on Virtual machine {vm.name}. Since 5.0 Reference
com.vmware.vc.HA.AllHostAddrsPingable | info | VC | com.vmware.vc.HA.AllHostAddrsPingable| All vSphere HA isolation addresses are reachable by host {host.name} in cluster {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.AllIsoAddrsPingable | info | VC | com.vmware.vc.HA.AllIsoAddrsPingable| All vSphere HA isolation addresses are reachable by host {host.name} in cluster {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.AnsweredVmLockLostQuestionEvent | warning | VirtualMachine | com.vmware.vc.HA.AnsweredVmLockLostQuestionEvent| Lock-lost question on virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} was answered by vSphere HA Since 5.0 Reference
com.vmware.vc.HA.AnsweredVmTerminatePDLEvent | warning | VirtualMachine | com.vmware.vc.HA.AnsweredVmTerminatePDLEvent| vSphere HA answered a question from host {host.name} in cluster {computeResource.name} about terminating virtual machine {vm.name} Since 5.1 Reference
com.vmware.vc.HA.AutoStartDisabled | info | VC | com.vmware.vc.HA.AutoStartDisabled| The automatic Virtual Machine Startup/Shutdown feature has been disabled on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Automatic VM restarts will interfere with vSphere HA when reacting to a host failure. Since 5.0 Reference
com.vmware.vc.HA.CannotResetVmWithInaccessibleDatastore | warning | Cluster | com.vmware.vc.HA.CannotResetVmWithInaccessibleDatastore| vSphere HA did not reset VM {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} because the VM had files on inaccessible datastore(s) Since 5.5 Reference
com.vmware.vc.HA.ClusterContainsIncompatibleHosts | warning | Cluster | com.vmware.vc.HA.ClusterContainsIncompatibleHosts| vSphere HA Cluster {computeResource.name} in {datacenter.name} contains ESX/ESXi 3.5 hosts and more recent host versions, which isn't fully supported. Since 5.0 Reference
com.vmware.vc.HA.ClusterFailoverActionCompletedEvent | info | VC | com.vmware.vc.HA.ClusterFailoverActionCompletedEvent| HA completed a failover action in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.ClusterFailoverActionInitiatedEvent | warning | Cluster | com.vmware.vc.HA.ClusterFailoverActionInitiatedEvent| HA initiated a failover action in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.DasAgentRunningEvent | info | VC | com.vmware.vc.HA.DasAgentRunningEvent| HA Agent on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} is running Since 4.1 Reference
com.vmware.vc.HA.DasFailoverHostFailedEvent | error | Cluster | com.vmware.vc.HA.DasFailoverHostFailedEvent| HA failover host {host.name} in cluster {computeResource.name} in {datacenter.name} has failed Since 4.1 Reference
com.vmware.vc.HA.DasFailoverHostIsolatedEvent | warning | Cluster | com.vmware.vc.HA.DasFailoverHostIsolatedEvent| Host {host.name} has been isolated from cluster {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.DasFailoverHostPartitionedEvent | warning | Cluster | com.vmware.vc.HA.DasFailoverHostPartitionedEvent| Failover Host {host.name} in {computeResource.name} in {datacenter.name} is in a different network partition than the master Since 5.0 Reference
com.vmware.vc.HA.DasFailoverHostUnreachableEvent | warning | Cluster | com.vmware.vc.HA.DasFailoverHostUnreachableEvent| The vSphere HA agent on the failover host {host.name} in cluster {computeResource.name} in {datacenter.name} is not reachable from vCenter Server Since 5.0 Reference
com.vmware.vc.HA.DasHostCompleteDatastoreFailureEvent | error | Cluster | com.vmware.vc.HA.DasHostCompleteDatastoreFailureEvent| All shared datastores failed on the host {hostName} in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.DasHostCompleteNetworkFailureEvent | error | Cluster | com.vmware.vc.HA.DasHostCompleteNetworkFailureEvent| All VM networks failed on the host {hostName} in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.DasHostFailedEvent | error | Cluster | com.vmware.vc.HA.DasHostFailedEvent| A possible host failure has been detected by HA on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.DasHostIsolatedEvent | warning | Cluster | com.vmware.vc.HA.DasHostIsolatedEvent| Host {host.name} has been isolated from cluster {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.DasHostMonitoringDisabledEvent | warning | Cluster | com.vmware.vc.HA.DasHostMonitoringDisabledEvent| No virtual machine failover will occur until Host Monitoring is enabled in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.DasTotalClusterFailureEvent | error | Cluster | com.vmware.vc.HA.DasTotalClusterFailureEvent| HA recovered from a total cluster failure in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.HA.FailedRestartAfterIsolationEvent | error | VirtualMachine | com.vmware.vc.HA.FailedRestartAfterIsolationEvent| vSphere HA was unable to restart virtual machine {vm.name} in cluster {computeResource.name} in datacenter {datacenter.name} after it was powered off in response to a network isolation event. The virtual machine should be manually powered back on. Since 5.0 Reference
com.vmware.vc.HA.HeartbeatDatastoreChanged | info | VC | com.vmware.vc.HA.HeartbeatDatastoreChanged| Datastore {dsName} is {changeType.@enum.com.vmware.vc.HA.HeartbeatDatastoreChange} for storage heartbeating monitored by the vSphere HA agent on host {host.name} in cluster {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.HeartbeatDatastoreNotSufficient | warning | Cluster | com.vmware.vc.HA.HeartbeatDatastoreNotSufficient| The number of heartbeat datastores for host {host.name} in cluster {computeResource.name} in {datacenter.name} is {selectedNum}, which is less than required: {requiredNum} Since 5.0 Reference
com.vmware.vc.HA.HostAgentErrorEvent | warning | Cluster | com.vmware.vc.HA.HostAgentErrorEvent| vSphere HA Agent for host {host.name} has an error in {computeResource.name} in {datacenter.name}: {reason.@enum.com.vmware.vc.HA.HostAgentErrorReason} Since 5.0 Reference
com.vmware.vc.HA.HostDasAgentHealthyEvent | info | VC | com.vmware.vc.HA.HostDasAgentHealthyEvent| HA Agent on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} is healthy Since 4.1 Reference
com.vmware.vc.HA.HostDasErrorEvent | warning | Cluster | com.vmware.vc.HA.HostDasErrorEvent| vSphere HA agent on {host.name} in cluster {computeResource.name} in {datacenter.name} has an error: {reason.@enum.HostDasErrorEvent.HostDasErrorReason} Since 5.0 Reference
com.vmware.vc.HA.HostDoesNotSupportVsan | error | VC | com.vmware.vc.HA.HostDoesNotSupportVsan| vSphere HA cannot be configured on host {host.name} in cluster {computeResource.name} in {datacenter.name} because vCloud Distributed Storage is enabled but the host does not support that feature Since 5.5 Reference
com.vmware.vc.HA.HostHasNoIsolationAddrsDefined | warning | Cluster | com.vmware.vc.HA.HostHasNoIsolationAddrsDefined| Host {host.name} in cluster {computeResource.name} in {datacenter.name} has no isolation addresses defined as required by vSphere HA. Since 5.0 Reference
com.vmware.vc.HA.HostHasNoMountedDatastores | error | Cluster | com.vmware.vc.HA.HostHasNoMountedDatastores| vSphere HA cannot be configured on {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} because there are no mounted datastores. Since 5.1 Reference
com.vmware.vc.HA.HostHasNoSslThumbprint | error | Cluster | com.vmware.vc.HA.HostHasNoSslThumbprint| vSphere HA cannot be configured on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} because its SSL thumbprint has not been verified. Check that vCenter Server is configured to verify SSL thumbprints and that the thumbprint for {host.name} has been verified. Since 5.0 Reference
com.vmware.vc.HA.HostIncompatibleWithHA | error | Cluster | com.vmware.vc.HA.HostIncompatibleWithHA| The product version of host {host.name} in cluster {computeResource.name} in {datacenter.name} is incompatible with HA. Since 5.0 Reference
com.vmware.vc.HA.HostPartitionedFromMasterEvent | warning | Cluster | com.vmware.vc.HA.HostPartitionedFromMasterEvent| Host {host.name} is in a different network partition than the master {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.HostStateChangedEvent | info | VC | com.vmware.vc.HA.HostStateChangedEvent| The vSphere HA availability state of the host {host.name} has changed to {newState.@enum.com.vmware.vc.HA.DasFdmAvailabilityState} in {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.HostUnconfiguredWithProtectedVms | warning | Cluster | com.vmware.vc.HA.HostUnconfiguredWithProtectedVms| Host {host.name} in cluster {computeResource.name} in {datacenter.name} is disconnected, but contains {protectedVmCount} protected virtual machine(s) Since 5.0 Reference
com.vmware.vc.HA.HostUnconfigureError | warning | Cluster | com.vmware.vc.HA.HostUnconfigureError| There was an error unconfiguring the vSphere HA agent on host {host.name} in cluster {computeResource.name} in {datacenter.name}. To solve this problem, connect the host to a vCenter Server of version 5.0 or later. Since 5.0 Reference
com.vmware.vc.HA.InvalidMaster | warning | Cluster | com.vmware.vc.HA.InvalidMaster| vSphere HA Agent on host {remoteHostname} is an invalid master. The host should be examined to determine if it has been compromised. Since 5.0 Reference
com.vmware.vc.HA.NotAllHostAddrsPingable | warning | Cluster | com.vmware.vc.HA.NotAllHostAddrsPingable| The vSphere HA agent on host {host.name} in cluster {computeResource.name} in {datacenter.name} cannot reach some of the management network addresses of other hosts, and thus vSphere HA may not be able to restart VMs if a host failure occurs: {unpingableAddrs} Since 5.0 Reference
com.vmware.vc.HA.StartFTSecondaryFailedEvent | info | VirtualMachine | com.vmware.vc.HA.StartFTSecondaryFailedEvent| vSphere HA agent failed to start Fault Tolerance secondary VM {secondaryCfgPath} on host {secondaryHost} for primary VM {vm.name} in cluster {computeResource.name} in {datacenter.name}. Reason : {fault.msg}. vSphere HA agent will retry until it times out. Since 5.0 Reference
com.vmware.vc.HA.StartFTSecondarySucceededEvent | info | VC | com.vmware.vc.HA.StartFTSecondarySucceededEvent| vSphere HA agent successfully started Fault Tolerance secondary VM {secondaryCfgPath} on host {secondaryHost} for primary VM {vm.name} in cluster {computeResource.name}. Since 5.0 Reference
com.vmware.vc.HA.UserHeartbeatDatastoreRemoved | warning | Cluster | com.vmware.vc.HA.UserHeartbeatDatastoreRemoved| Datastore {dsName} is removed from the set of preferred heartbeat datastores selected for cluster {computeResource.name} in {datacenter.name} because the datastore is removed from inventory Since 5.0 Reference
com.vmware.vc.HA.VcCannotFindMasterEvent | warning | Cluster | com.vmware.vc.HA.VcCannotFindMasterEvent| vCenter Server is unable to find a master vSphere HA Agent in {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.VcConnectedToMasterEvent | warning | VC | com.vmware.vc.HA.VcConnectedToMasterEvent| vCenter Server is connected to the master vSphere HA Agent running on host {hostname} in {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.VcDisconnectedFromMasterEvent | warning | VC | com.vmware.vc.HA.VcDisconnectedFromMasterEvent| vCenter Server is disconnected from the master vSphere HA Agent running on host {hostname} in {computeResource.name} in {datacenter.name} Since 5.0 Reference
com.vmware.vc.HA.VMIsHADisabledIsolationEvent | info | VC | com.vmware.vc.HA.VMIsHADisabledIsolationEvent| vSphere HA did not perform an isolation response for {vm.name} in cluster {computeResource.name} in {datacenter.name} because its VM restart priority is Disabled Since 5.1 Reference
com.vmware.vc.HA.VMIsHADisabledRestartEvent | info | VC | com.vmware.vc.HA.VMIsHADisabledRestartEvent| vSphere HA did not attempt to restart {vm.name} in cluster {computeResource.name} in {datacenter.name} because its VM restart priority is Disabled Since 5.1 Reference
com.vmware.vc.HA.VmNotProtectedEvent | warning | VirtualMachine | com.vmware.vc.HA.VmNotProtectedEvent| VM {vm.name} in cluster {computeResource.name} in {datacenter.name} failed to become vSphere HA Protected and vSphere HA may not attempt to restart it after a failure. Since 5.0 Reference
com.vmware.vc.HA.VmProtectedEvent | info | VC | com.vmware.vc.HA.VmProtectedEvent| VM {vm.name} in cluster {computeResource.name} in {datacenter.name} is vSphere HA Protected and vSphere HA will attempt to restart it after a failure. Since 5.0 Reference
com.vmware.vc.ha.VmRestartedByHAEvent | warning | VirtualMachine | com.vmware.vc.ha.VmRestartedByHAEvent| Virtual machine {vm.name} was restarted on host {host.name} in cluster {computeResource.name} by vSphere HA Since 5.0 Reference
com.vmware.vc.HA.VmUnprotectedEvent | warning | VirtualMachine | com.vmware.vc.HA.VmUnprotectedEvent| VM {vm.name} in cluster {computeResource.name} in {datacenter.name} is not vSphere HA Protected. Since 5.0 Reference
com.vmware.vc.HA.VmUnprotectedOnDiskSpaceFull | info | VC | com.vmware.vc.HA.VmUnprotectedOnDiskSpaceFull| vSphere HA has unprotected virtual machine {vm.name} in cluster {computeResource.name} in datacenter {datacenter.name} because it ran out of disk space Since 5.1 Reference
com.vmware.vc.host.AutoStartReconfigureFailedEvent | error | VC | com.vmware.vc.host.AutoStartReconfigureFailedEvent| Reconfiguring autostart rules for virtual machines on {host.name} in datacenter {datacenter.name} failed Since 5.0 Reference
com.vmware.vc.host.clear.vFlashResource.inaccessible | info | VC | com.vmware.vc.host.clear.vFlashResource.inaccessible| Host's vSphere Flash resource is restored to be accessible. Since 5.5 Reference
com.vmware.vc.host.clear.vFlashResource.reachthreshold | info | VC | com.vmware.vc.host.clear.vFlashResource.reachthreshold| Host's vSphere Flash resource usage dropped below {1}%. Since 5.5 Reference
com.vmware.vc.host.problem.vFlashResource.inaccessible | warning | VC | com.vmware.vc.host.problem.vFlashResource.inaccessible| Host's vSphere Flash resource is inaccessible. Since 5.5 Reference
com.vmware.vc.host.problem.vFlashResource.reachthreshold | warning | VC | com.vmware.vc.host.problem.vFlashResource.reachthreshold| Host's vSphere Flash resource usage is more than {1}%. Since 5.5 Reference
com.vmware.vc.host.vFlash.defaultModuleChangedEvent | info | VC | com.vmware.vc.host.vFlash.defaultModuleChangedEvent| Any new vFlash cache configuration request will use {vFlashModule} as default vSphere Flash module. All existing vFlash cache configurations remain unchanged. Since 5.5 Reference
com.vmware.vc.host.vFlash.modulesLoadedEvent | info | VC | com.vmware.vc.host.vFlash.modulesLoadedEvent| vSphere Flash modules are loaded or reloaded on the host Since 5.5 Reference
com.vmware.vc.host.vFlash.SsdConfigurationFailedEvent | error | ESXHostStorage | com.vmware.vc.host.vFlash.SsdConfigurationFailedEvent| {1} on disk '{2}' failed due to {3} Since 5.5 Reference
com.vmware.vc.host.vFlash.VFlashResourceCapacityExtendedEvent | info | VC | com.vmware.vc.host.vFlash.VFlashResourceCapacityvSphere Flash resource capacity is extended Since 5.5 Reference
com.vmware.vc.host.vFlash.VFlashResourceConfiguredEvent | info | VC | com.vmware.vc.host.vFlash.VFlashResourceConfiguredEvent| vSphere Flash resource is configured on the host Since 5.5 Reference
com.vmware.vc.host.vFlash.VFlashResourceRemovedEvent | info | VC | com.vmware.vc.host.vFlash.VFlashResourceRemovedEvent| vSphere Flash resource is removed from the host Since 5.5 Reference
com.vmware.vc.npt.VmAdapterEnteredPassthroughEvent | info | VC | com.vmware.vc.npt.VmAdapterEnteredPassthroughEvent| Network passthrough is active on adapter {deviceLabel} of virtual machine {vm.name} on host {host.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.npt.VmAdapterExitedPassthroughEvent | info | VC | com.vmware.vc.npt.VmAdapterExitedPassthroughEvent| Network passthrough is inactive on adapter {deviceLabel} of virtual machine {vm.name} on host {host.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.ovfconsumers.CloneOvfConsumerStateErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.CloneOvfConsumerStateErrorEvent| Failed to clone state for the entity '{entityName}' on extension {extensionName} Since 5.0 Reference
com.vmware.vc.ovfconsumers.GetOvfEnvironmentSectionsErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.GetOvfEnvironmentSectionsErrorEvent| Failed to retrieve OVF environment sections for VM '{vm.name}' from extension {extensionName} Since 5.0 Reference
com.vmware.vc.ovfconsumers.PowerOnAfterCloneErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.PowerOnAfterCloneErrorEvent| Powering on VM '{vm.name}' after cloning was blocked by an extension. Message: {description} Since 5.0 Reference
com.vmware.vc.ovfconsumers.RegisterEntityErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.RegisterEntityErrorEvent| Failed to register entity '{entityName}' on extension {extensionName} Since 5.0 Reference
com.vmware.vc.ovfconsumers.UnregisterEntitiesErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.UnregisterEntitiesErrorEvent| Failed to unregister entities on extension {extensionName} Since 5.0 Reference
com.vmware.vc.ovfconsumers.ValidateOstErrorEvent | warning | VC | com.vmware.vc.ovfconsumers.ValidateOstErrorEvent| Failed to validate OVF descriptor on extension {extensionName} Since 5.0 Reference
com.vmware.vc.profile.AnswerFileExportedEvent | info | VC | com.vmware.vc.profile.AnswerFileExportedEvent| Answer file for host {host.name} in datacenter {datacenter.name} has been exported Since 5.0 Reference
com.vmware.vc.profile.AnswerFileUpdatedEvent | info | VC | com.vmware.vc.profile.AnswerFileUpdatedEvent| Answer file for host {host.name} in datacenter {datacenter.name} has been updated Since 5.0 Reference
com.vmware.vc.rp.ResourcePoolRenamedEvent | info | VC | com.vmware.vc.rp.ResourcePoolRenamedEvent| Resource pool '{oldName}' has been renamed to '{newName}' Since 5.1 Reference
com.vmware.vc.sdrs.CanceledDatastoreMaintenanceModeEvent | info | VC | com.vmware.vc.sdrs.CanceledDatastoreMaintenanceModeEvent| The datastore maintenance mode operation has been canceled Since 5.0 Reference
com.vmware.vc.sdrs.ConfiguredStorageDrsOnPodEvent | info | VC | com.vmware.vc.sdrs.ConfiguredStorageDrsOnPodEvent| Configured storage DRS on datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sdrs.ConsistencyGroupViolationEvent | warning | VC | com.vmware.vc.sdrs.ConsistencyGroupViolationEvent| Datastore cluster {objectName} has datastores that belong to different SRM Consistency Groups Since 5.1 Reference
com.vmware.vc.sdrs.DatastoreEnteredMaintenanceModeEvent | info | VC | com.vmware.vc.sdrs.DatastoreEnteredMaintenanceModeEvent| Datastore {ds.name} has entered maintenance mode Since 5.0 Reference
com.vmware.vc.sdrs.DatastoreEnteringMaintenanceModeEvent | info | VC | com.vmware.vc.sdrs.DatastoreEnteringMaintenanceModeEvent| Datastore {ds.name} is entering maintenance mode Since 5.0 Reference
com.vmware.vc.sdrs.DatastoreExitedMaintenanceModeEvent | info | VC | com.vmware.vc.sdrs.DatastoreExitedMaintenanceModeEvent| Datastore {ds.name} has exited maintenance mode Since 5.0 Reference
com.vmware.vc.sdrs.DatastoreInMultipleDatacentersEvent | warning | VC | com.vmware.vc.sdrs.DatastoreInMultipleDatacentersEvent| Datastore cluster {objectName} has one or more datastores: {datastore} shared across multiple datacenters Since 5.0 Reference
com.vmware.vc.sdrs.DatastoreMaintenanceModeErrorsEvent | error | VC | com.vmware.vc.sdrs.DatastoreMaintenanceModeErrorsEvent| Datastore {ds.name} encountered errors while entering maintenance mode Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsDisabledEvent | info | VC | com.vmware.vc.sdrs.StorageDrsDisabledEvent| Disabled storage DRS on datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsEnabledEvent | info | VC | com.vmware.vc.sdrs.StorageDrsEnabledEvent| Enabled storage DRS on datastore cluster {objectName} with automation level {behavior.@enum.storageDrs.PodConfigInfo.Behavior} Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsInvocationFailedEvent | error | VC | com.vmware.vc.sdrs.StorageDrsInvocationFailedEvent| Storage DRS invocation failed on datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsNewRecommendationPendingEvent | info | VC | com.vmware.vc.sdrs.StorageDrsNewRecommendationPendingEvent| A new storage DRS recommendation has been generated on datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsNotSupportedHostConnectedToPodEvent | warning | VC | com.vmware.vc.sdrs.StorageDrsNotSupportedHostConnectedToPodEvent| Datastore cluster {objectName} is connected to one or more hosts: {host} that do not support storage DRS Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsRecommendationApplied | info | VC | com.vmware.vc.sdrs.StorageDrsRecommendationApplied| All pending recommendations on datastore cluster {objectName} were applied Since 5.5 Reference
com.vmware.vc.sdrs.StorageDrsStorageMigrationEvent | info | VC | com.vmware.vc.sdrs.StorageDrsStorageMigrationEvent| Storage DRS migrated disks of VM {vm.name} to datastore {ds.name} Since 5.0 Reference
com.vmware.vc.sdrs.StorageDrsStoragePlacementEvent | info | VC | com.vmware.vc.sdrs.StorageDrsStoragePlacementEvent| Storage DRS placed disks of VM {vm.name} on datastore {ds.name} Since 5.0 Reference
com.vmware.vc.sdrs.StoragePodCreatedEvent | info | VC | com.vmware.vc.sdrs.StoragePodCreatedEvent| Created datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sdrs.StoragePodDestroyedEvent | info | VC | com.vmware.vc.sdrs.StoragePodDestroyedEvent| Removed datastore cluster {objectName} Since 5.0 Reference
com.vmware.vc.sioc.NotSupportedHostConnectedToDatastoreEvent | warning | VC | com.vmware.vc.sioc.NotSupportedHostConnectedToDatastoreEvent| SIOC has detected that a host: {host} connected to a SIOC-enabled datastore: {objectName} is running an older version of ESX that does not support SIOC. This is an unsupported configuration. Since 5.0 Reference
com.vmware.vc.sms.datastore.ComplianceStatusCompliantEvent | info | VC | com.vmware.vc.sms.datastore.ComplianceStatusCompliantEvent| Virtual disk {diskKey} on {vmName} connected to datastore {datastore.name} in {datacenter.name} is compliant from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.sms.datastore.ComplianceStatusNonCompliantEvent | error | VirtualMachine | com.vmware.vc.sms.datastore.ComplianceStatusNonCompliantEvent| Virtual disk {diskKey} on {vmName} connected to {datastore.name} in {datacenter.name} is not compliant {operationalStatus] from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.sms.datastore.ComplianceStatusUnknownEvent | warning | VC | com.vmware.vc.sms.datastore.ComplianceStatusUnknownEvent| Virtual disk {diskKey} on {vmName} connected to {datastore.name} in {datacenter.name} compliance status is unknown from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.sms.LunCapabilityInitEvent | info | VC | com.vmware.vc.sms.LunCapabilityInitEvent| Storage provider system default capability event Since 5.0 Reference
com.vmware.vc.sms.LunCapabilityMetEvent | info | VC | com.vmware.vc.sms.LunCapabilityMetEvent| Storage provider system capability requirements met Since 5.0 Reference
com.vmware.vc.sms.LunCapabilityNotMetEvent | info | VC | com.vmware.vc.sms.LunCapabilityNotMetEvent| Storage provider system capability requirements not met Since 5.0 Reference
com.vmware.vc.sms.provider.health.event | info | VC | com.vmware.vc.sms.provider.health.event| {msgTxt} Since 5.0 Reference
com.vmware.vc.sms.provider.system.event | info | VC | com.vmware.vc.sms.provider.system.event| {msgTxt} Since 5.0 Reference
com.vmware.vc.sms.ThinProvisionedLunThresholdClearedEvent | info | VC | com.vmware.vc.sms.ThinProvisionedLunThresholdClearedEvent| Storage provider thin provisioning capacity threshold reached Since 5.0 Reference
com.vmware.vc.sms.ThinProvisionedLunThresholdCrossedEvent | info | VC | com.vmware.vc.sms.ThinProvisionedLunThresholdCrossedEvent| Storage provider thin provisioning capacity threshold crossed Since 5.0 Reference
com.vmware.vc.sms.ThinProvisionedLunThresholdInitEvent | info | VC | com.vmware.vc.sms.ThinProvisionedLunThresholdInitEvent| Storage provider thin provisioning default capacity event Since 5.0 Reference
com.vmware.vc.sms.vm.ComplianceStatusCompliantEvent | info | VC | com.vmware.vc.sms.vm.ComplianceStatusCompliantEvent| Virtual disk {diskKey} on {vm.name} on {host.name} and {computeResource.name} in {datacenter.name} is compliant from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.sms.vm.ComplianceStatusNonCompliantEvent | error | VC | com.vmware.vc.sms.vm.ComplianceStatusNonCompliantEvent| Virtual disk {diskKey} on {vm.name} on {host.name} and {computeResource.name} in {datacenter.name} is not compliant {operationalStatus] from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.sms.vm.ComplianceStatusUnknownEvent | warning | VC | com.vmware.vc.sms.vm.ComplianceStatusUnknownEvent| Virtual disk {diskKey} on {vm.name} on {host.name} and {computeResource.name} in {datacenter.name} compliance status is unknown from storage provider {providerName}. Since 5.5 Reference
com.vmware.vc.spbm.ProfileAssociationFailedEvent | error | VC | com.vmware.vc.spbm.ProfileAssociationFailedEvent| Profile association/dissociation failed for {entityName} Since 5.5 Reference
com.vmware.vc.stats.HostQuickStatesNotUpToDateEvent | info | VC | com.vmware.vc.stats.HostQuickStatesNotUpToDateEvent| Quick stats on {host.name} in {computeResource.name} in {datacenter.name} is not up-to-date Since 5.0 Reference
com.vmware.vc.VCHealthStateChangedEvent | info | VC | com.vmware.vc.VCHealthStateChangedEvent| vCenter Service overall health changed from '{oldState}' to '{newState}' Since 4.1 Reference
com.vmware.vc.vcp.FtDisabledVmTreatAsNonFtEvent | info | VC | com.vmware.vc.vcp.FtDisabledVmTreatAsNonFtEvent| HA VM Component Protection protects virtual machine {vm.name} on {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} as non-FT virtual machine because the FT state is disabled Since 4.1 Reference
com.vmware.vc.vcp.FtFailoverEvent | info | VC | com.vmware.vc.vcp.FtFailoverEvent| FT Primary VM {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} is going to fail over to Secondary VM due to component failure Since 4.1 Reference
com.vmware.vc.vcp.FtFailoverFailedEvent | error | VirtualMachine | com.vmware.vc.vcp.FtFailoverFailedEvent| FT virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} failed to failover to secondary Since 4.1 Reference
com.vmware.vc.vcp.FtSecondaryRestartEvent | info | VC | com.vmware.vc.vcp.FtSecondaryRestartEvent| HA VM Component Protection is restarting FT secondary virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} due to component failure Since 4.1 Reference
com.vmware.vc.vcp.FtSecondaryRestartFailedEvent | error | VirtualMachine | com.vmware.vc.vcp.FtSecondaryRestartFailedEvent| FT Secondary VM {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} failed to restart Since 4.1 Reference
com.vmware.vc.vcp.NeedSecondaryFtVmTreatAsNonFtEvent | info | VC | com.vmware.vc.vcp.NeedSecondaryFtVmTreatAsNonFtEvent| HA VM Component Protection protects virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} as non-FT virtual machine because it has been in the needSecondary state too long Since 4.1 Reference
com.vmware.vc.vcp.TestEndEvent | info | VC | com.vmware.vc.vcp.TestEndEvent| VM Component Protection test ends on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.vcp.TestStartEvent | info | VC | com.vmware.vc.vcp.TestStartEvent| VM Component Protection test starts on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.vcp.VcpNoActionEvent | info | VC | com.vmware.vc.vcp.VcpNoActionEvent| HA VM Component Protection did not take action on virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} due to the feature configuration setting Since 4.1 Reference
com.vmware.vc.vcp.VmDatastoreFailedEvent | error | VirtualMachine | com.vmware.vc.vcp.VmDatastoreFailedEvent| Virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} lost access to {datastore} Since 4.1 Reference
com.vmware.vc.vcp.VmNetworkFailedEvent | error | VirtualMachine | com.vmware.vc.vcp.VmNetworkFailedEvent| Virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} lost access to {network} Since 4.1 Reference
com.vmware.vc.vcp.VmPowerOffHangEvent | error | VirtualMachine | com.vmware.vc.vcp.VmPowerOffHangEvent| HA VM Component Protection could not power off virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} successfully after trying {numTimes} times and will keep trying Since 4.1 Reference
com.vmware.vc.vcp.VmRestartEvent | info | VC | com.vmware.vc.vcp.VmRestartEvent| HA VM Component Protection is restarting virtual machine {vm.name} due to component failure on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 4.1 Reference
com.vmware.vc.vcp.VmRestartFailedEvent | error | VirtualMachine | com.vmware.vc.vcp.VmRestartFailedEvent| Virtual machine {vm.name} affected by component failure on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} failed to restart Since 4.1 Reference
com.vmware.vc.vcp.VmWaitForCandidateHostEvent | error | VirtualMachine | com.vmware.vc.vcp.VmWaitForCandidateHostEvent| HA VM Component Protection could not find a destination host for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} after waiting {numSecWait} seconds and will keep trying Since 4.1 Reference
com.vmware.vc.vm.VmRegisterFailedEvent | error | VC | com.vmware.vc.vm.VmRegisterFailedEvent| Virtual machine {vm.name} registration on {host.name} in datacenter {datacenter.name} failed Since 5.0 Reference
com.vmware.vc.vm.VmStateFailedToRevertToSnapshot | error | VirtualMachine | com.vmware.vc.vm.VmStateFailedToRevertToSnapshot| Failed to revert the execution state of the virtual machine {vm.name} on host {host.name}, in compute resource {computeResource.name} to snapshot {snapshotName}, with ID {snapshotId} Since 5.0 Reference
com.vmware.vc.vm.VmStateRevertedToSnapshot | info | VC | com.vmware.vc.vm.VmStateRevertedToSnapshot| The execution state of the virtual machine {vm.name} on host {host.name}, in compute resource {computeResource.name} has been reverted to the state of snapshot {snapshotName}, with ID {snapshotId} Since 5.0 Reference
com.vmware.vc.vmam.AppMonitoringNotSupported | warning | VC | com.vmware.vc.vmam.AppMonitoringNotSupported| Application monitoring is not supported on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.vmam.VmAppHealthMonitoringStateChangedEvent | warning | VC | com.vmware.vc.vmam.VmAppHealthMonitoringStateChangedEvent| Application heartbeat status changed to {status} for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.vmam.VmAppHealthStateChangedEvent | warning | VirtualMachine | com.vmware.vc.vmam.VmAppHealthStateChangedEvent| vSphere HA detected that the application state changed to {state.@enum.vm.GuestInfo.AppStateType} for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 5.5 Reference
com.vmware.vc.vmam.VmDasAppHeartbeatFailedEvent | warning | VirtualMachine | com.vmware.vc.vmam.VmDasAppHeartbeatFailedEvent| Application heartbeat failed for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 4.1 Reference
com.vmware.vc.VmCloneFailedInvalidDestinationEvent | error | VC | com.vmware.vc.VmCloneFailedInvalidDestinationEvent| Cannot clone {vm.name} as {destVmName} to invalid or non-existent destination with ID {invalidMoRef}: {fault} Since 5.0 Reference
com.vmware.vc.VmCloneToResourcePoolFailedEvent | error | VC | com.vmware.vc.VmCloneToResourcePoolFailedEvent| Cannot clone {vm.name} as {destVmName} to resource pool {destResourcePool}: {fault} Since 5.0 Reference
com.vmware.vc.VmDiskConsolidatedEvent | info | VC | com.vmware.vc.VmDiskConsolidatedEvent| Virtual machine {vm.name} disks consolidated successfully on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
com.vmware.vc.VmDiskConsolidationNeeded | info | VC | com.vmware.vc.VmDiskConsolidationNeeded| Virtual machine {vm.name} disks consolidation is needed on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
com.vmware.vc.VmDiskConsolidationNoLongerNeeded | info | VC | com.vmware.vc.VmDiskConsolidationNoLongerNeeded| Virtual machine {vm.name} disks consolidation is no longer needed on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.1 Reference
com.vmware.vc.VmDiskFailedToConsolidateEvent | error | VirtualMachine | com.vmware.vc.VmDiskFailedToConsolidateEvent| Virtual machine {vm.name} disks consolidation failed on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
com.vmware.vc.vsan.DatastoreNoCapacityEvent | error | VC | com.vmware.vc.vsan.DatastoreNoCapacityEvent| VSAN datastore {datastoreName} in cluster {computeResource.name} in datacenter {datacenter.name} does not have capacity Since 5.5 Reference
com.vmware.vc.vsan.HostCommunicationErrorEvent | error | ESXHost | com.vmware.vc.vsan.HostCommunicationErrorEvent| event.com.vmware.vc.vsan.HostCommunicationErrorEvent.fullFormat Since 5.5 Reference
com.vmware.vc.vsan.HostNotInClusterEvent | error | VC | com.vmware.vc.vsan.HostNotInClusterEvent| {host.name} with the VSAN service enabled is not in the vCenter cluster {computeResource.name} in datacenter {datacenter.name} Since 5.5 Reference
com.vmware.vc.vsan.HostNotInVsanClusterEvent | error | VC | com.vmware.vc.vsan.HostNotInVsanClusterEvent| {host.name} is in a VSAN enabled cluster {computeResource.name} in datacenter {datacenter.name} but does not have VSAN service enabled Since 5.5 Reference
com.vmware.vc.vsan.HostVendorProviderDeregistrationFailedEvent | error | VC | com.vmware.vc.vsan.HostVendorProviderDeregistrationFailedEvent| Vendor provider {host.name} deregistration failed Since 5.5 Reference
com.vmware.vc.vsan.HostVendorProviderDeregistrationSuccessEvent | info | VC | com.vmware.vc.vsan.HostVendorProviderDeregistrationSuccessEvent| Vendor provider {host.name} deregistration succeeded Since 5.5 Reference
com.vmware.vc.vsan.HostVendorProviderRegistrationFailedEvent | error | VC | com.vmware.vc.vsan.HostVendorProviderRegistrationFailedEvent| Vendor provider {host.name} registration failed Since 5.5 Reference
com.vmware.vc.vsan.HostVendorProviderRegistrationSuccessEvent | info | VC | com.vmware.vc.vsan.HostVendorProviderRegistrationSuccessEvent| Vendor provider {host.name} registration succeeded Since 5.5 Reference
com.vmware.vc.vsan.NetworkMisConfiguredEvent | error | ESXHostNetwork | com.vmware.vc.vsan.NetworkMisConfiguredEvent| VSAN network is not configured on {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 5.5 Reference
com.vmware.vc.vsan.RogueHostFoundEvent | error | VC | com.vmware.vc.vsan.RogueHostFoundEvent| Found another host participating in the VSAN service in cluster {computeResource.name} in datacenter {datacenter.name} which is not a member of this host's vCenter cluster Since 5.5 Reference
com.vmware.vim.eam.agency.create | info | VC | com.vmware.vim.eam.agency.create| {agencyName} created by {ownerName} Since 5.0 Reference
com.vmware.vim.eam.agency.destroyed | info | VC | com.vmware.vim.eam.agency.destroyed| {agencyName} removed from the vSphere ESX Agent Manager Since 5.0 Reference
com.vmware.vim.eam.agency.goalstate | info | VC | com.vmware.vim.eam.agency.goalstate| {agencyName} changed goal state from {oldGoalState} to {newGoalState} Since 5.0 Reference
com.vmware.vim.eam.agency.statusChanged | info | VC | com.vmware.vim.eam.agency.statusChanged| Agency status changed from {oldStatus} to {newStatus} Since 5.1 Reference
com.vmware.vim.eam.agency.updated | info | VC | com.vmware.vim.eam.agency.updated| Configuration updated {agencyName} Since 5.0 Reference
com.vmware.vim.eam.agent.created | info | VC | com.vmware.vim.eam.agent.created| Agent added to host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.destroyed | info | VC | com.vmware.vim.eam.agent.destroyed| Agent removed from host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.destroyedNoHost | info | VC | com.vmware.vim.eam.agent.destroyedNoHost| Agent removed from host ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterPowerOn | info | VC | com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterPowerOn| Agent VM {vm.name} has been powered on. Mark agent as available to proceed agent workflow ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterProvisioning | info | VC | com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterProvisioning| Agent VM {vm.name} has been provisioned. Mark agent as available to proceed agent workflow ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.statusChanged | info | VC | com.vmware.vim.eam.agent.statusChanged| Agent status changed from {oldStatus} to {newStatus} Since 5.1 Reference
com.vmware.vim.eam.agent.task.deleteVm | info | VC | com.vmware.vim.eam.agent.task.deleteVm| Agent VM {vmName} is deleted on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.task.deployVm | info | VC | com.vmware.vim.eam.agent.task.deployVm| Agent VM {vm.name} is provisioned on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.task.powerOffVm | info | VC | com.vmware.vim.eam.agent.task.powerOffVm| Agent VM {vm.name} powered off, on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.task.powerOnVm | info | VC | com.vmware.vim.eam.agent.task.powerOnVm| Agent VM {vm.name} powered on, on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.task.vibInstalled | info | VC | com.vmware.vim.eam.agent.task.vibInstalled| Agent installed VIB {vib} on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.agent.task.vibUninstalled | info | VC | com.vmware.vim.eam.agent.task.vibUninstalled| Agent uninstalled VIB {vib} on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.cannotAccessAgentOVF | warning | VC | com.vmware.vim.eam.issue.cannotAccessAgentOVF| Unable to access agent OVF package at {url} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.cannotAccessAgentVib | warning | VC | com.vmware.vim.eam.issue.cannotAccessAgentVib| Unable to access agent VIB module at {url} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.hostInMaintenanceMode | warning | VC | com.vmware.vim.eam.issue.hostInMaintenanceMode| Agent cannot complete an operation since the host {host.name} is in maintenance mode ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.hostInStandbyMode | warning | VC | com.vmware.vim.eam.issue.hostInStandbyMode| Agent cannot complete an operation since the host {host.name} is in standby mode ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.hostPoweredOff | warning | VC | com.vmware.vim.eam.issue.hostPoweredOff| Agent cannot complete an operation since the host {host.name} is powered off ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.incompatibleHostVersion | warning | VC | com.vmware.vim.eam.issue.incompatibleHostVersion| Agent is not deployed due to incompatible host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.insufficientIpAddresses | warning | VC | com.vmware.vim.eam.issue.insufficientIpAddresses| Insufficient IP addresses in IP pool in agent's VM network ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.insufficientResources | warning | VC | com.vmware.vim.eam.issue.insufficientResources| Agent cannot be provisioned due to insufficient resources on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.insufficientSpace | warning | VC | com.vmware.vim.eam.issue.insufficientSpace| Agent on {host.name} cannot be provisioned due to insufficient space on datastore ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.missingAgentIpPool | warning | VC | com.vmware.vim.eam.issue.missingAgentIpPool| No IP pool in agent's VM network ({agencyname}) Since 5.0 Reference
com.vmware.vim.eam.issue.missingDvFilterSwitch | warning | VC | com.vmware.vim.eam.issue.missingDvFilterSwitch| dvFilter switch is not configured on host {host.name} ({agencyname}) Since 5.0 Reference
com.vmware.vim.eam.issue.noAgentVmDatastore | warning | VC | com.vmware.vim.eam.issue.noAgentVmDatastore| No agent datastore configuration on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.noAgentVmNetwork | warning | VC | com.vmware.vim.eam.issue.noAgentVmNetwork| No agent network configuration on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.noCustomAgentVmDatastore | error | VC | com.vmware.vim.eam.issue.noCustomAgentVmDatastore| Agent datastore(s) {customAgentVmDatastoreName} not available on host {host.name} ({agencyName}) Since 5.5 Reference
com.vmware.vim.eam.issue.noCustomAgentVmNetwork | error | VC | com.vmware.vim.eam.issue.noCustomAgentVmNetwork| Agent network(s) {customAgentVmNetworkName} not available on host {host.name} ({agencyName}) Since 5.1 Reference
com.vmware.vim.eam.issue.orphandedDvFilterSwitch | warning | VC | com.vmware.vim.eam.issue.orphandedDvFilterSwitch| Unused dvFilter switch on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.orphanedAgency | warning | VC | com.vmware.vim.eam.issue.orphanedAgency| Orphaned agency found. ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.ovfInvalidFormat | warning | VC | com.vmware.vim.eam.issue.ovfInvalidFormat| OVF used to provision agent on host {host.name} has invalid format ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.ovfInvalidProperty | warning | VC | com.vmware.vim.eam.issue.ovfInvalidProperty| OVF environment used to provision agent on host {host.name} has one or more invalid properties ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.resolved | info | VC | com.vmware.vim.eam.issue.resolved| Issue {type} resolved (key {key}) Since 5.1 Reference
com.vmware.vim.eam.issue.unknownAgentVm | warning | VC | com.vmware.vim.eam.issue.unknownAgentVm| Unknown agent VM {vm.name} Since 5.0 Reference
com.vmware.vim.eam.issue.vibCannotPutHostInMaintenanceMode | warning | VC | com.vmware.vim.eam.issue.vibCannotPutHostInMaintenanceMode| Cannot put host into maintenance mode ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibInvalidFormat | warning | VC | com.vmware.vim.eam.issue.vibInvalidFormat| Invalid format for VIB module at {url} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibNotInstalled | warning | VC | com.vmware.vim.eam.issue.vibNotInstalled| VIB module for agent is not installed on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibRequiresHostInMaintenanceMode | error | VC | com.vmware.vim.eam.issue.vibRequiresHostInMaintenanceMode| Host must be put into maintenance mode to complete agent VIB installation ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibRequiresHostReboot | error | VC | com.vmware.vim.eam.issue.vibRequiresHostReboot| Host {host.name} must be reboot to complete agent VIB installation ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibRequiresManualInstallation | error | VC | com.vmware.vim.eam.issue.vibRequiresManualInstallation| VIB {vib} requires manual installation on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vibRequiresManualUninstallation | error | VC | com.vmware.vim.eam.issue.vibRequiresManualUninstallation| VIB {vib} requires manual uninstallation on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmCorrupted | warning | VC | com.vmware.vim.eam.issue.vmCorrupted| Agent VM {vm.name} on host {host.name} is corrupted ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmDeployed | warning | VC | com.vmware.vim.eam.issue.vmDeployed| Agent VM {vm.name} is provisioned on host {host.name} when it should be removed ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmMarkedAsTemplate | warning | VC | com.vmware.vim.eam.issue.vmMarkedAsTemplate| Agent VM {vm.name} on host {host.name} is marked as template ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmNotDeployed | warning | VC | com.vmware.vim.eam.issue.vmNotDeployed| Agent VM is missing on host {host.name} ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmOrphaned | warning | VC | com.vmware.vim.eam.issue.vmOrphaned| Orphaned agent VM {vm.name} on host {host.name} detected ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmPoweredOff | warning | VC | com.vmware.vim.eam.issue.vmPoweredOff| Agent VM {vm.name} on host {host.name} is expected to be powered on ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmPoweredOn | warning | VC | com.vmware.vim.eam.issue.vmPoweredOn| Agent VM {vm.name} on host {host.name} is expected to be powered off ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmSuspended | warning | VC | com.vmware.vim.eam.issue.vmSuspended| Agent VM {vm.name} on host {host.name} is expected to be powered on but is suspended ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmWrongFolder | warning | VC | com.vmware.vim.eam.issue.vmWrongFolder| Agent VM {vm.name} on host {host.name} is in the wrong VM folder ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.issue.vmWrongResourcePool | warning | VC | com.vmware.vim.eam.issue.vmWrongResourcePool| Agent VM {vm.name} on host {host.name} is in the resource pool ({agencyName}) Since 5.0 Reference
com.vmware.vim.eam.login.invalid | warning | VC | com.vmware.vim.eam.login.invalid| Failed login to vSphere ESX Agent Manager Since 5.0 Reference
com.vmware.vim.eam.login.succeeded | info | VC | com.vmware.vim.eam.login.succeeded| Successful login by {user} into vSphere ESX Agent Manager Since 5.0 Reference
com.vmware.vim.eam.logout | info | VC | com.vmware.vim.eam.logout| User {user} logged out of vSphere ESX Agent Manager by logging out of the vCenter server Since 5.0 Reference
com.vmware.vim.eam.task.scanForUnknownAgentVmsCompleted | info | VC | com.vmware.vim.eam.task.scanForUnknownAgentVmsCompleted| Scan for unknown agent VMs completed Since 5.0 Reference
com.vmware.vim.eam.task.scanForUnknownAgentVmsInitiated | info | VC | com.vmware.vim.eam.task.scanForUnknownAgentVmsInitiated| Scan for unknown agent VMs initiated Since 5.0 Reference
com.vmware.vim.eam.task.setupDvFilter | info | VC | com.vmware.vim.eam.task.setupDvFilter| DvFilter switch '{switchName}' is setup on host {host.name} Since 5.0 Reference
com.vmware.vim.eam.task.tearDownDvFilter | info | VC | com.vmware.vim.eam.task.tearDownDvFilter| DvFilter switch '{switchName}' is teared down on host {host.name} Since 5.0 Reference
com.vmware.vim.eam.unauthorized.access | warning | VC | com.vmware.vim.eam.unauthorized.access| Unauthorized access by {user} in vSphere ESX Agent Manager Since 5.0 Reference
com.vmware.vim.eam.vum.failedtouploadvib | error | VC | com.vmware.vim.eam.vum.failedtouploadvib| Failed to upload {vibUrl} to VMware Update Manager ({agencyName}) Since 5.0 Reference
com.vmware.vim.vsm.dependency.bind.vApp | info | VC | com.vmware.vim.vsm.dependency.bind.vApp| event.com.vmware.vim.vsm.dependency.bind.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.bind.vm | info | VC | com.vmware.vim.vsm.dependency.bind.vm| event.com.vmware.vim.vsm.dependency.bind.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.create.vApp | info | VC | com.vmware.vim.vsm.dependency.create.vApp| event.com.vmware.vim.vsm.dependency.create.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.create.vm | info | VC | com.vmware.vim.vsm.dependency.create.vm| event.com.vmware.vim.vsm.dependency.create.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.destroy.vApp | info | VC | com.vmware.vim.vsm.dependency.destroy.vApp| event.com.vmware.vim.vsm.dependency.destroy.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.destroy.vm | info | VC | com.vmware.vim.vsm.dependency.destroy.vm| event.com.vmware.vim.vsm.dependency.destroy.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.reconfigure.vApp | info | VC | com.vmware.vim.vsm.dependency.reconfigure.vApp| event.com.vmware.vim.vsm.dependency.reconfigure.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.reconfigure.vm | info | VC | com.vmware.vim.vsm.dependency.reconfigure.vm| event.com.vmware.vim.vsm.dependency.reconfigure.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.unbind.vApp | info | VC | com.vmware.vim.vsm.dependency.unbind.vApp| event.com.vmware.vim.vsm.dependency.unbind.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.unbind.vm | info | VC | com.vmware.vim.vsm.dependency.unbind.vm| event.com.vmware.vim.vsm.dependency.unbind.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.update.vApp | info | VC | com.vmware.vim.vsm.dependency.update.vApp| event.com.vmware.vim.vsm.dependency.update.vApp.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.dependency.update.vm | info | VC | com.vmware.vim.vsm.dependency.update.vm| event.com.vmware.vim.vsm.dependency.update.vm.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.provider.register | info | VC | com.vmware.vim.vsm.provider.register| event.com.vmware.vim.vsm.provider.register.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.provider.unregister | info | VC | com.vmware.vim.vsm.provider.unregister| event.com.vmware.vim.vsm.provider.unregister.fullFormat Since 5.0 Reference
com.vmware.vim.vsm.provider.update | info | VC | com.vmware.vim.vsm.provider.update| event.com.vmware.vim.vsm.provider.update.fullFormat Since 5.0 Reference
CustomFieldDefAddedEvent | info | VC | Created new custom field definition {name} Since 2.0 Reference
CustomFieldDefEvent | info | VC | This event records a custom field definition event. Since 2.0 Reference
CustomFieldDefRemovedEvent | info | VC | Removed field definition {name} Since 2.0 Reference
CustomFieldDefRenamedEvent | info | VC | Renamed field definition from {name} to {newName} Since 2.0 Reference
CustomFieldValueChangedEvent | info | VC | Changed custom field {name} on {entity.name} in {datacenter.name} to {value} Since 2.0 Reference
CustomizationFailed | warning | VC | Cannot complete customization of VM {vm.name}. See customization log at {logLocation} on the guest OS for details. Since 2.5 Reference
CustomizationLinuxIdentityFailed | warning | VC | An error occurred while setting up Linux identity. See log file '{logLocation}' on guest OS for details. Since 2.5 Reference
CustomizationNetworkSetupFailed | warning | VC | An error occurred while setting up network properties of the guest OS. See the log file {logLocation} in the guest OS for details. Since 2.5 Reference
CustomizationStartedEvent | info | VC | Started customization of VM {vm.name}. Customization log located at {logLocation} in the guest OS. Since 2.5 Reference
CustomizationSucceeded | info | VC | Customization of VM {vm.name} succeeded. Customization log located at {logLocation} in the guest OS. Since 2.5 Reference
CustomizationSysprepFailed | warning | VC | The version of Sysprep {sysprepVersion} provided for customizing VM {vm.name} does not match the version of guest OS {systemVersion}. See the log file {logLocation} in the guest OS for more information. Since 2.5 Reference
CustomizationUnknownFailure | warning | VC | An error occurred while customizing VM {vm.name}. For details reference the log file {logLocation} in the guest OS. Since 2.5 Reference
DasAdmissionControlDisabledEvent | info | VC | HA admission control disabled on cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasAdmissionControlEnabledEvent | info | VC | HA admission control enabled on cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasAgentFoundEvent | info | VC | Re-established contact with a primary host in this HA cluster Since 2.0 Reference
DasAgentUnavailableEvent | error | Cluster | Unable to contact a primary HA agent in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasClusterIsolatedEvent | error | Cluster | All hosts in the HA cluster {computeResource.name} in {datacenter.name} were isolated from the network. Check the network configuration for proper network redundancy in the management network. Since 4.0 Reference
DasDisabledEvent | info | VC | HA disabled on cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasEnabledEvent | info | VC | HA enabled on cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasHostFailedEvent | error | Cluster | A possible host failure has been detected by HA on {failedHost.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DasHostIsolatedEvent | warning | Cluster | Host {isolatedHost.name} has been isolated from cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DatacenterCreatedEvent | info | VC | Created datacenter {datacenter.name} in folder {parent.name} Since 2.5 Reference
DatacenterRenamedEvent | info | VC | Renamed datacenter from {oldName} to {newName} Since 2.5 Reference
DatastoreCapacityIncreasedEvent | info | VC | Datastore {datastore.name} increased in capacity from {oldCapacity} bytes to {oldCapacity} bytes in {datacenter.name} Since 4.0 Reference
DatastoreDestroyedEvent | info | VC | Removed unconfigured datastore {datastore.name} Since 2.0 Reference
DatastoreDiscoveredEvent | info | VC | Discovered datastore {datastore.name} on {host.name} in {datacenter.name} Since 2.0 Reference
DatastoreDuplicatedEvent | error | VC | Multiple datastores named {datastore} detected on host {host.name} in {datacenter.name} Since 2.0 Reference
DatastoreFileCopiedEvent | info | VC | File or directory {sourceFile} copied from {sourceDatastore.name} to {datastore.name} as {targetFile} Since 4.0 Reference
DatastoreFileDeletedEvent | info | VC | File or directory {targetFile} deleted from {datastore.name} Since 4.0 Reference
DatastoreFileMovedEvent | info | VC | File or directory {sourceFile} moved from {sourceDatastore.name} to {datastore.name} as {targetFile} Since 4.0 Reference
DatastoreIORMReconfiguredEvent | info | VC | Reconfigured Storage I/O Control on datastore {datastore.name} Since 4.1 Reference
DatastorePrincipalConfigured | info | VC | Configured datastore principal {datastorePrincipal} on host {host.name} in {datacenter.name} Since 2.0 Reference
DatastoreRemovedOnHostEvent | info | VC | Removed datastore {datastore.name} from {host.name} in {datacenter.name} Since 2.0 Reference
DatastoreRenamedEvent | info | VC | Renamed datastore from {oldName} to {newName} in {datacenter.name} Since 2.0 Reference
DatastoreRenamedOnHostEvent | info | VC | Renamed datastore from {oldName} to {newName} in {datacenter.name} Since 2.0 Reference
DrsDisabledEvent | info | VC | Disabled DRS on cluster {computeResource.name} in datacenter {datacenter.name} Since 2.0 Reference
DrsEnabledEvent | info | VC | Enabled DRS on {computeResource.name} with automation level {behavior} in {datacenter.name} Since 2.0 Reference
DrsEnteredStandbyModeEvent | info | VC | DRS put {host.name} into standby mode Since 2.5 Reference
DrsEnteringStandbyModeEvent | info | VC | DRS is putting {host.name} into standby mode Since 4.0 Reference
DrsExitedStandbyModeEvent | info | VC | DRS moved {host.name} out of standby mode Since 2.5 Reference
DrsExitingStandbyModeEvent | info | VC | DRS is moving {host.name} out of standby mode Since 4.0 Reference
DrsExitStandbyModeFailedEvent | error | ESXHost | DRS cannot move {host.name} out of standby mode Since 4.0 Reference
DrsInvocationFailedEvent | error | Cluster | DRS invocation not completed Since 4.0 Reference
DrsRecoveredFromFailureEvent | info | VC | DRS has recovered from the failure Since 4.0 Reference
DrsResourceConfigureFailedEvent | error | Cluster | Unable to apply DRS resource settings on host {host.name} in {datacenter.name}. {reason.msg}. This can significantly reduce the effectiveness of DRS. Since 2.0 Reference
DrsResourceConfigureSyncedEvent | info | VC | Resource configuration specification returns to synchronization from previous failure on host '{host.name}' in {datacenter.name} Since 2.0 Reference
DrsRuleComplianceEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is now compliant with DRS VM-Host affinity rules Since 4.1 Reference
DrsRuleViolationEvent | warning | VirtualMachine | {vm.name} on {host.name} in {datacenter.name} is violating a DRS VM-Host affinity rule Since 4.1 Reference
DrsVmMigratedEvent | info | VC | DRS migrated {vm.name} from {sourceHost.name} to {host.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
DrsVmPoweredOnEvent | info | VC | DRS powered On {vm.name} on {host.name} in {datacenter.name} Since 2.5 Reference
DuplicateIpDetectedEvent | warning | ESXHostNetwork | Virtual machine {macAddress} on host {host.name} has a duplicate IP {duplicateIP} Since 2.5 Reference
DvpgImportEvent | info | VC | Import operation with type {importType} was performed on {net.name} Since 5.1 Reference
DvpgRestoreEvent | info | VC | Restore operation was performed on {net.name} Since 5.1 Reference
DVPortgroupCreatedEvent | info | VC | Distributed virtual port group {net.name} in {datacenter.name} was added to switch {dvs.name}. Since 4.0 Reference
DVPortgroupDestroyedEvent | info | VC | Distributed virtual port group {net.name} in {datacenter.name} was deleted. Since 4.0 Reference
DVPortgroupReconfiguredEvent | info | VC | Distributed virtual port group {net.name} in {datacenter.name} was reconfigured. Since 4.0 Reference
DVPortgroupRenamedEvent | info | VC | Distributed virtual port group {oldName} in {datacenter.name} was renamed to {newName} Since 4.0 Reference
DvsCreatedEvent | info | VC | A Distributed Virtual Switch {dvs.name} was created in {datacenter.name}. Since 4.0 Reference
DvsDestroyedEvent | info | VC | Distributed Virtual Switch {dvs.name} in {datacenter.name} was deleted. Since 4.0 Reference
DvsEvent | info | VC | Distributed Virtual Switch event Since 4.0 Reference
DvsHealthStatusChangeEvent | info | VC | Health check status was changed in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name} Since 5.1 Reference
DvsHostBackInSyncEvent | info | VC | The Distributed Virtual Switch {dvs.name} configuration on the host was synchronized with that of the vCenter Server. Since 4.0 Reference
DvsHostJoinedEvent | info | VC | The host {hostJoined.name} joined the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsHostLeftEvent | info | VC | The host {hostLeft.name} left the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsHostStatusUpdated | info | VC | The host {hostMember.name} changed status on the vNetwork Distributed Switch {dvs.name} in {datacenter.name} Since 4.1 Reference
DvsHostWentOutOfSyncEvent | warning | ESXHostNetwork | The Distributed Virtual Switch {dvs.name} configuration on the host differed from that of the vCenter Server. Since 4.0 Reference
DvsImportEvent | info | VC | Import operation with type {importType} was performed on {dvs.name} Since 5.1 Reference
DvsMergedEvent | info | VC | Distributed Virtual Switch {srcDvs.name} was merged into {dstDvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortBlockedEvent | info | VC | Port {portKey} was blocked in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortConnectedEvent | info | VC | The port {portKey} was connected in the Distributed Virtual Switch {dvs.name} in {datacenter.name} Since 4.0 Reference
DvsPortCreatedEvent | info | VC | New ports were created in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortDeletedEvent | info | VC | Deleted ports in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortDisconnectedEvent | info | VC | The port {portKey} was disconnected in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortEnteredPassthruEvent | info | VC | dvPort {portKey} entered passthrough mode in the vNetwork Distributed Switch {dvs.name} in {datacenter.name} Since 4.1 Reference
DvsPortExitedPassthruEvent | info | VC | dvPort {portKey} exited passthrough mode in the vNetwork Distributed Switch {dvs.name} in {datacenter.name} Since 4.1 Reference
DvsPortJoinPortgroupEvent | info | VC | Port {portKey} was moved into the distributed virtual port group {portgroupName} in {datacenter.name}. Since 4.0 Reference
DvsPortLeavePortgroupEvent | info | VC | Port {portKey} was moved out of the distributed virtual port group {portgroupName} in {datacenter.name}. Since 4.0 Reference
DvsPortLinkDownEvent | warning | VC | The port {portKey} link was down in the Distributed Virtual Switch {dvs.name} in {datacenter.name} Since 4.0 Reference
DvsPortLinkUpEvent | info | VC | The port {portKey} link was up in the Distributed Virtual Switch {dvs.name} in {datacenter.name} Since 4.0 Reference
DvsPortReconfiguredEvent | info | VC | Reconfigured ports in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortRuntimeChangeEvent | info | VC | The dvPort {portKey} runtime information changed in the vSphere Distributed Switch {dvs.name} in {datacenter.name}. Since 5.0 Reference
DvsPortUnblockedEvent | info | VC | Port {portKey} was unblocked in the Distributed Virtual Switch {dvs.name} in {datacenter.name}. Since 4.0 Reference
DvsPortVendorSpecificStateChangeEvent | info | VC | The dvPort {portKey} vendor specific state changed in the vSphere Distributed Switch {dvs.name} in {datacenter.name}. Since 5.0 Reference
DvsReconfiguredEvent | info | VC | The Distributed Virtual Switch {dvs.name} in {datacenter.name} was reconfigured. Since 4.0 Reference
DvsRenamedEvent | info | VC | The Distributed Virtual Switch {oldName} in {datacenter.name} was renamed to {newName}. Since 4.0 Reference
DvsRestoreEvent | info | VC | Restore operation was performed on {dvs.name} Since 5.1 Reference
DvsUpgradeAvailableEvent | info | VC | An upgrade for the Distributed Virtual Switch {dvs.name} in datacenter {datacenter.name} is available. Since 4.0 Reference
DvsUpgradedEvent | info | VC | Distributed Virtual Switch {dvs.name} in datacenter {datacenter.name} was upgraded. Since 4.0 Reference
DvsUpgradeInProgressEvent | info | VC | An upgrade for the Distributed Virtual Switch {dvs.name} in datacenter {datacenter.name} is in progress. Since 4.0 Reference
DvsUpgradeRejectedEvent | info | VC | Cannot complete an upgrade for the Distributed Virtual Switch {dvs.name} in datacenter {datacenter.name} Since 4.0 Reference
EnteredMaintenanceModeEvent | info | VC | Host {host.name} in {datacenter.name} has entered maintenance mode Since 2.0 Reference
EnteredStandbyModeEvent | info | VC | The host {host.name} is in standby mode Since 2.5 Reference
EnteringMaintenanceModeEvent | info | VC | Host {host.name} in {datacenter.name} has started to enter maintenance mode Since 2.0 Reference
EnteringStandbyModeEvent | info | VC | The host {host.name} is entering standby mode Since 2.5 Reference
ErrorUpgradeEvent | error | VC | {message} Since 2.0 Reference
esx.audit.dcui.defaults.factoryrestore | warning | VC | esx.audit.dcui.defaults.factoryrestore| The host has been restored to default factory settings. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.disabled | info | VC | esx.audit.dcui.disabled| The DCUI has been disabled. Since 5.0 Reference
esx.audit.dcui.enabled | info | VC | esx.audit.dcui.enabled| The DCUI has been enabled. Since 5.0 Reference
esx.audit.dcui.host.reboot | warning | VC | esx.audit.dcui.host.reboot| The host is being rebooted through the Direct Console User Interface (DCUI). Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.host.shutdown | warning | VC | esx.audit.dcui.host.shutdown| The host is being shut down through the Direct Console User Interface (DCUI). Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.hostagents.restart | info | VC | esx.audit.dcui.hostagents.restart| The management agents on the host are being restarted. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.login.failed | error | VC | esx.audit.dcui.login.failed| Authentication of user {1} has failed. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.login.passwd.changed | info | VC | esx.audit.dcui.login.passwd.changed| Login password for user {1} has been changed. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.network.factoryrestore | warning | VC | esx.audit.dcui.network.factoryrestore| The host has been restored to factory network settings. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.dcui.network.restart | info | VC | esx.audit.dcui.network.restart| A management interface {1} has been restarted. Please consult ESXi Embedded and vCenter Server Setup Guide or follow the Ask VMware link for more information. Since 5.0 Reference
esx.audit.esxcli.host.poweroff | warning | ESXHost | esx.audit.esxcli.host.poweroff| The host is being powered off through esxcli. Reason for powering off: {1}. Please consult vSphere Documentation Center or follow the Ask VMware link for more information. Since 5.1 Reference
esx.audit.esxcli.host.restart | info | ESXHost | esx.audit.esxcli.host.restart| event.esx.audit.esxcli.host.restart.fullFormat Since 5.1 Reference
esx.audit.esximage.hostacceptance.changed | info | VC | esx.audit.esximage.hostacceptance.changed| Host acceptance level changed from {1} to {2} Since 5.0 Reference
esx.audit.esximage.install.novalidation | warning | VC | esx.audit.esximage.install.novalidation| Attempting to install an image profile with validation disabled. This may result in an image with unsatisfied dependencies, file or package conflicts, and potential security violations. Since 5.0 Reference
esx.audit.esximage.install.securityalert | warning | VC | esx.audit.esximage.install.securityalert| SECURITY ALERT: Installing image profile '{1}' with {2}. Since 5.0 Reference
esx.audit.esximage.profile.install.successful | info | VC | esx.audit.esximage.profile.install.successful| Successfully installed image profile '{1}'. Installed VIBs {2}, removed VIBs {3} Since 5.0 Reference
esx.audit.esximage.profile.update.successful | info | VC | esx.audit.esximage.profile.update.successful| Successfully updated host to image profile '{1}'. Installed VIBs {2}, removed VIBs {3} Since 5.0 Reference
esx.audit.esximage.vib.install.successful | info | VC | esx.audit.esximage.vib.install.successful| Successfully installed VIBs {1}, removed VIBs {2} Since 5.0 Reference
esx.audit.esximage.vib.remove.successful | info | VC | esx.audit.esximage.vib.remove.successful| Successfully removed VIBs {1} Since 5.0 Reference
esx.audit.host.boot | info | VC | esx.audit.host.boot| Host has booted. Since 5.0 Reference
esx.audit.host.maxRegisteredVMsExceeded | warning | ESXHost | esx.audit.host.maxRegisteredVMsExceeded| The number of virtual machines registered on host {host.name} in cluster {computeResource.name} in {datacenter.name} exceeded limit: {current} registered, {limit} is the maximum supported. Since 5.1 Reference
esx.audit.host.stop.reboot | info | VC | esx.audit.host.stop.reboot| Host is rebooting. Since 5.0 Reference
esx.audit.host.stop.shutdown | info | VC | esx.audit.host.stop.shutdown| Host is shutting down. Since 5.0 Reference
esx.audit.lockdownmode.disabled | info | VC | esx.audit.lockdownmode.disabled| Administrator access to the host has been enabled. Since 5.0 Reference
esx.audit.lockdownmode.enabled | info | VC | esx.audit.lockdownmode.enabled| Administrator access to the host has been disabled. Since 5.0 Reference
esx.audit.maintenancemode.canceled | info | VC | esx.audit.maintenancemode.canceled| The host has canceled entering maintenance mode. Since 5.0 Reference
esx.audit.maintenancemode.entered | info | VC | esx.audit.maintenancemode.entered| The host has entered maintenance mode. Since 5.0 Reference
esx.audit.maintenancemode.entering | info | VC | esx.audit.maintenancemode.entering| The host has begun entering maintenance mode. Since 5.0 Reference
esx.audit.maintenancemode.exited | info | VC | esx.audit.maintenancemode.exited| The host has exited maintenance mode. Since 5.0 Reference
esx.audit.net.firewall.config.changed | info | VC | esx.audit.net.firewall.config.changed| Firewall configuration has changed. Operation '{1}' for rule set {2} succeeded. Since 5.0 Reference
esx.audit.net.firewall.disabled | warning | VC | esx.audit.net.firewall.disabled| Firewall has been disabled. Since 5.0 Reference
esx.audit.net.firewall.enabled | info | VC | esx.audit.net.firewall.enabled| Firewall has been enabled for port {1}. Since 5.0 Reference
esx.audit.net.firewall.port.hooked | info | VC | esx.audit.net.firewall.port.hooked| Port {1} is now protected by Firewall. Since 5.0 Reference
esx.audit.net.firewall.port.removed | warning | VC | esx.audit.net.firewall.port.removed| Port {1} is no longer protected with Firewall. Since 5.0 Reference
esx.audit.net.lacp.disable | info | VC | esx.audit.net.lacp.disable| LACP for VDS {1} is disabled. Since 5.1 Reference
esx.audit.net.lacp.enable | info | VC | esx.audit.net.lacp.enable| LACP for VDS {1} is enabled. Since 5.1 Reference
esx.audit.net.lacp.uplink.connected | info | VC | esx.audit.net.lacp.uplink.connected| Lacp info: uplink {1} on VDS {2} got connected. Since 5.1 Reference
esx.audit.net.vdl2.ip.change | warning | ESXHostNetwork | esx.audit.net.vdl2.ip.change| VDL2 IP changed on vmknic {1}, port {2}, DVS {3}, VLAN {4}. Since 5.0 Reference
esx.audit.net.vdl2.mappingtable.full | warning | ESXHostNetwork | esx.audit.net.vdl2.mappingtable.full| Mapping table entries of VDL2 network {1} on DVS {2} exhausted. This network might suffer a low performance. Since 5.0 Reference
esx.audit.net.vdl2.route.change | warning | ESXHostNetwork | esx.audit.net.vdl2.route.change| VDL2 IP interface on vmknic: {1}, DVS: {2}, VLAN: {3} default route changed. Since 5.0 Reference
esx.audit.shell.disabled | info | VC | esx.audit.shell.disabled| The ESX command line shell has been disabled. Since 5.0 Reference
esx.audit.shell.enabled | info | VC | esx.audit.shell.enabled| The ESX command line shell has been enabled. Since 5.0 Reference
esx.audit.ssh.disabled | info | VC | esx.audit.ssh.disabled| SSH access has been disabled. Since 5.0 Reference
esx.audit.ssh.enabled | info | VC | esx.audit.ssh.enabled| SSH access has been enabled. Since 5.0 Reference
esx.audit.usb.config.changed | info | VC | esx.audit.usb.config.changed| USB configuration has changed on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
esx.audit.uw.secpolicy.alldomains.level.changed | warning | VC | esx.audit.uw.secpolicy.alldomains.level.changed| The enforcement level for all security domains has been changed to {1}. The enforcement level must always be set to enforcing. Since 5.0 Reference
esx.audit.uw.secpolicy.domain.level.changed | warning | VC | esx.audit.uw.secpolicy.domain.level.changed| The enforcement level for security domain {1} has been changed to {2}. The enforcement level must always be set to enforcing. Since 5.0 Reference
esx.audit.vmfs.lvm.device.discovered | info | VC | esx.audit.vmfs.lvm.device.discovered| One or more LVM devices have been discovered on this host. Since 5.0 Reference
esx.audit.vmfs.volume.mounted | info | VC | esx.audit.vmfs.volume.mounted| File system {1} on volume {2} has been mounted in {3} mode on this host. Since 5.0 Reference
esx.audit.vmfs.volume.umounted | info | VC | esx.audit.vmfs.volume.umounted| The volume {1} has been safely un-mounted. The datastore is no longer accessible on this host. Since 5.0 Reference
esx.audit.vsan.clustering.enabled | info | VC | esx.audit.vsan.clustering.enabled| VSAN clustering and directory services have been enabled. Since 5.5 Reference
esx.clear.coredump.configured | info | VC | esx.clear.coredump.configured| A vmkcore disk partition is available and/or a network coredump server has been configured. Host core dumps will be saved. Since 5.1 Reference
esx.clear.net.connectivity.restored | info | ESXHostNetwork | esx.clear.net.connectivity.restored| Network connectivity restored on virtual switch {1}, portgroups: {2}. Physical NIC {3} is up. Since 4.1 Reference
esx.clear.net.dvport.connectivity.restored | info | ESXHostNetwork | esx.clear.net.dvport.connectivity.restored| Network connectivity restored on DVPorts: {1}. Physical NIC {2} is up. Since 4.1 Reference
esx.clear.net.dvport.redundancy.restored | info | ESXHostNetwork | esx.clear.net.dvport.redundancy.restored| Uplink redundancy restored on DVPorts: {1}. Physical NIC {2} is up. Since 4.1 Reference
esx.clear.net.lacp.lag.transition.up | info | VC | esx.clear.net.lacp.lag.transition.up| LACP info: LAG {1} on VDS {2} is up. Since 5.5 Reference
esx.clear.net.lacp.uplink.transition.up | info | ESXHostNetwork | esx.clear.net.lacp.uplink.transition.up| Lacp info: uplink {1} on VDS {2} is moved into link aggregation group. Since 5.1 Reference
esx.clear.net.lacp.uplink.unblocked | info | ESXHostNetwork | esx.clear.net.lacp.uplink.unblocked| Lacp error: uplink {1} on VDS {2} is unblocked. Since 5.1 Reference
esx.clear.net.redundancy.restored | info | ESXHostNetwork | esx.clear.net.redundancy.restored| Uplink redundancy restored on virtual switch {1}, portgroups: {2}. Physical NIC {3} is up. Since 4.1 Reference
esx.clear.net.vmnic.linkstate.up | info | ESXHostNetwork | esx.clear.net.vmnic.linkstate.up| Physical NIC {1} linkstate is up. Since 4.1 Reference
esx.clear.scsi.device.io.latency.improved | info | ESXHostStorage | esx.clear.scsi.device.io.latency.improved| Device {1} performance has improved. I/O latency reduced from {2} microseconds to {3} microseconds. Since 5.0 Reference
esx.clear.scsi.device.state.on | info | ESXHostStorage | esx.clear.scsi.device.state.on| Device {1}, has been turned on administratively. Since 5.0 Reference
esx.clear.scsi.device.state.permanentloss.deviceonline | info | ESXHostStorage | esx.clear.scsi.device.state.permanentloss.deviceonline| Device {1}, that was permanently inaccessible is now online. No data consistency guarantees. Since 5.0 Reference
esx.clear.storage.apd.exit | info | ESXHostStorage | esx.clear.storage.apd.exit| Device or filesystem with identifer [{1}] has exited the All Paths Down state. Since 5.1 Reference
esx.clear.storage.connectivity.restored | info | ESXHostStorage | esx.clear.storage.connectivity.restored| Connectivity to storage device {1} (Datastores: {2}) restored. Path {3} is active again. Since 4.1 Reference
esx.clear.storage.redundancy.restored | info | ESXHostStorage | esx.clear.storage.redundancy.restored| Path redundancy to storage device {1} (Datastores: {2}) restored. Path {3} is active again. Since 4.1 Reference
esx.clear.vsan.clustering.enabled | info | VC | esx.clear.vsan.clustering.enabled| VSAN clustering and directory services have now been enabled. Since 5.5 Reference
esx.clear.vsan.network.available | info | VC | esx.clear.vsan.network.available| event.esx.clear.vsan.network.available.fullFormat Since 5.5 Reference
esx.clear.vsan.vmknic.ready | info | VC | esx.clear.vsan.vmknic.ready| event.esx.clear.vsan.vmknic.ready.fullFormat Since 5.5 Reference
esx.problem.3rdParty.error | error | VC | esx.problem.3rdParty.error| A 3rd party component, {1}, running on ESXi has reported an error. Please follow the knowledge base link ({2}) to see the steps to remedy the problem as reported by {3}. The message reported is: {4}. Since 5.0 Reference
esx.problem.3rdParty.info | info | VC | esx.problem.3rdParty.info| event.esx.problem.3rdParty.info.fullFormat Since 5.0 Reference
esx.problem.3rdParty.warning | warning | VC | esx.problem.3rdParty.warning| A 3rd party component, {1}, running on ESXi has reported a warning related to a problem. Please follow the knowledge base link ({2}) to see the steps to remedy the problem as reported by {3}. The message reported is: {4}. Since 5.0 Reference
esx.problem.apei.bert.memory.error.corrected | error | ESXHostHardware | esx.problem.apei.bert.memory.error.corrected| A corrected memory error occurred in last boot. The following details were reported. Physical Addr: {1}, Physical Addr Mask: {2}, Node: {3}, Card: {4}, Module: {5}, Bank: {6}, Device: {7}, Row: {8}, Column: {9} Error type: {10} Since 4.1 Reference
esx.problem.apei.bert.memory.error.fatal | error | ESXHostHardware | esx.problem.apei.bert.memory.error.fatal| A fatal memory error occurred in the last boot. The following details were reported. Physical Addr: {1}, Physical Addr Mask: {2}, Node: {3}, Card: {4}, Module: {5}, Bank: {6}, Device: {7}, Row: {8}, Column: {9} Error type: {10} Since 4.1 Reference
esx.problem.apei.bert.memory.error.recoverable | error | ESXHostHardware | esx.problem.apei.bert.memory.error.recoverable| A recoverable memory error occurred in last boot. The following details were reported. Physical Addr: {1}, Physical Addr Mask: {2}, Node: {3}, Card: {4}, Module: {5}, Bank: {6}, Device: {7}, Row: {8}, Column: {9} Error type: {10} Since 4.1 Reference
esx.problem.apei.bert.pcie.error.corrected | error | ESXHostHardware | esx.problem.apei.bert.pcie.error.corrected| A corrected PCIe error occurred in last boot. The following details were reported. Port Type: {1}, Device: {2}, Bus #: {3}, Function: {4}, Slot: {5}, Device Vendor: {6}, Version: {7}, Command Register: {8}, Status Register: {9}. Since 4.1 Reference
esx.problem.apei.bert.pcie.error.fatal | error | ESXHostHardware | esx.problem.apei.bert.pcie.error.fatal| Platform encounterd a fatal PCIe error in last boot. The following details were reported. Port Type: {1}, Device: {2}, Bus #: {3}, Function: {4}, Slot: {5}, Device Vendor: {6}, Version: {7}, Command Register: {8}, Status Register: {9}. Since 4.1 Reference
esx.problem.apei.bert.pcie.error.recoverable | error | ESXHostHardware | esx.problem.apei.bert.pcie.error.recoverable| A recoverable PCIe error occurred in last boot. The following details were reported. Port Type: {1}, Device: {2}, Bus #: {3}, Function: {4}, Slot: {5}, Device Vendor: {6}, Version: {7}, Command Register: {8}, Status Register: {9}. Since 4.1 Reference
esx.problem.application.core.dumped | warning | ESXHost | esx.problem.application.core.dumped| An application ({1}) running on ESXi host has crashed ({2} time(s) so far). A core file might have been created at {3}. Since 5.0 Reference
esx.problem.coredump.unconfigured | warning | ESXHost | esx.problem.coredump.unconfigured| No vmkcore disk partition is available and no network coredump server has been configured. Host core dumps cannot be saved. Since 5.0 Reference
esx.problem.cpu.amd.mce.dram.disabled | error | ESXHostHardware | esx.problem.cpu.amd.mce.dram.disabled| DRAM ECC not enabled. Please enable it in BIOS. Since 5.0 Reference
esx.problem.cpu.intel.ioapic.listing.error | error | ESXHostHardware | esx.problem.cpu.intel.ioapic.listing.error| Not all IO-APICs are listed in the DMAR. Not enabling interrupt remapping on this platform. Since 5.0 Reference
esx.problem.cpu.mce.invalid | error | ESXHostHardware | esx.problem.cpu.mce.invalid| MCE monitoring will be disabled as an unsupported CPU was detected. Please consult the ESX HCL for information on supported hardware. Since 5.0 Reference
esx.problem.cpu.smp.ht.invalid | error | ESXHostHardware | esx.problem.cpu.smp.ht.invalid| Disabling HyperThreading due to invalid configuration: Number of threads: {1}, Number of PCPUs: {2}. Since 5.0 Reference
esx.problem.cpu.smp.ht.numpcpus.max | error | ESXHostHardware | esx.problem.cpu.smp.ht.numpcpus.max| Found {1} PCPUs, but only using {2} of them due to specified limit. Since 5.0 Reference
esx.problem.cpu.smp.ht.partner.missing | warning | ESXHostHardware | esx.problem.cpu.smp.ht.partner.missing| Disabling HyperThreading due to invalid configuration: HT partner {1} is missing from PCPU {2}. Since 5.0 Reference
esx.problem.dhclient.lease.none | error | ESXHostNetwork | esx.problem.dhclient.lease.none| Unable to obtain a DHCP lease on interface {1}. Since 5.0 Reference
esx.problem.dhclient.lease.offered.error | warning | ESXHostNetwork | esx.problem.dhclient.lease.offered.error| event.esx.problem.dhclient.lease.offered.error.fullFormat Since 5.0 Reference
esx.problem.dhclient.lease.persistent.none | warning | ESXHostNetwork | esx.problem.dhclient.lease.persistent.none| No working DHCP leases in persistent database. Since 5.0 Reference
esx.problem.esximage.install.error | warning | VC | esx.problem.esximage.install.error| Could not install image profile: {1} Since 5.0 Reference
esx.problem.esximage.install.invalidhardware | warning | VC | esx.problem.esximage.install.invalidhardware| Host doesn't meet image profile '{1}' hardware requirements: {2} Since 5.0 Reference
esx.problem.esximage.install.stage.error | warning | VC | esx.problem.esximage.install.stage.error| Could not stage image profile '{1}': {2} Since 5.0 Reference
esx.problem.hardware.acpi.interrupt.routing.device.invalid | warning | ESXHostHardware | esx.problem.hardware.acpi.interrupt.routing.device.invalid| Skipping interrupt routing entry with bad device number: {1}. This is a BIOS bug. Since 5.0 Reference
esx.problem.hardware.acpi.interrupt.routing.pin.invalid | warning | ESXHostHardware | esx.problem.hardware.acpi.interrupt.routing.pin.invalid| Skipping interrupt routing entry with bad device pin: {1}. This is a BIOS bug. Since 5.0 Reference
esx.problem.hardware.ioapic.missing | warning | ESXHostHardware | esx.problem.hardware.ioapic.missing| IOAPIC Num {1} is missing. Please check BIOS settings to enable this IOAPIC. Since 5.0 Reference
esx.problem.host.coredump | warning | ESXHost | esx.problem.host.coredump| An unread host kernel core dump has been found. Since 5.0 Reference
esx.problem.hostd.core.dumped | warning | ESXHost | esx.problem.hostd.core.dumped| {1} crashed ({2} time(s) so far) and a core file might have been created at {3}. This might have caused connections to the host to be dropped. Since 5.0 Reference
esx.problem.iorm.badversion | warning | ESXHostStorage | esx.problem.iorm.badversion| Host {1} cannot participate in Storage I/O Control(SIOC) on datastore {2} because the version number {3} of the SIOC agent on this host is incompatible with number {4} of its counterparts on other hosts connected to this datastore. Since 5.0 Reference
esx.problem.iorm.nonviworkload | warning | ESXHostStorage | esx.problem.iorm.nonviworkload| An external I/O activity is detected on datastore {1}, this is an unsupported configuration. Consult the Resource Management Guide or follow the Ask VMware link for more information. Since 4.1 Reference
esx.problem.migrate.vmotion.default.heap.create.failed | error | Cluster | esx.problem.migrate.vmotion.default.heap.create.failed| Failed to create default migration heap. This might be the result of severe host memory pressure or virtual address space exhaustion. Migration might still be possible, but will be unreliable in cases of extreme host memory pressure. Since 5.0 Reference
esx.problem.migrate.vmotion.server.pending.cnx.listen.socket.shutdown | warning | Cluster | esx.problem.migrate.vmotion.server.pending.cnx.listen.socket.shutdown| The ESXi host's vMotion network server encountered an error while monitoring incoming network connections. Shutting down listener socket. vMotion might not be possible with this host until vMotion is manually re-enabled. Failure status: {1} Since 5.0 Reference
esx.problem.net.connectivity.lost | error | ESXHostNetwork | esx.problem.net.connectivity.lost| Lost network connectivity on virtual switch {1}. Physical NIC {2} is down. Affected portgroups:{3}. Since 4.1 Reference
esx.problem.net.dvport.connectivity.lost | error | ESXHostNetwork | esx.problem.net.dvport.connectivity.lost| Lost network connectivity on DVPorts: {1}. Physical NIC {2} is down. Since 4.1 Reference
esx.problem.net.dvport.redundancy.degraded | warning | ESXHostNetwork | esx.problem.net.dvport.redundancy.degraded| Uplink redundancy degraded on DVPorts: {1}. Physical NIC {2} is down. Since 4.1 Reference
esx.problem.net.dvport.redundancy.lost | warning | ESXHostNetwork | esx.problem.net.dvport.redundancy.lost| Lost uplink redundancy on DVPorts: {1}. Physical NIC {2} is down. Since 4.1 Reference
esx.problem.net.e1000.tso6.notsupported | error | ESXHostNetwork | esx.problem.net.e1000.tso6.notsupported| Guest-initiated IPv6 TCP Segmentation Offload (TSO) packets ignored. Manually disable TSO inside the guest operating system in virtual machine {1}, or use a different virtual adapter. Since 4.1 Reference
esx.problem.net.fence.port.badfenceid | warning | ESXHostNetwork | esx.problem.net.fence.port.badfenceid| VMkernel failed to set fenceId {1} on distributed virtual port {2} on switch {3}. Reason: invalid fenceId. Since 5.0 Reference
esx.problem.net.fence.resource.limited | warning | ESXHostNetwork | esx.problem.net.fence.resource.limited| Vmkernel failed to set fenceId {1} on distributed virtual port {2} on switch {3}. Reason: maximum number of fence networks or ports have been reached. Since 5.0 Reference
esx.problem.net.fence.switch.unavailable | warning | ESXHostNetwork | esx.problem.net.fence.switch.unavailable| Vmkernel failed to set fenceId {1} on distributed virtual port {2} on switch {3}. Reason: dvSwitch fence property is not set. Since 5.0 Reference
esx.problem.net.firewall.config.failed | error | ESXHostNetwork | esx.problem.net.firewall.config.failed| Firewall configuration operation '{1}' failed. The changes were not applied to rule set {2}. Since 5.0 Reference
esx.problem.net.firewall.port.hookfailed | error | ESXHostNetwork | esx.problem.net.firewall.port.hookfailed| Adding port {1} to Firewall failed. Since 5.0 Reference
esx.problem.net.gateway.set.failed | error | ESXHostNetwork | esx.problem.net.gateway.set.failed| Cannot connect to the specified gateway {1}. Failed to set it. Since 5.0 Reference
esx.problem.net.heap.belowthreshold | warning | ESXHostNetwork | esx.problem.net.heap.belowthreshold| {1} heap free size dropped below {2} percent. Since 5.0 Reference
esx.problem.net.lacp.lag.transition.down | warning | VC | esx.problem.net.lacp.lag.transition.down| LACP warning: LAG {1} on VDS {2} is down. Since 5.5 Reference
esx.problem.net.lacp.peer.noresponse | error | ESXHostNetwork | esx.problem.net.lacp.peer.noresponse| Lacp error: No peer response on uplink {1} for VDS {2}. Since 5.1 Reference
esx.problem.net.lacp.policy.incompatible | error | ESXHostNetwork | esx.problem.net.lacp.policy.incompatible| Lacp error: Current teaming policy on VDS {1} is incompatible, supported is IP hash only. Since 5.1 Reference
esx.problem.net.lacp.policy.linkstatus | error | ESXHostNetwork | esx.problem.net.lacp.policy.linkstatus| Lacp error: Current teaming policy on VDS {1} is incompatible, supported link failover detection is link status only. Since 5.1 Reference
esx.problem.net.lacp.uplink.blocked | warning | ESXHostNetwork | esx.problem.net.lacp.uplink.blocked| Lacp warning: uplink {1} on VDS {2} is blocked. Since 5.1 Reference
esx.problem.net.lacp.uplink.disconnected | warning | ESXHostNetwork | esx.problem.net.lacp.uplink.disconnected| Lacp warning: uplink {1} on VDS {2} got disconnected. Since 5.1 Reference
esx.problem.net.lacp.uplink.fail.duplex | error | ESXHostNetwork | esx.problem.net.lacp.uplink.fail.duplex| Lacp error: Duplex mode across all uplink ports must be full, VDS {1} uplink {2} has different mode. Since 5.1 Reference
esx.problem.net.lacp.uplink.fail.speed | error | ESXHostNetwork | esx.problem.net.lacp.uplink.fail.speed| Lacp error: Speed across all uplink ports must be same, VDS {1} uplink {2} has different speed. Since 5.1 Reference
esx.problem.net.lacp.uplink.inactive | error | ESXHostNetwork | esx.problem.net.lacp.uplink.inactive| Lacp error: All uplinks on VDS {1} must be active. Since 5.1 Reference
esx.problem.net.lacp.uplink.transition.down | warning | ESXHostNetwork | esx.problem.net.lacp.uplink.transition.down| Lacp warning: uplink {1} on VDS {2} is moved out of link aggregation group. Since 5.1 Reference
esx.problem.net.migrate.bindtovmk | warning | ESXHostNetwork | esx.problem.net.migrate.bindtovmk| The ESX advanced configuration option /Migrate/Vmknic is set to an invalid vmknic: {1}. /Migrate/Vmknic specifies a vmknic that vMotion binds to for improved performance. Update the configuration option with a valid vmknic. Alternatively, if you do not want vMotion to bind to a specific vmknic, remove the invalid vmknic and leave the option blank. Since 4.1 Reference
esx.problem.net.migrate.unsupported.latency | warning | ESXHostNetwork | esx.problem.net.migrate.unsupported.latency| ESXi has detected {1}ms round-trip vMotion network latency between host {2} and {3}. High latency vMotion networks are supported only if both ESXi hosts have been configured for vMotion latency tolerance. Since 5.0 Reference
esx.problem.net.portset.port.full | warning | ESXHostNetwork | esx.problem.net.portset.port.full| Portset {1} has reached the maximum number of ports ({2}). Cannot apply for any more free ports. Since 5.0 Reference
esx.problem.net.portset.port.vlan.invalidid | warning | ESXHostNetwork | esx.problem.net.portset.port.vlan.invalidid| {1} VLANID {2} is invalid. VLAN ID must be between 0 and 4095. Since 5.0 Reference
esx.problem.net.proxyswitch.port.unavailable | warning | ESXHostNetwork | esx.problem.net.proxyswitch.port.unavailable| Virtual NIC with hardware address {1} failed to connect to distributed virtual port {2} on switch {3}. There are no more ports available on the host proxy switch. Since 4.1 Reference
esx.problem.net.redundancy.degraded | warning | ESXHostNetwork | esx.problem.net.redundancy.degraded| Uplink redundancy degraded on virtual switch {1}. Physical NIC {2} is down. Affected portgroups:{3}. Since 4.1 Reference
esx.problem.net.redundancy.lost | warning | ESXHostNetwork | esx.problem.net.redundancy.lost| Lost uplink redundancy on virtual switch {1}. Physical NIC {2} is down. Affected portgroups:{3}. Since 4.1 Reference
esx.problem.net.uplink.mtu.failed | warning | ESXHostNetwork | esx.problem.net.uplink.mtu.failed| VMkernel failed to set the MTU value {1} on the uplink {2}. Since 4.1 Reference
esx.problem.net.vdl2.instance.initialization.fail | error | ESXHostNetwork | esx.problem.net.vdl2.instance.initialization.fail| VDL2 instance on DVS {1} initialization failed. Since 5.0 Reference
esx.problem.net.vdl2.instance.notexist | error | ESXHostNetwork | esx.problem.net.vdl2.instance.notexist| VDL2 overlay instance is not created on DVS {1} before initializing VDL2 port or VDL2 IP interface. Since 5.0 Reference
esx.problem.net.vdl2.mcastgroup.fail | error | ESXHostNetwork | esx.problem.net.vdl2.mcastgroup.fail| VDL2 IP interface on vmknic: {1}, DVS: {2}, VLAN: {3} failed to join multicast group: {4}. Since 5.0 Reference
esx.problem.net.vdl2.network.initialization.fail | error | ESXHostNetwork | esx.problem.net.vdl2.network.initialization.fail| VDL2 network {1} on DVS {2} initialization failed. Since 5.0 Reference
esx.problem.net.vdl2.port.initialization.fail | error | ESXHostNetwork | esx.problem.net.vdl2.port.initialization.fail| VDL2 port {1} on VDL2 network {2}, DVS {3} initialization failed. Since 5.0 Reference
esx.problem.net.vdl2.vmknic.fail | error | ESXHostNetwork | esx.problem.net.vdl2.vmknic.fail| VDL2 IP interface failed on vmknic {1}, port {2}, DVS {3}, VLAN {4}. Since 5.0 Reference
esx.problem.net.vdl2.vmknic.notexist | error | ESXHostNetwork | esx.problem.net.vdl2.vmknic.notexist| VDL2 IP interface does not exist on DVS {1}, VLAN {2}. Since 5.0 Reference
esx.problem.net.vmknic.ip.duplicate | warning | ESXHostNetwork | esx.problem.net.vmknic.ip.duplicate| A duplicate IP address was detected for {1} on the interface {2}. The current owner is {3}. Since 4.1 Reference
esx.problem.net.vmnic.linkstate.down | warning | ESXHostNetwork | esx.problem.net.vmnic.linkstate.down| Physical NIC {1} linkstate is down. Since 4.1 Reference
esx.problem.net.vmnic.linkstate.flapping | warning | ESXHostNetwork | esx.problem.net.vmnic.linkstate.flapping| Taking down physical NIC {1} because the link is unstable. Since 5.0 Reference
esx.problem.net.vmnic.watchdog.reset | warning | ESXHostNetwork | esx.problem.net.vmnic.watchdog.reset| Uplink {1} has recovered from a transient failure due to watchdog timeout Since 4.1 Reference
esx.problem.ntpd.clock.correction.error | warning | ESXHost | esx.problem.ntpd.clock.correction.error| NTP daemon stopped. Time correction {1} > {2} seconds. Manually set the time and restart ntpd. Since 5.0 Reference
esx.problem.pageretire.platform.retire.request | info | VC | esx.problem.pageretire.platform.retire.request| Memory page retirement requested by platform firmware. FRU ID: {1}. Refer to System Hardware Log: {2} Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.host.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.host.exceeded| Number of host physical memory pages that have been selected for retirement ({1}) exceeds threshold ({2}). Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.kernel.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.kernel.exceeded| Number of kernel physical memory pages that have been selected for retirement ({1}) exceeds threshold ({2}). Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.userclient.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.userclient.exceeded| Number of physical memory pages belonging to (user) memroy client {1} that have been selected for retirement ({2}) exceeds threshold ({3}). Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.userprivate.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.userprivate.exceeded| Number of private user physical memory pages that have been selected for retirement ({1}) exceeds threshold ({2}). Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.usershared.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.usershared.exceeded| Number of shared user physical memory pages that have been selected for retirement ({1}) exceeds threshold ({2}). Since 5.0 Reference
esx.problem.pageretire.selectedmpnthreshold.vmmclient.exceeded | warning | ESXHost | esx.problem.pageretire.selectedmpnthreshold.vmmclient.exceeded| Number of physical memory pages belonging to (vmm) memroy client {1} that have been selected for retirement ({2}) exceeds threshold ({3}). Since 5.0 Reference
esx.problem.scsi.apd.event.descriptor.alloc.failed | error | ESXHostStorage | esx.problem.scsi.apd.event.descriptor.alloc.failed| No memory to allocate APD (All Paths Down) event subsystem. Since 5.0 Reference
esx.problem.scsi.device.close.failed | warning | ESXHostStorage | esx.problem.scsi.device.close.failed| "Failed to close the device {1} properly, plugin {2}. Since 5.0 Reference
esx.problem.scsi.device.detach.failed | warning | ESXHostStorage | esx.problem.scsi.device.detach.failed| Detach failed for device :{1}. Exceeded the number of devices that can be detached, please cleanup stale detach entries. Since 5.0 Reference
esx.problem.scsi.device.filter.attach.failed | warning | ESXHostStorage | esx.problem.scsi.device.filter.attach.failed| Failed to attach filters to device '%s' during registration. Plugin load failed or the filter rules are incorrect. Since 5.0 Reference
esx.problem.scsi.device.io.bad.plugin.type | warning | ESXHostStorage | esx.problem.scsi.device.io.bad.plugin.type| Bad plugin type for device {1}, plugin {2} Since 5.0 Reference
esx.problem.scsi.device.io.inquiry.failed | warning | ESXHostStorage | esx.problem.scsi.device.io.inquiry.failed| Failed to get standard inquiry for device {1} from Plugin {2}. Since 5.0 Reference
esx.problem.scsi.device.io.invalid.disk.qfull.value | warning | ESXHostStorage | esx.problem.scsi.device.io.invalid.disk.qfull.value| QFullSampleSize should be bigger than QFullThreshold. LUN queue depth throttling algorithm will not function as expected. Please set the QFullSampleSize and QFullThreshold disk configuration values in ESX correctly. Since 5.0 Reference
esx.problem.scsi.device.io.latency.high | warning | ESXHostStorage | esx.problem.scsi.device.io.latency.high| Device {1} performance has deteriorated. I/O latency increased from average value of {2} microseconds to {3} microseconds. Since 5.0 Reference
esx.problem.scsi.device.io.qerr.change.config | warning | ESXHostStorage | esx.problem.scsi.device.io.qerr.change.config| QErr set to 0x{1} for device {2}. This may cause unexpected behavior. The system is not configured to change the QErr setting of device. The QErr value supported by system is 0x{3}. Please check the SCSI ChangeQErrSetting configuration value for ESX. Since 5.0 Reference
esx.problem.scsi.device.io.qerr.changed | warning | ESXHostStorage | esx.problem.scsi.device.io.qerr.changed| QErr set to 0x{1} for device {2}. This may cause unexpected behavior. The device was originally configured to the supported QErr setting of 0x{3}, but this has been changed and could not be changed back. Since 5.0 Reference
esx.problem.scsi.device.is.local.failed | warning | ESXHostStorage | esx.problem.scsi.device.is.local.failed| Failed to verify if the device {1} from plugin {2} is a local - not shared - device Since 5.0 Reference
esx.problem.scsi.device.is.pseudo.failed | warning | ESXHostStorage | esx.problem.scsi.device.is.pseudo.failed| Failed to verify if the device {1} from plugin {2} is a pseudo device Since 5.0 Reference
esx.problem.scsi.device.is.ssd.failed | warning | ESXHostStorage | esx.problem.scsi.device.is.ssd.failed| Failed to verify if the device {1} from plugin {2} is a Solid State Disk device Since 5.0 Reference
esx.problem.scsi.device.limitreached | error | ESXHostStorage | esx.problem.scsi.device.limitreached| The maximum number of supported devices of {1} has been reached. A device from plugin {2} could not be created. Since 4.1 Reference
esx.problem.scsi.device.state.off | info | VC | esx.problem.scsi.device.state.off| Device {1}, has been turned off administratively. Since 5.0 Reference
esx.problem.scsi.device.state.permanentloss | warning | ESXHostStorage | esx.problem.scsi.device.state.permanentloss| Device {1} has been removed or is permanently inaccessible. Affected datastores (if any): {2}. Since 5.0 Reference
esx.problem.scsi.device.state.permanentloss.noopens | info | VC | esx.problem.scsi.device.state.permanentloss.noopens| Permanently inaccessible device {1} has no more opens. It is now safe to unmount datastores (if any) {2} and delete the device. Since 5.0 Reference
esx.problem.scsi.device.state.permanentloss.pluggedback | warning | ESXHostStorage | esx.problem.scsi.device.state.permanentloss.pluggedback| Device {1} has been plugged back in after being marked permanently inaccessible. No data consistency guarantees. Since 5.0 Reference
esx.problem.scsi.device.state.permanentloss.withreservationheld | error | ESXHostStorage | esx.problem.scsi.device.state.permanentloss.withreservationheld| Device {1} has been removed or is permanently inaccessible, while holding a reservation. Affected datastores (if any): {2}. Since 5.0 Reference
esx.problem.scsi.device.thinprov.atquota | warning | ESXHostStorage | esx.problem.scsi.device.thinprov.atquota| Space utilization on thin-provisioned device {1} exceeded configured threshold. Affected datastores (if any): {2}. Since 4.1 Reference
esx.problem.scsi.scsipath.limitreached | error | ESXHostStorage | esx.problem.scsi.scsipath.limitreached| The maximum number of supported paths of {1} has been reached. Path {2} could not be added. Since 4.1 Reference
esx.problem.scsi.unsupported.plugin.type | warning | ESXHostStorage | esx.problem.scsi.unsupported.plugin.type| Scsi Device Allocation not supported for plugin type {1} Since 5.0 Reference
esx.problem.storage.apd.start | warning | ESXHostStorage | esx.problem.storage.apd.start| Device or filesystem with identifer [{1}] has entered the All Paths Down state. Since 5.1 Reference
esx.problem.storage.apd.timeout | warning | ESXHostStorage | esx.problem.storage.apd.timeout| Device or filesystem with identifer [{1}] has entered the All Paths Down Timeout state after being in the All Paths Down state for {2} seconds. I/Os will be fast failed. Since 5.1 Reference
esx.problem.storage.connectivity.devicepor | warning | ESXHostStorage | esx.problem.storage.connectivity.devicepor| Frequent PowerOn Reset Unit Attentions are occurring on device {1}. This might indicate a storage problem. Affected datastores: {2}1 Since 4.1 Reference
esx.problem.storage.connectivity.lost | error | ESXHostStorage | esx.problem.storage.connectivity.lost| Lost connectivity to storage device {1}. Path {2} is down. Affected datastores: {3}. Since 4.1 Reference
esx.problem.storage.connectivity.pathpor | warning | ESXHostStorage | esx.problem.storage.connectivity.pathpor| Frequent PowerOn Reset Unit Attentions are occurring on path {1}. This might indicate a storage problem. Affected device: {2}. Affected datastores: {3} Since 4.1 Reference
esx.problem.storage.connectivity.pathstatechanges | warning | ESXHostStorage | esx.problem.storage.connectivity.pathstatechanges| Frequent path state changes are occurring for path {1}. This might indicate a storage problem. Affected device: {2}. Affected datastores: {3} Since 4.1 Reference
esx.problem.storage.iscsi.discovery.connect.error | warning | ESXHostStorage | esx.problem.storage.iscsi.discovery.connect.error| iSCSI discovery to {1} on {2} failed. The iSCSI Initiator could not establish a network connection to the discovery address. Since 5.0 Reference
esx.problem.storage.iscsi.discovery.login.error | warning | ESXHostStorage | esx.problem.storage.iscsi.discovery.login.error| iSCSI discovery to {1} on {2} failed. The Discovery target returned a login error of: {3}. Since 5.0 Reference
esx.problem.storage.iscsi.target.connect.error | warning | ESXHostStorage | esx.problem.storage.iscsi.target.connect.error| Login to iSCSI target {1} on {2} failed. The iSCSI initiator could not establish a network connection to the target. Since 5.0 Reference
esx.problem.storage.iscsi.target.login.error | warning | ESXHostStorage | esx.problem.storage.iscsi.target.login.error| Login to iSCSI target {1} on {2} failed. Target returned login error of: {3}. Since 5.0 Reference
esx.problem.storage.iscsi.target.permanently.lost | error | ESXHostStorage | esx.problem.storage.iscsi.target.permanently.lost| The iSCSI target {2} was permanently removed from {1}. Since 5.1 Reference
esx.problem.storage.redundancy.degraded | warning | ESXHostStorage | esx.problem.storage.redundancy.degraded| Path redundancy to storage device {1} degraded. Path {2} is down. Affected datastores: {3}. Since 4.1 Reference
esx.problem.storage.redundancy.lost | warning | ESXHostStorage | esx.problem.storage.redundancy.lost| Lost path redundancy to storage device {1}. Path {2} is down. Affected datastores: {3}. Since 4.1 Reference
esx.problem.syslog.config | warning | ESXHost | esx.problem.syslog.config| System logging is not configured on host {host.name}. Please check Syslog options for the host under Configuration -> Software -> Advanced Settings in vSphere client. Since 5.0 Reference
esx.problem.syslog.nonpersistent | warning | ESXHost | esx.problem.syslog.nonpersistent| System logs on host {host.name} are stored on non-persistent storage. Consult product documentation to configure a syslog server or a scratch partition. Since 5.1 Reference
esx.problem.vfat.filesystem.full.other | warning | ESXHostStorage | esx.problem.vfat.filesystem.full.other| The VFAT filesystem {1} (UUID {2}) is full. Since 5.0 Reference
esx.problem.vfat.filesystem.full.scratch | warning | ESXHostStorage | esx.problem.vfat.filesystem.full.scratch| The host's scratch partition, which is the VFAT filesystem {1} (UUID {2}), is full. Since 5.0 Reference
esx.problem.visorfs.failure | error | ESXHostStorage | esx.problem.visorfs.failure| An operation on the root filesystem has failed. Since 5.0 Reference
esx.problem.visorfs.inodetable.full | warning | ESXHostStorage | esx.problem.visorfs.inodetable.full| The root filesystem's file table is full. As a result, the file {1} could not be created by the application '{2}'. Since 5.0 Reference
esx.problem.visorfs.ramdisk.full | warning | ESXHostStorage | esx.problem.visorfs.ramdisk.full| The ramdisk '{1}' is full. As a result, the file {2} could not be written. Since 5.0 Reference
esx.problem.visorfs.ramdisk.inodetable.full | error | ESXHostStorage | esx.problem.visorfs.ramdisk.inodetable.full| The file table of the ramdisk '{1}' is full. As a result, the file {2} could not be created by the application '{3}'. Since 5.1 Reference
esx.problem.vm.kill.unexpected.fault.failure | error | ESXHost | esx.problem.vm.kill.unexpected.fault.failure| The VM using the config file {1} could not fault in a guest physical page from the hypervisor level swap file at {2}. The VM is terminated as further progress is impossible. Since 5.1 Reference
esx.problem.vm.kill.unexpected.forcefulPageRetire | error | ESXHost | esx.problem.vm.kill.unexpected.forcefulPageRetire| The VM using the config file {1} contains the host physical page {2} which was scheduled for immediate retirement. To avoid system instability the VM is forcefully powered off. Since 5.0 Reference
esx.problem.vm.kill.unexpected.noSwapResponse | error | ESXHost | esx.problem.vm.kill.unexpected.noSwapResponse| The VM using the config file {1} did not respond to {2} swap actions in {3} seconds and is forcefully powered off to prevent system instability. Since 5.0 Reference
esx.problem.vm.kill.unexpected.vmtrack | error | ESXHost | esx.problem.vm.kill.unexpected.vmtrack| The VM using the config file {1} is allocating too many pages while system is critically low in free memory. It is forcefully terminated to prevent system instability. Since 5.1 Reference
esx.problem.vmfs.ats.support.lost | error | ESXHostStorage | esx.problem.vmfs.ats.support.lost| event.esx.problem.vmfs.ats.support.lost.fullFormat Since 5.1 Reference
esx.problem.vmfs.error.volume.is.locked | error | ESXHostStorage | esx.problem.vmfs.error.volume.is.locked| Volume on device {1} is locked, possibly because some remote host encountered an error during a volume operation and could not recover. Since 5.0 Reference
esx.problem.vmfs.extent.offline | warning | ESXHostStorage | esx.problem.vmfs.extent.offline| An attached device {1} may be offline. The file system {2} is now in a degraded state. While the datastore is still available, parts of data that reside on the extent that went offline might be inaccessible. Since 5.0 Reference
esx.problem.vmfs.extent.online | info | ESXHostStorage | esx.problem.vmfs.extent.online| Device {1} backing file system {2} came online. This extent was previously offline. All resources on this device are now available. Since 5.0 Reference
esx.problem.vmfs.heartbeat.recovered | info | ESXHostStorage | esx.problem.vmfs.heartbeat.recovered| Successfully restored access to volume {1} ({2}) following connectivity issues. Since 4.1 Reference
esx.problem.vmfs.heartbeat.timedout | warning | ESXHostStorage | esx.problem.vmfs.heartbeat.timedout| Lost access to volume {1} ({2}) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly. Since 4.1 Reference
esx.problem.vmfs.heartbeat.unrecoverable | error | ESXHostStorage | esx.problem.vmfs.heartbeat.unrecoverable| Lost connectivity to volume {1} ({2}) and subsequent recovery attempts have failed. Since 4.1 Reference
esx.problem.vmfs.journal.createfailed | warning | ESXHostStorage | esx.problem.vmfs.journal.createfailed| No space for journal on volume {1} ({2}). Opening volume in read-only metadata mode with limited write support. Since 4.1 Reference
esx.problem.vmfs.lock.corruptondisk | error | ESXHostStorage | esx.problem.vmfs.lock.corruptondisk| At least one corrupt on-disk lock was detected on volume {1} ({2}). Other regions of the volume might be damaged too. Since 4.1 Reference
esx.problem.vmfs.nfs.mount.connect.failed | error | ESXHostStorage | esx.problem.vmfs.nfs.mount.connect.failed| Failed to mount to the server {1} mount point {2}. {3} Since 4.1 Reference
esx.problem.vmfs.nfs.mount.limit.exceeded | error | ESXHostStorage | esx.problem.vmfs.nfs.mount.limit.exceeded| Failed to mount to the server {1} mount point {2}. {3} Since 4.1 Reference
esx.problem.vmfs.nfs.server.disconnect | error | ESXHostStorage | esx.problem.vmfs.nfs.server.disconnect| Lost connection to server {1} mount point {2} mounted as {3} ({4}). Since 4.1 Reference
esx.problem.vmfs.nfs.server.restored | info | ESXHostStorage | esx.problem.vmfs.nfs.server.restored| Restored connection to server {1} mount point {2} mounted as {3} ({4}). Since 4.1 Reference
esx.problem.vmfs.resource.corruptondisk | error | ESXHostStorage | esx.problem.vmfs.resource.corruptondisk| At least one corrupt resource metadata region was detected on volume {1} ({2}). Other regions of the volume might be damaged too. Since 4.1 Reference
esx.problem.vmfs.volume.locked | error | ESXHostStorage | esx.problem.vmfs.volume.locked| Volume on device {1} locked, possibly because remote host {2} encountered an error during a volume operation and could not recover. Since 4.1 Reference
esx.problem.vmsyslogd.remote.failure | error | ESXHost | esx.problem.vmsyslogd.remote.failure| The host "{1}" has become unreachable. Remote logging to this host has stopped. Since 5.0 Reference
esx.problem.vmsyslogd.storage.failure | error | ESXHost | esx.problem.vmsyslogd.storage.failure| Logging to storage has failed. Logs are no longer being stored locally on this host. Since 5.0 Reference
esx.problem.vmsyslogd.storage.logdir.invalid | error | ESXHost | esx.problem.vmsyslogd.storage.logdir.invalid| The configured log directory {1} cannot be used. The default directory {2} will be used instead. Since 5.1 Reference
esx.problem.vmsyslogd.unexpected | warning | ESXHost | esx.problem.vmsyslogd.unexpected| Log daemon has failed for an unexpected reason: {1} Since 5.0 Reference
esx.problem.vpxa.core.dumped | warning | ESXHost | esx.problem.vpxa.core.dumped| {1} crashed ({2} time(s) so far) and a core file might have been created at {3}. This might have caused connections to the host to be dropped. Since 5.0 Reference
esx.problem.vsan.clustering.disabled | warning | VC | esx.problem.vsan.clustering.disabled| VSAN clustering and directory services have been disabled thus will be no longer available. Since 5.5 Reference
esx.problem.vsan.net.not.ready | warning | ESXHostNetwork | esx.problem.vsan.net.not.ready| vmknic {1} that is currently configured to be used with VSAN doesn't have an IP address yet. There are no other active network configuration and therefore the VSAN node doesn't have network connectivity. Since 5.5 Reference
esx.problem.vsan.net.redundancy.lost | warning | ESXHostNetwork | esx.problem.vsan.net.redundancy.lost| VSAN network configuration doesn't have any redundancy. This might be a problem if further network configuration is removed. Since 5.5 Reference
esx.problem.vsan.net.redundancy.reduced | warning | ESXHostNetwork | esx.problem.vsan.net.redundancy.reduced| VSAN network configuration redundancy has been reduced. This might be a problem if further network configuration is removed. Since 5.5 Reference
esx.problem.vsan.no.network.connectivity | error | ESXHostNetwork | esx.problem.vsan.no.network.connectivity| VSAN doesn't have any network configuration. This can severely impact several objects in the VSAN datastore. Since 5.5 Reference
esx.problem.vsan.vmknic.not.ready | warning | VC | esx.problem.vsan.vmknic.not.ready| vmknic {1} that is currently configured to be used with VSAN doesn't have an IP address yet. However, there are other network configuration which are active. If those configurations are removed that may cause problems. Since 5.5 Reference
ExitedStandbyModeEvent | info | VC | The host {host.name} is no longer in standby mode Since 2.5 Reference
ExitingStandbyModeEvent | info | VC | The host {host.name} is exiting standby mode Since 4.0 Reference
ExitMaintenanceModeEvent | info | VC | Host {host.name} in {datacenter.name} has exited maintenance mode Since 2.0 Reference
ExitStandbyModeFailedEvent | error | ESXHost | The host {host.name} could not exit standby mode Since 4.0 Reference
FailoverLevelRestored | info | VC | Sufficient resources are available to satisfy HA failover level in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
GeneralEvent | info | VC | General event: {message} Since 2.0 Reference
GeneralHostErrorEvent | error | ESXHost | Error detected on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GeneralHostInfoEvent | info | VC | Issue detected on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GeneralHostWarningEvent | warning | ESXHost | Issue detected on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GeneralUserEvent | user | VC | User logged event: {message} Since 2.0 Reference
GeneralVmErrorEvent | error | VirtualMachine | Error detected for {vm.name} on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GeneralVmInfoEvent | info | VC | Issue detected for {vm.name} on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GeneralVmWarningEvent | warning | VirtualMachine | Issue detected for {vm.name} on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
GhostDvsProxySwitchDetectedEvent | info | VC | The Distributed Virtual Switch corresponding to the proxy switches {switchUuid} on the host {host.name} does not exist in vCenter or does not contain this host. Since 4.0 Reference
GhostDvsProxySwitchRemovedEvent | info | VC | A ghost proxy switch {switchUuid} on the host {host.name} was resolved. Since 4.0 Reference
GlobalMessageChangedEvent | info | VC | The message changed: {message} Since 2.0 Reference
hbr.primary.AppQuiescedDeltaCompletedEvent | info | VC | hbr.primary.AppQuiescedDeltaCompletedEvent| Application consistent delta completed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({bytes} bytes transferred) Since 5.0 Reference
hbr.primary.ConnectionRestoredToHbrServerEvent | info | VC | hbr.primary.ConnectionRestoredToHbrServerEvent| Connection to replication server restored for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
hbr.primary.DeltaAbortedEvent | warning | VC | hbr.primary.DeltaAbortedEvent| Delta aborted for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reason.@enum.hbr.primary.ReasonForDeltaAbort} Since 5.0 Reference
hbr.primary.DeltaCompletedEvent | info | VC | hbr.primary.DeltaCompletedEvent| Delta completed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({bytes} bytes transferred). Since 5.0 Reference
hbr.primary.DeltaStartedEvent | info | VC | hbr.primary.DeltaStartedEvent| Delta started by {userName} for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
hbr.primary.FailedToStartDeltaEvent | error | VC | hbr.primary.FailedToStartDeltaEvent| Failed to start delta for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reason.@enum.fault.ReplicationVmFault.ReasonForFault} Since 5.0 Reference
hbr.primary.FailedToStartSyncEvent | error | VC | hbr.primary.FailedToStartSyncEvent| Failed to start full sync for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reason.@enum.fault.ReplicationVmFault.ReasonForFault} Since 5.0 Reference
hbr.primary.FSQuiescedDeltaCompletedEvent | warning | VC | hbr.primary.FSQuiescedDeltaCompletedEvent| File system consistent delta completed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({bytes} bytes transferred) Since 5.0 Reference
hbr.primary.InvalidDiskReplicationConfigurationEvent | warning | VC | hbr.primary.InvalidDiskReplicationConfigurationEvent| Replication configuration is invalid for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}, disk {diskKey}: {reasonForFault.@enum.fault.ReplicationDiskConfigFault.ReasonForFault} Since 5.0 Reference
hbr.primary.InvalidVmReplicationConfigurationEvent | warning | VC | hbr.primary.InvalidVmReplicationConfigurationEvent| Replication configuration is invalid for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reasonForFault.@enum.fault.ReplicationVmConfigFault.ReasonForFault} Since 5.0 Reference
hbr.primary.NoConnectionToHbrServerEvent | warning | VC | hbr.primary.NoConnectionToHbrServerEvent| No connection to replication server for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reason.@enum.hbr.primary.ReasonForNoServerConnection} Since 5.0 Reference
hbr.primary.NoProgressWithHbrServerEvent | warning | VC | hbr.primary.NoProgressWithHbrServerEvent| Replication server error for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}: {reason.@enum.hbr.primary.ReasonForNoServerProgress} Since 5.0 Reference
hbr.primary.QuiesceNotSupported | warning | VC | hbr.primary.QuiesceNotSupported| Quiescing is not supported for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
hbr.primary.SyncCompletedEvent | info | VC | hbr.primary.SyncCompletedEvent| Full sync completed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({bytes} bytes transferred). Since 5.0 Reference
hbr.primary.SyncStartedEvent | info | VC | hbr.primary.SyncStartedEvent| Full sync started by {userName} for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 5.0 Reference
hbr.primary.UnquiescedDeltaCompletedEvent | warning | VC | hbr.primary.UnquiescedDeltaCompletedEvent| Delta completed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({bytes} bytes transferred). Since 5.0 Reference
hbr.primary.VmReplicationConfigurationChangedEvent | info | VC | hbr.primary.VmReplicationConfigurationChangedEvent| Replication configuration changed for virtual machine {vm.name} on host {host.name} in cluster {computeResource.name} in {datacenter.name} ({numDisks} disks, {rpo} minutes RPO, HBR Server is {hbrServerAddress}). Since 5.0 Reference
HealthStatusChangedEvent | info | VC | {componentName} status changed from {oldStatus} to {newStatus} Since 4.0 Reference
HostAddedEvent | info | VC | Added host {host.name} to datacenter {datacenter.name} Since 2.0 Reference
HostAddFailedEvent | error | VC | Cannot add host {hostname} to datacenter {datacenter.name} Since 2.0 Reference
HostAdminDisableEvent | warning | VC | Administrator access to the host {host.name} is disabled Since 2.5 Reference
HostAdminEnableEvent | warning | VC | Administrator access to the host {host.name} has been restored Since 2.5 Reference
HostCnxFailedAccountFailedEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: cannot configure management account Since 2.0 Reference
HostCnxFailedAlreadyManagedEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: already managed by {serverName} Since 2.0 Reference
HostCnxFailedBadCcagentEvent | error | ESXHost | Cannot connect host {host.name} in {datacenter.name} : server agent is not responding Since 2.0 Reference
HostCnxFailedBadUsernameEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: incorrect user name or password Since 2.0 Reference
HostCnxFailedBadVersionEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: incompatible version Since 2.0 Reference
HostCnxFailedCcagentUpgradeEvent | error | ESXHost | Cannot connect host {host.name} in {datacenter.name}. Did not install or upgrade vCenter agent service. Since 2.0 Reference
HostCnxFailedEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: error connecting to host Since 2.0 Reference
HostCnxFailedNetworkErrorEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: network error Since 2.0 Reference
HostCnxFailedNoAccessEvent | error | ESXHost | Cannot connect host {host.name} in {datacenter.name}: account has insufficient privileges Since 2.0 Reference
HostCnxFailedNoConnectionEvent | error | ESXHost | Cannot connect host {host.name} in {datacenter.name} Since 2.0 Reference
HostCnxFailedNoLicenseEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: not enough CPU licenses Since 2.0 Reference
HostCnxFailedNotFoundEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: incorrect host name Since 2.0 Reference
HostCnxFailedTimeoutEvent | error | ESXHost | Cannot connect {host.name} in {datacenter.name}: time-out waiting for host response Since 2.0 Reference
HostComplianceCheckedEvent | info | VC | Host {host.name} checked for compliance. Since 4.0 Reference
HostCompliantEvent | info | VC | Host {host.name} is in compliance with the attached profile Since 4.0 Reference
HostConfigAppliedEvent | info | VC | Host configuration changes applied. Since 4.0 Reference
HostConnectedEvent | info | VC | Connected to {host.name} in {datacenter.name} Since 2.0 Reference
HostConnectionLostEvent | error | ESXHost | Host {host.name} in {datacenter.name} is not responding Since 2.0 Reference
HostDasDisabledEvent | info | VC | HA agent disabled on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
HostDasDisablingEvent | info | VC | HA is being disabled on {host.name} in cluster {computeResource.name} in datacenter {datacenter.name} Since 2.0 Reference
HostDasEnabledEvent | info | VC | HA agent enabled on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
HostDasEnablingEvent | warning | Cluster | Enabling HA agent on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
HostDasErrorEvent | error | Cluster | HA agent on {host.name} in cluster {computeResource.name} in {datacenter.name} has an error {message}: {reason.@enum.HostDasErrorEvent.HostDasErrorReason} Since 2.0 Reference
HostDasOkEvent | info | VC | HA agent on host {host.name} in cluster {computeResource.name} in {datacenter.name} is configured correctly Since 2.0 Reference
HostDisconnectedEvent | warning | ESXHost | Disconnected from {host.name} in {datacenter.name}. Reason: {reason.@enum.HostDisconnectedEvent.ReasonCode} Since 2.0 Reference
HostDVPortEvent | info | VC | dvPort connected to host {host.name} in {datacenter.name} changed status Since 4.1 Reference
HostEnableAdminFailedEvent | error | VC | Cannot restore some administrator permissions to the host {host.name} Since 2.5 Reference
HostExtraNetworksEvent | error | ESXHostNetwork | Host {host.name} has the following extra networks not used by other hosts for HA communication:{ips}. Consider using HA advanced option das.allowNetwork to control network usage Since 4.0 Reference
HostGetShortNameFailedEvent | error | ESXHostNetwork | Cannot complete command 'hostname -s' on host {host.name} or returned incorrect name format Since 2.5 Reference
HostInAuditModeEvent | info | VC | Host {host.name} is running in audit mode. The host's configuration will not be persistent across reboots. Since 5.0 Reference
HostInventoryFullEvent | warning | ESXHost | Maximum ({capacity}) number of hosts allowed for this edition of vCenter Server has been reached Since 2.5 Reference
HostInventoryUnreadableEvent | info | VC | The virtual machine inventory file on host {host.name} is damaged or unreadable. Since 4.0 Reference
HostIpChangedEvent | info | VC | IP address of the host {host.name} changed from {oldIP} to {newIP} Since 2.5 Reference
HostIpInconsistentEvent | warning | ESXHostNetwork | Configuration of host IP address is inconsistent on host {host.name}: address resolved to {ipAddress} and {ipAddress2} Since 2.5 Reference
HostIpToShortNameFailedEvent | warning | ESXHostNetwork | Cannot resolve IP address to short name on host {host.name} Since 2.5 Reference
HostIsolationIpPingFailedEvent | warning | ESXHostNetwork | Host {host.name} could not reach isolation address: {isolationIp} Since 2.5 Reference
HostLicenseExpiredEvent | error | VC | A host license for {host.name} has expired Since 2.0 Reference
HostLocalPortCreatedEvent | info | ESXHostNetwork | A host local port {hostLocalPort.portKey} is created on vSphere Distributed Switch {hostLocalPort.switchUuid} to recover from management network connectivity loss on virtual NIC device {hostLocalPort.vnic} on the host {host.name}. Since 5.1 Reference
HostMissingNetworksEvent | error | ESXHostNetwork | Host {host.name} does not have the following networks used by other hosts for HA communication:{ips}. Consider using HA advanced option das.allowNetwork to control network usage Since 4.0 Reference
HostMonitoringStateChangedEvent | info | VC | Host monitoring state in {computeResource.name} in {datacenter.name} changed to {state} Since 4.0 Reference
HostNoAvailableNetworksEvent | error | ESXHostNetwork | Host {host.name} currently has no available networks for HA Communication. The following networks are currently used by HA: {ips} Since 4.0 Reference
HostNoHAEnabledPortGroupsEvent | error | ESXHostNetwork | Host {host.name} has no port groups enabled for HA communication. Since 4.0 Reference
HostNonCompliantEvent | warning | VC | Host {host.name} is not in compliance with the attached profile Since 4.0 Reference
HostNoRedundantManagementNetworkEvent | warning | ESXHostNetwork | Host {host.name} currently has no management network redundancy Since 2.5 Reference
HostNotInClusterEvent | error | Cluster | Host {host.name} is not a cluster member in {datacenter.name} Since 2.5 Reference
HostOvercommittedEvent | error | VC | Insufficient capacity in host {computeResource.name} to satisfy resource configuration in {datacenter.name} Since 4.0 Reference
HostPrimaryAgentNotShortNameEvent | error | ESXHostNetwork | Primary agent {primaryAgent} was not specified as a short name to host {host.name} Since 2.5 Reference
HostProfileAppliedEvent | info | VC | Profile is applied on the host {host.name} Since 4.0 Reference
HostReconnectionFailedEvent | error | VC | Cannot reconnect to {host.name} in {datacenter.name} Since 2.0 Reference
HostRemovedEvent | info | VC | Removed host {host.name} in {datacenter.name} Since 2.0 Reference
HostShortNameInconsistentEvent | warning | ESXHostNetwork | Host names {shortName} and {shortName2} both resolved to the same IP address. Check the host's network configuration and DNS entries Since 2.5 Reference
HostShortNameToIpFailedEvent | warning | ESXHostNetwork | Cannot resolve short name {shortName} to IP address on host {host.name} Since 2.5 Reference
HostShutdownEvent | info | VC | Shut down of {host.name} in {datacenter.name}: {reason} Since 2.0 Reference
HostStatusChangedEvent | info | VC | Configuration status on host {computeResource.name} changed from {oldStatus.@enum.ManagedEntity.Status} to {newStatus.@enum.ManagedEntity.Status} in {datacenter.name} Since 4.0 Reference
HostSyncFailedEvent | error | VC | Cannot synchronize host {host.name}. {reason.msg} Since 4.0 Reference
HostUpgradeFailedEvent | error | ESXHost | Cannot install or upgrade vCenter agent service on {host.name} in {datacenter.name} Since 2.0 Reference
HostUserWorldSwapNotEnabledEvent | warning | VC | event.HostUserWorldSwapNotEnabledEvent.fullFormat Since 4.0 Reference
HostVnicConnectedToCustomizedDVPortEvent | info | VC | Host {host.name} vNIC {vnic.vnic} was reconfigured to use dvPort {vnic.port.portKey} with port level configuration, which might be different from the dvPort group. Since 4.0 Reference
HostWwnChangedEvent | warning | ESXHostStorage | WWNs are changed for {host.name} Since 2.5 Reference
HostWwnConflictEvent | error | ESXHostStorage | The WWN ({wwn}) of {host.name} conflicts with the currently registered WWN Since 2.5 Reference
IncorrectHostInformationEvent | error | ESXHost | Host {host.name} did not provide the information needed to acquire the correct set of licenses Since 2.5 Reference
InfoUpgradeEvent | info | VC | {message} Since 2.0 Reference
InsufficientFailoverResourcesEvent | warning | Cluster | Insufficient resources to satisfy HA failover level on cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
InvalidEditionEvent | error | VC | The license edition '{feature}' is invalid Since 2.5 Reference
IScsiBootFailureEvent | warning | VC | Booting from iSCSI failed with an error. See the VMware Knowledge Base for information on configuring iBFT networking Since 4.1 Reference
LicenseExpiredEvent | error | VC | License {feature.featureName} has expired Since 2.0 Reference
LicenseNonComplianceEvent | error | VC | License inventory is not compliant. Licenses are overused Since 4.0 Reference
LicenseRestrictedEvent | error | VC | Unable to acquire licenses due to a restriction in the option file on the license server. Since 2.5 Reference
LicenseServerAvailableEvent | info | VC | License server {licenseServer} is available Since 2.0 Reference
LicenseServerUnavailableEvent | error | VC | License server {licenseServer} is unavailable Since 2.0 Reference
LocalDatastoreCreatedEvent | info | VC | Created local datastore {datastore.name} on {host.name} in {datacenter.name} Since 2.0 Reference
LocalTSMEnabledEvent | info | VC | The Local Tech Support Mode for the host {host.name} has been enabled Since 4.1 Reference
LockerMisconfiguredEvent | warning | VC | Datastore {datastore} which is configured to back the locker does not exist Since 2.5 Reference
LockerReconfiguredEvent | info | VC | Locker was reconfigured from {oldDatastore} to {newDatastore} datastore Since 2.5 Reference
MigrationErrorEvent | error | Cluster | Unable to migrate {vm.name} from {host.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MigrationHostErrorEvent | error | Cluster | Unable to migrate {vm.name} from {host.name} to {dstHost.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MigrationHostWarningEvent | warning | Cluster | Migration of {vm.name} from {host.name} to {dstHost.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MigrationResourceErrorEvent | error | Cluster | Cannot migrate {vm.name} from {host.name} to {dstHost.name} and resource pool {dstPool.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MigrationResourceWarningEvent | warning | Cluster | Migration of {vm.name} from {host.name} to {dstHost.name} and resource pool {dstPool.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MigrationWarningEvent | warning | Cluster | Migration of {vm.name} from {host.name} in {datacenter.name}: {fault.msg} Since 2.0 Reference
MtuMatchEvent | info | ESXHostNetwork | The MTU configured in the vSphere Distributed Switch matches the physical switch connected to uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name} Since 5.1 Reference
MtuMismatchEvent | error | ESXHostNetwork | The MTU configured in the vSphere Distributed Switch does not match the physical switch connected to uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name} Since 5.1 Reference
NASDatastoreCreatedEvent | info | VC | Created NAS datastore {datastore.name} on {host.name} in {datacenter.name} Since 2.0 Reference
NetworkRollbackEvent | error | ESXHostNetwork | Network configuration on the host {host.name} is rolled back as it disconnects the host from vCenter server. Since 5.1 Reference
NoAccessUserEvent | error | VC | Cannot login user {userName}@{ipAddress}: no permission Since 2.0 Reference
NoDatastoresConfiguredEvent | info | VC | No datastores have been configured on the host {host.name} Since 2.5 Reference
NoLicenseEvent | error | VC | A required license {feature.featureName} is not reserved Since 2.0 Reference
NoMaintenanceModeDrsRecommendationForVM | info | VC | Unable to automatically migrate {vm.name} from {host.name} Since 2.0 Reference
NonVIWorkloadDetectedOnDatastoreEvent | info | VC | Non-VI workload detected on datastore {datastore.name} Since 4.1 Reference
NotEnoughResourcesToStartVmEvent | info | VC | Not enough resources to failover {vm.name} in {computeResource.name} in {datacenter.name} Since 2.0 Reference
OutOfSyncDvsHost | warning | VC | The Distributed Virtual Switch configuration on some hosts differed from that of the vCenter Server. Since 4.0 Reference
PermissionAddedEvent | info | VC | Permission created for {principal} on {entity.name}, role is {role.name}, propagation is {propagate.@enum.auth.Permission.propagate} Since 2.0 Reference
PermissionRemovedEvent | info | VC | Permission rule removed for {principal} on {entity.name} Since 2.0 Reference
PermissionUpdatedEvent | info | VC | Permission changed for {principal} on {entity.name}, role is {role.name}, propagation is {propagate.@enum.auth.Permission.propagate} Since 2.0 Reference
ProfileAssociatedEvent | info | VC | Profile {profile.name} attached. Since 4.0 Reference
ProfileChangedEvent | info | VC | Profile {profile.name} was changed. Since 4.0 Reference
ProfileCreatedEvent | info | VC | Profile is created. Since 4.0 Reference
ProfileDissociatedEvent | info | VC | Profile {profile.name} detached. Since 4.0 Reference
ProfileEvent | info | VC | This event records a Profile specific event. Since 4.0 Reference
ProfileReferenceHostChangedEvent | info | VC | Profile {profile.name} reference host changed. Since 4.0 Reference
ProfileRemovedEvent | info | VC | Profile was removed. Since 4.0 Reference
RecoveryEvent | info | ESXHostNetwork | The host {hostName} network connectivity was recovered on the management virtual NIC {vnic} by connecting to a new port {portKey} on the vSphere Distributed Switch {dvsUuid}. Since 5.1 Reference
RemoteTSMEnabledEvent | info | VC | Remote Tech Support Mode (SSH) for the host {host.name} has been enabled Since 4.1 Reference
ResourcePoolCreatedEvent | info | VC | Created resource pool {resourcePool.name} in compute-resource {computeResource.name} in {datacenter.name} Since 2.0 Reference
ResourcePoolDestroyedEvent | info | VC | Removed resource pool {resourcePool.name} on {computeResource.name} in {datacenter.name} Since 2.0 Reference
ResourcePoolMovedEvent | info | VC | Moved resource pool {resourcePool.name} from {oldParent.name} to {newParent.name} on {computeResource.name} in {datacenter.name} Since 2.0 Reference
ResourcePoolReconfiguredEvent | verbose | VC | Updated configuration for {resourcePool.name} in compute-resource {computeResource.name} in {datacenter.name} Since 2.0 Reference
ResourceViolatedEvent | error | VC | Resource usage exceeds configuration for resource pool {resourcePool.name} in compute-resource {computeResource.name} in {datacenter.name} Since 2.0 Reference
RoleAddedEvent | info | VC | New role {role.name} created Since 2.0 Reference
RoleRemovedEvent | info | VC | Role {role.name} removed Since 2.0 Reference
RoleUpdatedEvent | info | VC | Modifed role {role.name} Since 2.0 Reference
RollbackEvent | info | ESXHostNetwork | The Network API {methodName} on this entity caused the host {hostName} to be diconnected from the vCenter Server. The configuration change was rolled back on the host. Since 5.1 Reference
ScheduledTaskCompletedEvent | info | VC | Task {scheduledTask.name} on {entity.name} in {datacenter.name} completed successfully Since 2.0 Reference
ScheduledTaskCreatedEvent | info | VC | Created task {scheduledTask.name} on {entity.name} in {datacenter.name} Since 2.0 Reference
ScheduledTaskEmailCompletedEvent | info | VC | Task {scheduledTask.name} on {entity.name} in {datacenter.name} sent email to {to} Since 2.0 Reference
ScheduledTaskEmailFailedEvent | warning | VC | Task {scheduledTask.name} on {entity.name} in {datacenter.name} cannot send email to {to}: {reason.msg} Since 2.0 Reference
ScheduledTaskEvent | info | VC | This event records the completion of a scheduled task. The name of the task is indicated. Since 2.0 Reference
ScheduledTaskFailedEvent | warning | VC | Task {scheduledTask.name} on {entity.name} in {datacenter.name} cannot be completed: {reason.msg} Since 2.0 Reference
ScheduledTaskReconfiguredEvent | info | VC | Reconfigured task {scheduledTask.name} on {entity.name} in {datacenter.name} Since 2.0 Reference
ScheduledTaskRemovedEvent | info | VC | Removed task {scheduledTask.name} on {entity.name} in {datacenter.name} Since 2.0 Reference
ScheduledTaskStartedEvent | info | VC | Running task {scheduledTask.name} on {entity.name} in {datacenter.name} Since 2.0 Reference
ServerLicenseExpiredEvent | error | VC | A vCenter Server license has expired Since 2.0 Reference
ServerStartedSessionEvent | info | VC | vCenter started Since 2.0 Reference
SessionTerminatedEvent | info | VC | A session for user '{terminatedUsername}' has stopped Since 2.0 Reference
SV130 | info | ESXHost | SV130 Host {host.name} has entered vCenter maintenance mode
SV131 | info | ESXHost | SV130 Host {host.name} has exited vCenter maintenance mode
SV132 | error | ESXHostNetwork | SV132 Network connection to Distributed Virtual Switch {DVS.name} has been restored.
SV133 | info | ESXHostNetwork | SV133 Network connectivity issue for distributed virtual switch {DVS.name} in Datacenter {datacenter.name}. The following host physical network links are down
SV134 | info | ESXHostNetwork | SV134 Physical NICs were not assigned on DVS {DVS.name}
SV135 | error | ESXHostStorage | SV135 Storage connectivity issue for host {Host.name}. The following paths to storage are dead - On storage adapter [Hba.Name]([Hba.model]) Pathname [PathName.name] (Datastore[Datastore.name])
SV136 | info | ESXHostStorage | SV136 All VMHBA storage paths are connected for host {Host.name}
SV137 | info | ESXHostStorage | SV137 Storage connectivity issue for host {Host.name} is unknown
SV138 | error | ESXHostNetwork | SV138 Network connectivity issue for virtual switch {Switch.name} on host {host.name}. The following host physical network links are down VMNIC name
SV139 | info | ESXHostNetwork | SV139 Network connection to Virtual Switch {Switch.name} has been restored.
SV140 | info | ESXHostNetwork | SV140 Physical nics were not assigned on switch {switch.Name} on host {host.name}
TaskEvent | info | VC | Task: {info.descriptionId} Since 2.0 Reference
TaskTimeoutEvent | info | VC | Task: {info.descriptionId} time-out Since 2.5 Reference
TeamingMatchEvent | info | ESXHostNetwork | Teaming configuration in the vSphere Distributed Switch {dvs.name} on host {host.name} matches the physical switch configuration in {datacenter.name}. Detail: {healthResult.summary.@enum.dvs.VmwareDistributedVirtualSwitch.TeamingMatchStatus} Since 5.1 Reference
TeamingMisMatchEvent | error | ESXHostNetwork | Teaming configuration in the vSphere Distributed Switch {dvs.name} on host {host.name} does not match the physical switch configuration in {datacenter.name}. Detail: {healthResult.summary.@enum.dvs.VmwareDistributedVirtualSwitch.TeamingMatchStatus} Since 5.1 Reference
TemplateBeingUpgradedEvent | info | VC | Upgrading template {legacyTemplate} Since 2.0 Reference
TemplateUpgradedEvent | info | VC | Template {legacyTemplate} upgrade completed Since 2.0 Reference
TemplateUpgradeFailedEvent | info | VC | Cannot upgrade template {legacyTemplate} due to: {reason.msg} Since 2.0 Reference
TimedOutHostOperationEvent | warning | ESXHost | The operation performed on {host.name} in {datacenter.name} timed out Since 2.0 Reference
UnlicensedVirtualMachinesEvent | info | VC | There are {unlicensed} unlicensed virtual machines on host {host} - there are only {available} licenses available Since 2.5 Reference
UnlicensedVirtualMachinesFoundEvent | info | VC | {unlicensed} unlicensed virtual machines found on host {host} Since 2.5 Reference
UpdatedAgentBeingRestartedEvent | info | VC | The agent on host {host.name} is updated and will soon restart Since 2.5 Reference
UpgradeEvent | info | VC | This event records that the agent has been patched and will be restarted. Since 2.0 Reference
UplinkPortMtuNotSupportEvent | error | ESXHostNetwork | Not all VLAN MTU settings on the external physical switch allow the vSphere Distributed Switch maximum MTU size packets to pass on the uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name}. Since 5.1 Reference
UplinkPortMtuSupportEvent | info | ESXHostNetwork | All VLAN MTU settings on the external physical switch allow the vSphere Distributed Switch maximum MTU size packets to pass on the uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name}. Since 5.1 Reference
UplinkPortVlanTrunkedEvent | info | ESXHostNetwork | The configured VLAN in the vSphere Distributed Switch was trunked by the physical switch connected to uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name}. Since 5.1 Reference
UplinkPortVlanUntrunkedEvent | error | ESXHostNetwork | Not all the configured VLANs in the vSphere Distributed Switch were trunked by the physical switch connected to uplink port {healthResult.uplinkPortKey} in vSphere Distributed Switch {dvs.name} on host {host.name} in {datacenter.name}. Since 5.1 Reference
UserAssignedToGroup | info | VC | User {userLogin} was added to group {group} Since 2.0 Reference
UserLoginSessionEvent | verbose | VC | User {userName}@{ipAddress} logged in Since 2.0 Reference
UserLogoutSessionEvent | verbose | VC | User {userName} logged out Since 2.0 Reference
UserPasswordChanged | info | VC | Password was changed for account {userLogin} on host {host.name} Since 2.0 Reference
UserUnassignedFromGroup | info | VC | User {userLogin} removed from group {group} Since 2.0 Reference
UserUpgradeEvent | user | VC | {message} Since 2.0 Reference
VcAgentUninstalledEvent | info | VC | event.VcAgentUninstalledEvent.fullFormat Since 4.0 Reference
VcAgentUninstallFailedEvent | error | VC | Cannot uninstall vCenter agent from {host.name} in {datacenter.name}. {reason.@enum.fault.AgentInstallFailed.Reason} Since 4.0 Reference
VcAgentUpgradedEvent | info | VC | vCenter agent has been upgraded on {host.name} in {datacenter.name} Since 2.0 Reference
VcAgentUpgradeFailedEvent | error | VC | Cannot upgrade vCenter agent on {host.name} in {datacenter.name}. {reason.@enum.fault.AgentInstallFailed.Reason} Since 2.0 Reference
vim.event.LicenseDowngradedEvent | warning | VC | vim.event.LicenseDowngradedEvent| License downgrade: {licenseKey} removes the following features: {lostFeatures} Since 4.1 Reference
VimAccountPasswordChangedEvent | info | VC | VIM account password was changed on host {host.name} Since 2.5 Reference
VmAcquiredMksTicketEvent | info | VC | Remote console to {vm.name} on {host.name} in {datacenter.name} has been opened Since 2.5 Reference
VmAcquiredTicketEvent | info | VC | A ticket for {vm.name} of type {ticketType} on {host.name} in {datacenter.name} has been acquired Since 4.1 Reference
VmAutoRenameEvent | info | VC | Invalid name for {vm.name} on {host.name} in {datacenter.name}. Renamed from {oldName} to {newName} Since 2.0 Reference
VmBeingClonedEvent | info | VC | Cloning {vm.name} on host {host.name} in {datacenter.name} to {destName} on host {destHost.name} Since 2.0 Reference
VmBeingClonedNoFolderEvent | info | VC | Cloning {vm.name} on host {host.name} in {datacenter.name} to {destName} on host {destHost.name} Since 4.1 Reference
VmBeingCreatedEvent | info | VC | Creating {vm.name} on host {host.name} in {datacenter.name} Since 2.0 Reference
VmBeingDeployedEvent | info | VC | Deploying {vm.name} on host {host.name} in {datacenter.name} from template {srcTemplate.name} Since 2.0 Reference
VmBeingHotMigratedEvent | info | VC | Migrating {vm.name} from {host.name} to {destHost.name} in {datacenter.name} Since 2.0 Reference
VmBeingMigratedEvent | info | VC | Relocating {vm.name} from {host.name} to {destHost.name} in {datacenter.name} Since 2.0 Reference
VmBeingRelocatedEvent | info | VC | Relocating {vm.name} in {datacenter.name} from {host.name} to {destHost.name} Since 2.0 Reference
VmClonedEvent | info | VC | Clone of {sourceVm.name} completed Since 2.0 Reference
VmCloneFailedEvent | error | VC | Cannot clone {vm.name}: {reason.msg} Since 2.0 Reference
VmConfigMissingEvent | info | VC | Configuration file for {vm.name} on {host.name} in {datacenter.name} cannot be found Since 2.0 Reference
VmConnectedEvent | info | VC | Virtual machine {vm.name} is connected Since 2.0 Reference
VmCreatedEvent | info | VC | Created virtual machine {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmDasBeingResetEvent | warning | VirtualMachine | {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} reset due to a guest OS error Since 4.0 Reference
VmDasBeingResetWithScreenshotEvent | warning | VirtualMachine | {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} reset due to a guest OS error. Screenshot is saved at {screenshotFilePath}. Since 4.0 Reference
VmDasResetFailedEvent | error | VirtualMachine | Cannot reset {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} due to a guest OS error Since 4.0 Reference
VmDasUpdateErrorEvent | error | VirtualMachine | Unable to update HA agents given the state of {vm.name} Since 2.0 Reference
VmDasUpdateOkEvent | info | VC | HA agents have been updated with the current state of the virtual machine Since 2.0 Reference
VmDateRolledBackEvent | error | VirtualMachine | Disconnecting all hosts as the date of virtual machine {vm.name} has been rolled back Since 2.0 Reference
VmDeployedEvent | info | VC | Template {srcTemplate.name} deployed on host {host.name} Since 2.0 Reference
VmDeployFailedEvent | error | VC | Cannot deploy template: {reason.msg} Since 2.0 Reference
VmDisconnectedEvent | info | VC | {vm.name} on host {host.name} in {datacenter.name} is disconnected Since 2.0 Reference
VmDiscoveredEvent | info | VC | Discovered {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmDiskFailedEvent | error | VirtualMachine | Cannot create virtual disk {disk} Since 2.0 Reference
VmDVPortEvent | info | VC | dvPort connected to VM {vm.name} on {host.name} in {datacenter.name} changed status Since 4.1 Reference
VmEmigratingEvent | info | VC | Migrating {vm.name} off host {host.name} in {datacenter.name} Since 2.0 Reference
VmEndRecordingEvent | info | VC | End a recording session on {vm.name} Since 4.0 Reference
VmEndReplayingEvent | info | VC | End a replay session on {vm.name} Since 4.0 Reference
VmEvent | info | VC | This is a catch-all event for various VM events (the type of event is listed in the event). See VMware's documentation for the list of possible events. Since 2.0 Reference
VmFailedMigrateEvent | error | VirtualMachine | Cannot migrate {vm.name} from {host.name} to {destHost.name} in {datacenter.name} Since 2.0 Reference
VmFailedRelayoutEvent | error | VirtualMachine | Cannot complete relayout {vm.name} on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedRelayoutOnVmfs2DatastoreEvent | error | VirtualMachine | Cannot complete relayout for virtual machine {vm.name} which has disks on a VMFS2 volume. Since 2.0 Reference
VmFailedStartingSecondaryEvent | error | VirtualMachine | vCenter cannot start the Secondary VM {vm.name}. Reason: {reason.@enum.VmFailedStartingSecondaryEvent.FailureReason} Since 4.0 Reference
VmFailedToPowerOffEvent | error | VirtualMachine | Cannot power Off {vm.name} on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedToPowerOnEvent | error | VirtualMachine | Cannot power On {vm.name} on {host.name} in {datacenter.name}. {reason.msg} Since 2.0 Reference
VmFailedToRebootGuestEvent | error | VirtualMachine | Cannot reboot the guest OS for {vm.name} on {host.name} in {datacenter.name}. {reason.msg} Since 2.0 Reference
VmFailedToResetEvent | error | VirtualMachine | Cannot suspend {vm.name} on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedToShutdownGuestEvent | error | VirtualMachine | {vm.name} cannot shut down the guest OS on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedToStandbyGuestEvent | error | VirtualMachine | {vm.name} cannot standby the guest OS on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedToSuspendEvent | error | VirtualMachine | Cannot suspend {vm.name} on {host.name} in {datacenter.name}: {reason.msg} Since 2.0 Reference
VmFailedUpdatingSecondaryConfig | error | VirtualMachine | vCenter cannot update the Secondary VM {vm.name} configuration Since 4.0 Reference
VmFailoverFailed | warning | VirtualMachine | Failover unsuccessful for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
VmFaultToleranceStateChangedEvent | info | VC | Fault Tolerance state on {vm.name} changed from {oldState.@enum.VirtualMachine.FaultToleranceState} to {newState.@enum.VirtualMachine.FaultToleranceState} Since 4.0 Reference
VmFaultToleranceTurnedOffEvent | info | VC | Fault Tolerance protection has been turned off for {vm.name} Since 4.0 Reference
VmFaultToleranceVmTerminatedEvent | error | VirtualMachine | The Fault Tolerance VM ({vm.name}) has been terminated. {reason.@enum.VmFaultToleranceVmTerminatedEvent.TerminateReason} Since 4.0 Reference
VMFSDatastoreCreatedEvent | info | VC | Created VMFS datastore {datastore.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VMFSDatastoreExpandedEvent | info | VC | Expanded VMFS datastore {datastore.name} on {host.name} in {datacenter.name} Since 4.0 Reference
VMFSDatastoreExtendedEvent | info | VC | Extended VMFS datastore {datastore.name} on {host.name} in {datacenter.name} Since 4.0 Reference
VmGuestRebootEvent | info | VC | Guest OS reboot for {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmGuestShutdownEvent | info | VC | Guest OS shut down for {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmGuestStandbyEvent | info | VC | Guest OS standby for {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmHealthMonitoringStateChangedEvent | info | VC | VM monitoring state in {computeResource.name} in {datacenter.name} changed to {state} Since 4.0 Reference
VmInstanceUuidAssignedEvent | info | VC | Assign a new instance UUID ({instanceUuid}) to {vm.name} Since 4.0 Reference
VmInstanceUuidChangedEvent | info | VC | The instance UUID of {vm.name} has been changed from ({oldInstanceUuid}) to ({newInstanceUuid}) Since 4.0 Reference
VmInstanceUuidConflictEvent | error | VirtualMachine | The instance UUID ({instanceUuid}) of {vm.name} conflicts with the instance UUID assigned to {conflictedVm.name} Since 4.0 Reference
VmMacAssignedEvent | info | VC | New MAC address ({mac}) assigned to adapter {adapter} for {vm.name} Since 2.0 Reference
VmMacChangedEvent | warning | VC | Changed MAC address from {oldMac} to {newMac} for adapter {adapter} for {vm.name} Since 2.0 Reference
VmMacConflictEvent | error | VirtualMachine | The MAC address ({mac}) of {vm.name} conflicts with MAC assigned to {conflictedVm.name} Since 2.0 Reference
VmMaxFTRestartCountReached | warning | VirtualMachine | Reached maximum Secondary VM (with FT turned On) restart count for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 4.0 Reference
VmMaxRestartCountReached | warning | VirtualMachine | Reached maximum VM restart count for {vm.name} on {host.name} in cluster {computeResource.name} in {datacenter.name}. Since 4.0 Reference
VmMessageErrorEvent | error | VirtualMachine | Error message on {vm.name} on {host.name} in {datacenter.name}: {message} Since 4.0 Reference
VmMessageEvent | info | VC | Message on {vm.name} on {host.name} in {datacenter.name}: {message} Since 2.0 Reference
VmMessageWarningEvent | warning | VirtualMachine | Warning message on {vm.name} on {host.name} in {datacenter.name}: {message} Since 4.0 Reference
VmMigratedEvent | info | VC | Migration of virtual machine {vm.name} from {sourceHost.name} to {host.name} completed Since 2.0 Reference
VmNoCompatibleHostForSecondaryEvent | warning | VirtualMachine | No compatible host for the Secondary VM {vm.name} Since 4.0 Reference
VmNoNetworkAccessEvent | warning | VirtualMachine | Not all networks for {vm.name} are accessible by {destHost.name} Since 2.0 Reference
VmOrphanedEvent | warning | VirtualMachine | {vm.name} does not exist on {host.name} in {datacenter.name} Since 2.0 Reference
VMotionLicenseExpiredEvent | error | VC | A VMotion license for {host.name} has expired Since 2.0 Reference
VmPoweredOffEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is powered off Since 2.0 Reference
VmPoweredOnEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is powered on Since 2.0 Reference
VmPoweringOnWithCustomizedDVPortEvent | info | VC | Virtual machine {vm.name} powered On with vNICs connected to dvPorts that have a port level configuration, which might be different from the dvPort group configuration. Since 4.0 Reference
VmPowerOffOnIsolationEvent | info | VC | {vm.name} was powered Off on the isolated host {isolatedHost.name} in cluster {computeResource.name} in {datacenter.name} Since 2.0 Reference
VmPrimaryFailoverEvent | error | VirtualMachine | VM ({vm.name}) failed over to {host.name}. {reason.@enum.VirtualMachine.NeedSecondaryReason} Since 4.0 Reference
VmReconfiguredEvent | info | VC | Reconfigured {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmRegisteredEvent | info | VC | Registered {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmRelayoutSuccessfulEvent | info | VC | Relayout of {vm.name} on {host.name} in {datacenter.name} completed Since 2.0 Reference
VmRelayoutUpToDateEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is in the correct format and relayout is not necessary Since 2.0 Reference
VmReloadFromPathEvent | info | VC | {vm.name} on {host.name} reloaded from new configuration {configPath} Since 4.1 Reference
VmReloadFromPathFailedEvent | error | VirtualMachine | {vm.name} on {host.name} could not be reloaded from {configPath} Since 4.1 Reference
VmRelocatedEvent | info | VC | Completed the relocation of the virtual machine Since 2.0 Reference
VmRelocateFailedEvent | error | VirtualMachine | Cannot relocate virtual machine '{vm.name}' in {datacenter.name} Since 2.0 Reference
VmRemoteConsoleConnectedEvent | info | VC | Remote console connected to {vm.name} on host {host.name} Since 4.0 Reference
VmRemoteConsoleDisconnectedEvent | info | VC | Remote console disconnected from {vm.name} on host {host.name} Since 4.0 Reference
VmRemovedEvent | info | VC | Removed {vm.name} on {host.name} from {datacenter.name} Since 2.0 Reference
VmRenamedEvent | warning | VC | Renamed {vm.name} from {oldName} to {newName} in {datacenter.name} Since 2.0 Reference
VmRequirementsExceedCurrentEVCModeEvent | warning | VirtualMachine | Feature requirements of {vm.name} exceed capabilities of {host.name}'s current EVC mode. Since 5.1 Reference
VmResettingEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is reset Since 2.0 Reference
VmResourcePoolMovedEvent | info | VC | Moved {vm.name} from resource pool {oldParent.name} to {newParent.name} in {datacenter.name} Since 2.0 Reference
VmResourceReallocatedEvent | info | VC | Changed resource allocation for {vm.name} Since 2.0 Reference
VmRestartedOnAlternateHostEvent | info | VC | Virtual machine {vm.name} was restarted on {host.name} since {sourceHost.name} failed Since 2.0 Reference
VmResumingEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is resumed Since 2.0 Reference
VmSecondaryAddedEvent | info | VC | A Secondary VM has been added for {vm.name} Since 4.0 Reference
VmSecondaryDisabledBySystemEvent | error | VirtualMachine | vCenter disabled Fault Tolerance on VM '{vm.name}' because the Secondary VM could not be powered On. Since 4.0 Reference
VmSecondaryDisabledEvent | info | VC | Disabled Secondary VM for {vm.name} Since 4.0 Reference
VmSecondaryEnabledEvent | info | VC | Enabled Secondary VM for {vm.name} Since 4.0 Reference
VmSecondaryStartedEvent | info | VC | Started Secondary VM for {vm.name} Since 4.0 Reference
VmShutdownOnIsolationEvent | info | VC | {vm.name} was shut down on the isolated host {isolatedHost.name} in cluster {computeResource.name} in {datacenter.name}: {shutdownResult.@enum.VmShutdownOnIsolationEvent.Operation} Since 4.0 Reference
VmStartingEvent | info | VC | {vm.name} on host {host.name} in {datacenter.name} is starting Since 2.0 Reference
VmStartingSecondaryEvent | info | VC | Starting Secondary VM for {vm.name} Since 4.0 Reference
VmStartRecordingEvent | info | VC | Start a recording session on {vm.name} Since 4.0 Reference
VmStartReplayingEvent | info | VC | Start a replay session on {vm.name} Since 4.0 Reference
VmStaticMacConflictEvent | error | VC | The static MAC address ({mac}) of {vm.name} conflicts with MAC assigned to {conflictedVm.name} Since 2.0 Reference
VmStoppingEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is stopping Since 2.0 Reference
VmSuspendedEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is suspended Since 2.0 Reference
VmSuspendingEvent | info | VC | {vm.name} on {host.name} in {datacenter.name} is being suspended Since 2.0 Reference
VmTimedoutStartingSecondaryEvent | error | VirtualMachine | Starting the Secondary VM {vm.name} timed out within {timeout} ms Since 4.0 Reference
VmUnsupportedStartingEvent | warning | VirtualMachine | Unsupported guest OS {guestId} for {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmUpgradeCompleteEvent | info | VC | Virtual hardware upgraded to version {version} Since 2.0 Reference
VmUpgradeFailedEvent | error | VirtualMachine | Cannot upgrade virtual hardware Since 2.0 Reference
VmUpgradingEvent | info | VC | Upgrading virtual hardware on {vm.name} in {datacenter.name} to version {version} Since 2.0 Reference
VmUuidAssignedEvent | info | VC | Assigned new BIOS UUID ({uuid}) to {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmUuidChangedEvent | warning | VC | Changed BIOS UUID from {oldUuid} to {newUuid} for {vm.name} on {host.name} in {datacenter.name} Since 2.0 Reference
VmUuidConflictEvent | error | VC | BIOS ID ({uuid}) of {vm.name} conflicts with that of {conflictedVm.name} Since 2.0 Reference
VmVnicPoolReservationViolationClearEvent | info | VC | The reservation violation on the virtual NIC network resource pool {vmVnicResourcePoolName} with key {vmVnicResourcePoolKey} on {dvs.name} is cleared Since 5.5 Reference
VmVnicPoolReservationViolationRaiseEvent | info | VC | The reservation allocated to the virtual NIC network resource pool {vmVnicResourcePoolName} with key {vmVnicResourcePoolKey} on {dvs.name} is violated Since 5.5 Reference
VmWwnAssignedEvent | info | VC | New WWNs assigned to {vm.name} Since 2.5 Reference
VmWwnChangedEvent | warning | VirtualMachine | WWNs are changed for {vm.name} Since 2.5 Reference
VmWwnConflictEvent | error | VirtualMachine | The WWN ({wwn}) of {vm.name} conflicts with the currently registered WWN Since 2.5 Reference
vprob.net.connectivity.lost | error | ESXHostNetwork | vprob.net.connectivity.lost| Lost network connectivity on virtual switch {1}. Physical NIC {2} is down. Affected portgroups:{3}. Since 4.0 Reference
vprob.net.e1000.tso6.notsupported | error | ESXHostNetwork | vprob.net.e1000.tso6.notsupported| Guest-initiated IPv6 TCP Segmentation Offload (TSO) packets ignored. Manually disable TSO inside the guest operating system in virtual machine {1}, or use a different virtual adapter. Since 4.0 Reference
vprob.net.migrate.bindtovmk | warning | ESXHostNetwork | vprob.net.migrate.bindtovmk| The ESX advanced config option /Migrate/Vmknic is set to an invalid vmknic: {1}. /Migrate/Vmknic specifies a vmknic that VMotion binds to for improved performance. Please update the config option with a valid vmknic or, if you don't want VMotion to bind to a specific vmknic, remove the invalid vmknic and leave the option blank. Since 4.0 Reference
vprob.net.proxyswitch.port.unavailable | error | ESXHostNetwork | vprob.net.proxyswitch.port.unavailable| Virtual NIC with hardware address {1} failed to connect to distributed virtual port {2} on switch {3}. No more ports available on the host proxy switch. Since 4.0 Reference
vprob.net.redundancy.degraded | warning | ESXHostNetwork | vprob.net.redundancy.degraded| Uplink redundancy degraded on virtual switch {1}. Physical NIC {2} is down. {3} uplinks still up. Affected portgroups:{4}. Since 4.0 Reference
vprob.net.redundancy.lost | warning | ESXHostNetwork | vprob.net.redundancy.lost| Lost uplink redundancy on virtual switch {1}. Physical NIC {2} is down. Affected portgroups:{3}. Since 4.0 Reference
vprob.scsi.device.thinprov.atquota | warning | VC | vprob.scsi.device.thinprov.atquota| Space utilization on thin-provisioned device {1} exceeded configured threshold. Since 4.1 Reference
vprob.storage.connectivity.lost | error | ESXHostStorage | vprob.storage.connectivity.lost| Lost connectivity to storage device {1}. Path {2} is down. Affected datastores: {3}. Since 4.0 Reference
vprob.storage.redundancy.degraded | warning | ESXHostStorage | vprob.storage.redundancy.degraded| Path redundancy to storage device {1} degraded. Path {2} is down. {3} remaining active paths. Affected datastores: {4}. Since 4.0 Reference
vprob.storage.redundancy.lost | warning | ESXHostStorage | vprob.storage.redundancy.lost| Lost path redundancy to storage device {1}. Path {2} is down. Affected datastores: {3}. Since 4.0 Reference
vprob.vmfs.error.volume.is.locked | error | ESXHostStorage | vprob.vmfs.error.volume.is.locked| Volume on device {1} is locked, possibly because some remote host encountered an error during a volume operation and could not recover. Since 5.0 Reference
vprob.vmfs.extent.offline | warning | ESXHostStorage | vprob.vmfs.extent.offline| An attached device {1} might be offline. The file system {2} is now in a degraded state. While the datastore is still available, parts of data that reside on the extent that went offline might be inaccessible. Since 5.0 Reference
vprob.vmfs.extent.online | info | ESXHostStorage | vprob.vmfs.extent.online| Device {1} backing file system {2} came online. This extent was previously offline. All resources on this device are now available. Since 5.0 Reference
vprob.vmfs.heartbeat.recovered | info | ESXHostStorage | vprob.vmfs.heartbeat.recovered| Successfully restored access to volume {1} ({2}) following connectivity issues. Since 4.0 Reference
vprob.vmfs.heartbeat.timedout | warning | ESXHostStorage | vprob.vmfs.heartbeat.timedout| Lost access to volume {1} ({2}) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly. Since 4.0 Reference
vprob.vmfs.heartbeat.unrecoverable | error | ESXHostStorage | vprob.vmfs.heartbeat.unrecoverable| Lost connectivity to volume {1} ({2}) and subsequent recovery attempts have failed. Since 4.0 Reference
vprob.vmfs.journal.createfailed | warning | ESXHostStorage | vprob.vmfs.journal.createfailed| No space for journal on volume {1} ({2}). Opening volume in read-only metadata mode with limited write support. Since 4.0 Reference
vprob.vmfs.lock.corruptondisk | error | ESXHostStorage | vprob.vmfs.lock.corruptondisk| At least one corrupt on-disk lock was detected on volume {1} ({2}). Other regions of the volume may be damaged too. Since 4.0 Reference
vprob.vmfs.nfs.server.disconnect | error | ESXHostStorage | vprob.vmfs.nfs.server.disconnect| Lost connection to server {1} mount point {2} mounted as {3} ({4}). Since 4.0 Reference
vprob.vmfs.nfs.server.restored | info | ESXHostStorage | vprob.vmfs.nfs.server.restored| Restored connection to server {1} mount point {2} mounted as {3} ({4}). Since 4.0 Reference
vprob.vmfs.resource.corruptondisk | error | ESXHostStorage | vprob.vmfs.resource.corruptondisk| At least one corrupt resource metadata region was detected on volume {1} ({2}). Other regions of the volume may be damaged too. Since 4.0 Reference
vprob.vmfs.volume.locked | error | ESXHostStorage | vprob.vmfs.volume.locked| Volume on device {1} locked, possibly because remote host {2} encountered an error during a volume operation and could not recover. Since 4.0 Reference
WarningUpgradeEvent | warning | VC | {message} Since 2.0 Reference


vcEventsDoc

 Top

• Event AccountCreatedEvent

This event records that an account was created on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AccountRemovedEvent

This event records that an account was removed from a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AccountUpdatedEvent

This event records that an account was updated on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ad.event.ImportCertEvent

Import certificate succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.ImportCertFailedEvent

Import certificate failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.JoinDomainEvent

Join domain succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.JoinDomainFailedEvent

Join domain failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.LeaveDomainEvent

Leave domain succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.LeaveDomainFailedEvent

Leave domain failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AdminPasswordNotChangedEvent

Default password for the Admin user on the host has not been changed.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event AlarmAcknowledgedEvent

Alarm acknowledged

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AlarmActionTriggeredEvent

This event records that an alarm was triggered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmClearedEvent

Alarm cleared manually

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AlarmCreatedEvent

This event records the creation of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmEmailCompletedEvent

This event records the completion of an alarm email notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmEmailFailedEvent

This event records a failure to complete an alarm email notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmReconfiguredEvent

This event records the reconfiguration of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmRemovedEvent

This event records the removal of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmScriptCompleteEvent

This event records the completion of an alarm-triggered script.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmScriptFailedEvent

This event records a failure to complete an alarm-triggered script.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmSnmpCompletedEvent

This event records the completion of an alarm SNMP notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmSnmpFailedEvent

This event records a failure to complete an alarm SNMP notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmStatusChangedEvent

This event records that an entity (such as a host or VM) has changed its overall status because an alarm was triggered. The event will show which entity and will indicate which alarm was triggered.

A host's or VM's alarm status changing from "green"/ "yellow" / "red" to "gray" may indicate that the host or VM has been shutdown.

If the alarm status is "yellow" or "red" then the icons in the VI Client will change.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AllVirtualMachinesLicensedEvent

This event records that the previously unlicensed virtual machines on the specified host are now licensed. After this event is entered into the event log, we expect to see that the configuration issue removed from the host managed object.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event AlreadyAuthenticatedSessionEvent

This event records a failed user logon due to the user already being logged on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event BadUsernameSessionEvent

This event records a failed user logon. Failed logons are due to no match existing between the provided user name and password combination and the combinations stored for authentication.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CanceledHostOperationEvent

An operation performed on the host was canceled. Typically, a previous event in the sequence of events contains more information about the cause of this cancellation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ChangeOwnerOfFileEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ChangeOwnerOfFileFailedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ClusterComplianceCheckedEvent

This event records that a compliance check was triggered on the cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ClusterCreatedEvent

This event records when a cluster is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterDestroyedEvent

This event records when a cluster is destroyed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterOvercommittedEvent

This event records when a cluster's host capacity cannot satisfy resource configuration constraints.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterReconfiguredEvent

This event records when a cluster is reconfigured.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterStatusChangedEvent

This event records when a cluster's overall status changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.AddLicenseEvent

Added License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.AssignLicenseEvent

Assigned License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.DLFDownloadFailedEvent

Download License Information

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseAssignFailedEvent

License assignment faults

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseCapacityExceededEvent

License usage exceeds the license capacity

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseExpiryEvent

License Expiry

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseUserThresholdExceededEvent

License User Threshold Exceeded

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.license.RemoveLicenseEvent

Removed License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.UnassignLicenseEvent

Unassigned License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.cim.CIMGroupHealthStateChanged

Hardware Health Changed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdatedVmFilesEvent

Updated VM files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdateVmFilesFailedEvent

Failed to update VM files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdatingVmFilesEvent

Updating VM Files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.dvs.LacpConfigInconsistentEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ft.VmAffectedByDasDisabledEvent

VMware HA has been disabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.guestOperations.GuestOperation

Guest operation performed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.guestOperations.GuestOperationAuthFailure

Authentication failed for guest operation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AllHostAddrsPingable

All vSphere HA isolation addresses are reachable by host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AllIsoAddrsPingable

All vSphere HA isolation addresses are reachable by host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AnsweredVmLockLostQuestionEvent

Lock-lost question was answered by vSphere HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AnsweredVmTerminatePDLEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AutoStartDisabled

The automatic Virtual Machine Startup/Shutdown feature has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.CannotResetVmWithInaccessibleDatastore

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterContainsIncompatibleHosts

vSphere HA Cluster contains ESX/ESXi 3.5 hosts and more recent host versions, which isn't fully supported.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterFailoverActionCompletedEvent

HA completed a failover action

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterFailoverActionInitiatedEvent

HA initiated a failover action

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasAgentRunningEvent

HA Agent is running

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostFailedEvent

HA failover host has failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostIsolatedEvent

Host has been isolated from cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostPartitionedEvent

Failover Host is in a different network partition than the master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostUnreachableEvent

The vSphere HA agent on the failover host is not reachable from vCenter Server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostCompleteDatastoreFailureEvent

Host complete datastore failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostCompleteNetworkFailureEvent

Host complete network failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostFailedEvent

A possible host failure has been detected by HA

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostIsolatedEvent

Host has been isolated from cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostMonitoringDisabledEvent

No virtual machine failover will occur until Host Monitoring is enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasTotalClusterFailureEvent

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.FailedRestartAfterIsolationEvent

Failed to restart VM after isolation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HeartbeatDatastoreChanged

Datastore heartbeat changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HeartbeatDatastoreNotSufficient

Number of heartbeat datastores is less than required

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostAgentErrorEvent

Host HA Agent has an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDasAgentHealthyEvent

HA Agent on host is healthy

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDasErrorEvent

Host HA has an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDoesNotSupportVsan

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoIsolationAddrsDefined

Host has no isolation addresses defined as required by vSphere HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoMountedDatastores

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoSslThumbprint

vSphere HA cannot be configured because its SSL thumbprint has not been verified

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostIncompatibleWithHA

The product version of host is incompatible with HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostPartitionedFromMasterEvent

Host is in a different network partition than the master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostStateChangedEvent

Host HA state has changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostUnconfiguredWithProtectedVms

Host with protected VMs is disconnected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostUnconfigureError

Error unconfiguring HA agent on host. To solve this problem, connect the host to a vCenter Server of version 5.0 or later.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.InvalidMaster

HA Agent on host is an invalid master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.NotAllHostAddrsPingable

Host HA Agent cannot reach some of the management network addresses of other hosts

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.StartFTSecondaryFailedEvent

Host HA agent failed to start Fault Tolerance secondary VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.StartFTSecondarySucceededEvent

Host HA agent successfully started Fault Tolerance secondary VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.UserHeartbeatDatastoreRemoved

Datastore is removed from inventory

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcCannotFindMasterEvent

vCenter Server is unable to find a master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcConnectedToMasterEvent

vCenter Server is connected to the master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcDisconnectedFromMasterEvent

vCenter Server is disconnected from the master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VMIsHADisabledIsolationEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VMIsHADisabledRestartEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmNotProtectedEvent

VM failed to become vSphere HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmProtectedEvent

VM is vSphere HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ha.VmRestartedByHAEvent

VM was restarted by HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmUnprotectedEvent

VM is not HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmUnprotectedOnDiskSpaceFull

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.AutoStartReconfigureFailedEvent

Failed to reconfigure autostart rules for virtual machines

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.clear.vFlashResource.inaccessible

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.clear.vFlashResource.reachthreshold

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.problem.vFlashResource.inaccessible

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.problem.vFlashResource.reachthreshold

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.defaultModuleChangedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.modulesLoadedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.SsdConfigurationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceCapacityExtendedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceConfiguredEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceRemovedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.npt.VmAdapterEnteredPassthroughEvent

Virtual NIC entered passthrough mode

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.npt.VmAdapterExitedPassthroughEvent

Virtual NIC exited passthrough mode

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.CloneOvfConsumerStateErrorEvent

Failed to clone extension entity state

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.GetOvfEnvironmentSectionsErrorEvent

Failed to retrieve OVF environment sections from extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.PowerOnAfterCloneErrorEvent

Extension has blocked powering on of cloned VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.RegisterEntityErrorEvent

Failed to register entity on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.UnregisterEntitiesErrorEvent

Failed to unregister entities on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.ValidateOstErrorEvent

Failed to validate OVF descriptor on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.profile.AnswerFileExportedEvent

Answer file has been exported

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.profile.AnswerFileUpdatedEvent

Answer file has been updated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.rp.ResourcePoolRenamedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.CanceledDatastoreMaintenanceModeEvent

The datastore maintenance mode operation has been canceled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.ConfiguredStorageDrsOnPodEvent

Storage DRS configured on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.ConsistencyGroupViolationEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreEnteredMaintenanceModeEvent

Datastore has entered maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreEnteringMaintenanceModeEvent

Datastore is entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreExitedMaintenanceModeEvent

Datastore has exited maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreInMultipleDatacentersEvent

Datastore cluster has one or more datastores shared across multiple datacenters

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreMaintenanceModeErrorsEvent

Datastore encountered errors while entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsDisabledEvent

Storage DRS disabled on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsEnabledEvent

Storage DRS enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsInvocationFailedEvent

Storage DRS invocation failed on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsNewRecommendationPendingEvent

A new storage DRS recommendation has been generated on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsNotSupportedHostConnectedToPodEvent

Datastore cluster is connected to one or more hosts that do not support storage DRS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsRecommendationApplied

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsStorageMigrationEvent

VM disks migrated by storage DRS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsStoragePlacementEvent

Storage DRS placed disks of VM on specified datastore

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StoragePodCreatedEvent

Datastore cluster created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StoragePodDestroyedEvent

Datastore cluster removed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sioc.NotSupportedHostConnectedToDatastoreEvent

SIOC has detected that a host is running an older version of ESX that does not support SIOC

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusNonCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusUnknownEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityInitEvent

Storage provider system default capability event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityMetEvent

Storage provider system capability requirements met

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityNotMetEvent

Storage provider system capability requirements not met

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.provider.health.event

SMS Provider health event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.provider.system.event

SMS Provider system event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdClearedEvent

Storage provider thin provisioning capacity threshold reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdCrossedEvent

Storage provider thin provisioning capacity threshold crossed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdInitEvent

Storage provider thin provisioning default capacity event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusNonCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusUnknownEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.spbm.ProfileAssociationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.stats.HostQuickStatesNotUpToDateEvent

Host quick stats is not up-to-date

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VCHealthStateChangedEvent

vCenter Service Overall Health Changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtDisabledVmTreatAsNonFtEvent

HA VM Component Protection protects virtual machine as non-FT virtual machine because the FT state is disabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtFailoverEvent

FT Primary VM is going to fail over to Secondary VM due to component failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtFailoverFailedEvent

FT virtual machine failed to failover to secondary

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtSecondaryRestartEvent

HA VM Component Protection is restarting FT secondary virtual machine

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtSecondaryRestartFailedEvent

FT Secondary VM failed to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.NeedSecondaryFtVmTreatAsNonFtEvent

HA VM Component Protection protects virtual machine as non-FT virtual machine because it has been in the needSecondary state too long

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.TestEndEvent

VM Component Protection test ends

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.TestStartEvent

VM Component Protection test starts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VcpNoActionEvent

HA VM Component Protection did not take action on VM

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmDatastoreFailedEvent

Virtual machine lost datastore access

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmNetworkFailedEvent

Virtual machine lost VM network accessibility

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmPowerOffHangEvent

VM power off hang

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmRestartEvent

HA VM Component Protection is restarting virtual machine due to component failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmRestartFailedEvent

Virtual machine affected by component failure failed to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmWaitForCandidateHostEvent

No candidate host to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmRegisterFailedEvent

VM registration failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmStateFailedToRevertToSnapshot

Failed to revert the execution state of the virtual machine to snapshot

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmStateRevertedToSnapshot

The execution state of the virtual machine has been reverted to the state of snapshot

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.AppMonitoringNotSupported

Application monitoring is not supported

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmAppHealthMonitoringStateChangedEvent

Application heartbeat status changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmAppHealthStateChangedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmDasAppHeartbeatFailedEvent

Application heartbeat failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmCloneFailedInvalidDestinationEvent

Cannon clone a VM to invalid or non-existent destination

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmCloneToResourcePoolFailedEvent

Cannot clone a VM to resource pool

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidatedEvent

VM disks successfully consolidated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidationNeeded

VM disks consolidation is needed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidationNoLongerNeeded

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskFailedToConsolidateEvent

VM disks consolidation failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.DatastoreNoCapacityEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostCommunicationErrorEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostNotInClusterEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostNotInVsanClusterEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderDeregistrationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderDeregistrationSuccessEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderRegistrationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderRegistrationSuccessEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.NetworkMisConfiguredEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.RogueHostFoundEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.create

EAM Agency created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.destroyed

EAM Agency destroyed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.goalstate

EAM Agency goal state changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.statusChanged

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.updated

EAM Agency configuration updated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.created

EAM Agent added to host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.destroyed

EAM Agent removed from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.destroyedNoHost

EAM Agent removed from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterPowerOn

Agent VM has been powered on.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterProvisioning

Agent VM has been powered on.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.statusChanged

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.deleteVm

Agent VM is deleted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.deployVm

Agent VM is provisioned

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.powerOffVm

Agent VM powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.powerOnVm

Agent VM powered on

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.vibInstalled

VIB installed on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.vibUninstalled

VIB unistalled from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.cannotAccessAgentOVF

Unable to access agent OVF package

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.cannotAccessAgentVib

Unable to access agent VIB module

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostInMaintenanceMode

Agent cannot complete an operation since the host is in maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostInStandbyMode

Agent cannot complete an operation since the host is in standby mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostPoweredOff

Agent cannot complete an operation since the host is powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.incompatibleHostVersion

Agent is not deployed due to incompatible host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientIpAddresses

Insufficient IP addresses in IP pool in agent's VM network

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientResources

Agent cannot be provisioned due to insufficient resources on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientSpace

Agent on cannot be provisioned due to insufficient space on datastore

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.missingAgentIpPool

No IP pool in agent's VM network

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.missingDvFilterSwitch

dvFilter switch is not configured

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noAgentVmDatastore

No agent datastore configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noAgentVmNetwork

No agent network configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noCustomAgentVmDatastore

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noCustomAgentVmNetwork

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.orphandedDvFilterSwitch

Unused dvFilter switch

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.orphanedAgency

Orphaned agency found

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.ovfInvalidFormat

OVF used to provision agent has invalid format

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.ovfInvalidProperty

OVF environment has one or more invalid properties

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.resolved

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.unknownAgentVm

Unknown agent VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibCannotPutHostInMaintenanceMode

Cannot put host into maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibInvalidFormat

Invalid format for VIB module

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibNotInstalled

VIB module for agent is not installed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresHostInMaintenanceMode

Host must be put into maintenance mode to complete agent VIB installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresHostReboot

Host must be rebooted to complete agent VIB installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresManualInstallation

VIB requires manual installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresManualUninstallation

VIB requires manual uninstallation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmCorrupted

Agent VM is corrupted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmDeployed

Agent VM is provisioned on host when it should be removed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmMarkedAsTemplate

Agent VM is marked as template

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmNotDeployed

Agent VM is missing on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmOrphaned

Orphaned agent VM detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmPoweredOff

Agent VM is expected to be powered on

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmPoweredOn

Agent VM is expected to be powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmSuspended

Agent VM is expected to be powered on but is suspended

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmWrongFolder

Agent VM is in the wrong VM folder

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmWrongResourcePool

Agent VM is in wrong resource pool

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.login.invalid

Failed login to vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.login.succeeded

User logged into vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.logout

User logged out of vSphere ESX Agent Manager by logging out of the vCenter server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.scanForUnknownAgentVmsCompleted

Scan for unknown agent VMs completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.scanForUnknownAgentVmsInitiated

Scan for unknown agent VMs initiated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.setupDvFilter

DvFilter switch is setup on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.tearDownDvFilter

DvFilter switch is teared down on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.unauthorized.access

Unauthorized access in vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.vum.failedtouploadvib

Failed to upload VIB to VMware Update Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.bind.vApp

VSM Dependecy bind - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.bind.vm

VSM Dependecy bind - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.create.vApp

VSM Dependecy create - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.create.vm

VSM Dependecy create - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.destroy.vApp

VSM Dependecy destroy - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.destroy.vm

VSM Dependecy destroy - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.reconfigure.vApp

VSM Dependecy reconfigure - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.reconfigure.vm

VSM Dependecy reconfigure - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.unbind.vApp

VSM Dependecy unbind - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.unbind.vm

VSM Dependecy unbind - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.update.vApp

VSM Dependecy update - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.update.vm

VSM Dependecy update - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.register

VSM Provider register

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.unregister

VSM Provider unregister

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.update

VSM Provider update

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefAddedEvent

This event records the addition of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefEvent

This event records a custom field definition event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefRemovedEvent

This event records the removal of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefRenamedEvent

This event records the renaming of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldValueChangedEvent

This event records a change to a custom field value for a particular entity.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomizationFailed

The customization sequence completed unsuccessfully in the guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationLinuxIdentityFailed

Failed to set Linux identity. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationNetworkSetupFailed

Network setup failed in the guest during customization. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationStartedEvent

The customization sequence has started in the VM guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationSucceeded

The customization sequence completed successfully in the guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationSysprepFailed

Sysprep failed to run in the guest during customization. This will most like have been caused by the fact that the wrong sysprep was used for the guest, so we include the version information in the event. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationUnknownFailure

The customization sequence failed unexpectedly in the guest. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DasAdmissionControlDisabledEvent

This event records when admission control checks have been disabled in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAdmissionControlEnabledEvent

This event records when admission control checks have been enabled in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAgentFoundEvent

This event records that vCenter has re-established contact with a primary host in this HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAgentUnavailableEvent

This event records that vCenter cannot contact any primary host in this HA cluster. HA designates some hosts as primary hosts in the HA cluster. When adding a new host to an existing cluster, HA needs to contact one of the primary hosts to finish the configuration. vCenter has lost contact with all primary nodes in the connected state. Attempts to configure HA on a host in this cluster will fail until a DasAgentFoundEvent is logged or unless this is the first node to be configured. For example, if all the other hosts are disconnected first.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasClusterIsolatedEvent

This event records that all hosts have been isolated from the network in a HA cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DasDisabledEvent

This event records when a cluster has been disabled for HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasEnabledEvent

This event records when a cluster has been enabled for HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasHostFailedEvent

This event records when a host failure has been detected by HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasHostIsolatedEvent

This event records that a host has been isolated from the network in a HA cluster. Since an isolated host cannot be distinguished from a failed host except by the isolated host itself, this event is logged when the isolated host regains network connectivity.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatacenterCreatedEvent

This event records when a datacenter object has been created.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DatacenterRenamedEvent

This event is generated whenever a datacenter is renamed.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DatastoreCapacityIncreasedEvent

This event records when increase in a datastore's capacity is observed. It may happen due to different reasons, like extending or expanding a datastore.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreDestroyedEvent

This event records when a datastore is removed from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreDiscoveredEvent

This event records when a host is added to vCenter and datastores are discovered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreDuplicatedEvent

This event records when a duplicate datastore name is found. This event is used in vCenter 1.x and is included for backward compability.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileCopiedEvent

This event records copy of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileDeletedEvent

This event records deletion of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileMovedEvent

This event records move of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreIORMReconfiguredEvent

This event records that the configuration of storage I/O resource management for a datastore has changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DatastorePrincipalConfigured

This event records that a datastore principal was configured on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRemovedOnHostEvent

This event records when a datastore is removed from a host but not from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRenamedEvent

This event records the renaming of a datastore.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRenamedOnHostEvent

This event records when a datastore is added to vCenter and is renamed by vCenter because this datastore already exists in vCenter with a different name, or because the name conflicts with another datastore in vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsDisabledEvent

This event records when DRS is disabled on a cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsEnabledEvent

This event records when DRS is enabled on a cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsEnteredStandbyModeEvent

This event records that the host has completely put into standby mode by Distributed Power Management. A host in this mode has no running virtual machines and no provisioning operations are occurring.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DrsEnteringStandbyModeEvent

This event records that a host has begun the process of entering standby mode initiated by Distributed Power Management.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsExitedStandbyModeEvent

This event records that Distributed Power Management has brought this host out of standby mode.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DrsExitingStandbyModeEvent

This event records that a host has begun the process of exiting standby mode initiated by Distributed Power Management.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsExitStandbyModeFailedEvent

This event records that Distributed Power Managment tried to bring a host out from standby mode, but the host failed to exit standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsInvocationFailedEvent

This event records DRS invocation failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsRecoveredFromFailureEvent

This event records that DRS has recovered from failure. It is triggered by a successful DRS invocation after repeated failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsResourceConfigureFailedEvent

This event records when resource configuration specification synchronization fails on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsResourceConfigureSyncedEvent

This event records when resource configuration specification returns to synchronized from previous failure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsRuleComplianceEvent

This event records when a virtual machine comes into compliance with DRS rules

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DrsRuleViolationEvent

This event records when a virtual machine violates a DRS rule

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DrsVmMigratedEvent

This event records a virtual machine migration that was recommended by DRS.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsVmPoweredOnEvent

This event records when a virtual machine is powered on by DRS.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DuplicateIpDetectedEvent

This event records that a duplicate IP address has been observed in conflict with the vmotion or IP storage interface configured on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DvpgImportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvpgRestoreEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DVPortgroupCreatedEvent

Distributed virtual portgroup was created

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupDestroyedEvent

Distributed virtual portgroup was destroyed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupReconfiguredEvent

Distributed virtual portgroup was reconfigured

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupRenamedEvent

Distributed virtual portgroup was renamed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsCreatedEvent

A distributed virtual switch was created

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsDestroyedEvent

A distributed virtual switch was destroyed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsEvent

These are dvs-related events.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHealthStatusChangeEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsHostBackInSyncEvent

The DVS configuration on the host was synchronized with that of the vCenter Server and the configuration is the same on the host and vCenter Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostJoinedEvent

A host joined the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostLeftEvent

A host left the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostStatusUpdated

A host has it's status or statusDetail updated

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsHostWentOutOfSyncEvent

The DVS configuration on the host diverged from that of the Virtual Center Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsImportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsMergedEvent

Two distributed virtual switches was merged.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortBlockedEvent

A port is blocked in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortConnectedEvent

A port is connected in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortCreatedEvent

New ports are created in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortDeletedEvent

Existing ports are deleted in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortDisconnectedEvent

A port is disconnected in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortEnteredPassthruEvent

A port has entered passthrough mode on the distributed virtual switch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsPortExitedPassthruEvent

A port has exited passthrough mode on the distributed virtual switch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsPortJoinPortgroupEvent

A port was moved into the distributed virtual portgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLeavePortgroupEvent

A port was moved out of the distributed virtual portgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLinkDownEvent

A port of which link status is changed to down in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLinkUpEvent

A port of which link status is changed to up in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortReconfiguredEvent

Existing ports are reconfigured in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortRuntimeChangeEvent

DVS runtime information changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event DvsPortUnblockedEvent

A port is blocked in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortVendorSpecificStateChangeEvent

Vendor specific state changed in the DVS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event DvsReconfiguredEvent

A distributed virtual switch was reconfigured.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsRenamedEvent

A distributed virtual switch was renamed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsRestoreEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsUpgradeAvailableEvent

An upgrade for the distributed virtual switch is available.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradedEvent

The distributed virtual switch was upgraded.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradeInProgressEvent

An upgrade for the distributed virtual switch is in progress.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradeRejectedEvent

An upgrade for the distributed virtual switch is rejected.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event EnteredMaintenanceModeEvent

This event records that the host has completely entered maintenance mode. A host in this mode has no running virtual machines and no provisioning operations are occuring.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event EnteredStandbyModeEvent

This event records that the host has completely entered standby mode. A host in this mode has no running virtual machines and no provisioning operations are occurring.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event EnteringMaintenanceModeEvent

This event records that a host has begun the process of entering maintenance mode. All virtual machine operations are blocked, except for the following:

· MigrateVM
· PowerOffVM
· SuspendVM
· ShutdownGuest
· StandbyGuest

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event EnteringStandbyModeEvent

This event records that a host has begun the process of entering standby mode. All virtual machine operations are blocked, except for the following:

· MigrateVM
· PowerOffVM
· SuspendVM
· ShutdownGuest
· StandbyGuest

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event ErrorUpgradeEvent

This event is a general error event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.defaults.factoryrestore

The host has been restored to default factory settings

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.disabled

The DCUI has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.enabled

The DCUI has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.host.reboot

The host is being rebooted through the Direct Console User Interface (DCUI)

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.host.shutdown

The host is being shut down through the Direct Console User Interface (DCUI)

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.hostagents.restart

The management agents on the host are being restarted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.login.failed

Authentication has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.login.passwd.changed

Login password has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.network.factoryrestore

The host has been restored to factory network settings

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.network.restart

A management interface has been restarted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esxcli.host.poweroff

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.esxcli.host.restart

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.hostacceptance.changed

Host acceptance level changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.install.novalidation

Attempting to install an image profile with validation disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.install.securityalert

SECURITY ALERT: Installing image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.profile.install.successful

Successfully installed image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.profile.update.successful

Successfully updated host to image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.vib.install.successful

Successfully installed VIBs

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.vib.remove.successful

Successfully removed VIBs

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.boot

Host has booted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.maxRegisteredVMsExceeded

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.host.stop.reboot

Host is rebooting

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.stop.shutdown

Host is shutting down

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.lockdownmode.disabled

Administrator access to the host has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.lockdownmode.enabled

Administrator access to the host has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.canceled

The host has canceled entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.entered

The host has entered maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.entering

The host has begun entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.exited

The host has exited maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.config.changed

Firewall configuration has changed.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.disabled

Firewall has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.enabled

Firewall has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.port.hooked

Port is now protected by Firewall

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.port.removed

Port is no longer protected with Firewall.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.disable

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.enable

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.uplink.connected

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.ip.change

VDL2 IP changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.mappingtable.full

Mapping table entries of VDL2 network exhausted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.route.change

VDL2 IP interface default route changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.shell.disabled

The ESX command line shell has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.shell.enabled

The ESX command line shell has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.ssh.disabled

SSH access has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.ssh.enabled

SSH access has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.usb.config.changed

USB configuration has changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.uw.secpolicy.alldomains.level.changed

The enforcement level for all security domains has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.uw.secpolicy.domain.level.changed

The enforcement level for security domain has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.lvm.device.discovered

One or more LVM devices have been discovered

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.volume.mounted

File system has been mounted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.volume.umounted

The volume has been safely un-mounted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vsan.clustering.enabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.coredump.configured

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.connectivity.restored

Restored network connectivity to portgroups

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.dvport.connectivity.restored

Restored Network Connectivity to DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.dvport.redundancy.restored

Restored Network Redundancy to DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.lag.transition.up

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.uplink.transition.up

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.uplink.unblocked

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.redundancy.restored

Restored uplink redundancy to portgroups

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.vmnic.linkstate.up

Link state up

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.io.latency.improved

Device performance has improved

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.state.on

Device has been turned on administratively

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.state.permanentloss.deviceonline

Device that was permanently inaccessible is now online. No data consistency guarantees

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.apd.exit

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.connectivity.restored

Restored connectivity to storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.redundancy.restored

Restored path redundancy to storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.clustering.enabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.network.available

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.vmknic.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.error

A 3rd party component running on ESXi has reported an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.info

A 3rd party component running on ESXi has reported an info message

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.warning

A 3rd party component running on ESXi has reported a warning

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.corrected

A corrected memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.fatal

A fatal memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.recoverable

A recoverable memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.corrected

A corrected PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.fatal

A fatal PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.recoverable

A recoverable PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.application.core.dumped

An application running on ESXi host has crashed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.coredump.unconfigured

No vmkcore disk partition is available and no network coredump server has been configured. Host core dumps cannot be saved.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.amd.mce.dram.disabled

DRAM ECC not enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.intel.ioapic.listing.error

Not all IO-APICs are listed in the DMAR

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.mce.invalid

MCE monitoring will be disabled as an unsupported CPU was detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.invalid

Disabling HyperThreading due to invalid configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.numpcpus.max

CPU limit reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.partner.missing

Disabling HyperThreading due to invalid configuration: HT partner is missing from PCPU

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.none

Unable to obtain a DHCP lease

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.offered.error

dhclient reported an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.persistent.none

No working DHCP leases in persistent database

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.error

Image profie could not be installed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.invalidhardware

Host doesn't meet hardware requirements

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.stage.error

Could not stage image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.acpi.interrupt.routing.device.invalid

BIOS bug, skipping interrupt routing entry with bad device number

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.acpi.interrupt.routing.pin.invalid

BIOS bug, skipping interrupt routing entry with bad device pin

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.ioapic.missing

IOAPIC is missing. Please check BIOS settings.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.host.coredump

An unread host kernel core dump has been found

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hostd.core.dumped

hostd crashed with a core file created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.iorm.badversion

Host cannot participate in SIOC because of incompatible version number

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.iorm.nonviworkload

External/Uncontrolled workload detected on a datastore

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.migrate.vmotion.default.heap.create.failed

Default migration heap creation failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.migrate.vmotion.server.pending.cnx.listen.socket.shutdown

The ESXi host's vMotion network server encountered an error while monitoring incoming network connections. Shutting down listener socket. vMotion might not be possible with this host until vMotion is manually re-enabled.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.connectivity.lost

Network connectivity lost on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.connectivity.lost

Network connectivity lost on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.redundancy.degraded

Network Redundancy Degraded on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.redundancy.lost

Network Redundancy Lost on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.e1000.tso6.notsupported

Guest-initiated IPv6 TCP Segmentation Offload (TSO) packets ignored. Manually disable TSO inside the guest operating system, or use a different virtual adapter.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.port.badfenceid

VMkernel failed to set fenceId

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.resource.limited

Maximum number of fence networks or ports have been reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.switch.unavailable

dvSwitch fence property is not set

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.firewall.config.failed

Firewall configuration failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.firewall.port.hookfailed

Adding port to Firewall failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.gateway.set.failed

Cannot connect to the specified gateway

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.heap.belowthreshold

Heap free size dropped

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.lag.transition.down

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.peer.noresponse

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.policy.incompatible

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.policy.linkstatus

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.blocked

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.disconnected

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.fail.duplex

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.fail.speed

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.inactive

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.transition.down

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.migrate.bindtovmk

Invalid vmknic specified in the ESX configuration

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.migrate.unsupported.latency

High vMotion network latency detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.portset.port.full

Maximum number of ports has been reached. Cannot apply for any more free ports.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.portset.port.vlan.invalidid

Invalid VLANID. VLAN ID must be between 0 and 4095.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.proxyswitch.port.unavailable

Virtual NIC connection to switch failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.redundancy.degraded

Network redundancy degraded on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.redundancy.lost

Network redundancy lost on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.uplink.mtu.failed

Failed to set MTU on an uplink

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.instance.initialization.fail

VDL2 instance initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.instance.notexist

VDL2 overlay instance is not created on DVS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.mcastgroup.fail

VDL2 IP interface on vmknic failed to join multicast group

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.network.initialization.fail

VDL2 network initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.port.initialization.fail

VDL2 initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.vmknic.fail

VDL2 IP interface failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.vmknic.notexist

VDL2 IP interface does not exist

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmknic.ip.duplicate

A duplicate IP address was detected on a vmknic interface

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.linkstate.down

Link state down

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.linkstate.flapping

NIC link is unstable. Taking down.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.watchdog.reset

Nic Watchdog Reset

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.ntpd.clock.correction.error

NTP daemon stopped.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.platform.retire.request

Memory page retirement requested by platform firmware

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.host.exceeded

Number of host physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.kernel.exceeded

Number of kernel physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.userclient.exceeded

Number of physical memory pages belonging to (user) memroy client that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.userprivate.exceeded

Number of private user physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.usershared.exceeded

Number of shared user physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.vmmclient.exceeded

Number of physical memory pages belonging to (vmm) memroy client that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.apd.event.descriptor.alloc.failed

No memory to allocate APD (All Paths Down) event subsystem

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.close.failed

Failed to close the device properly

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.detach.failed

Exceeded the number of devices that can be detached, detach failed.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.filter.attach.failed

Failed to attach filters to device '%s' during registration. Plugin load failed or the filter rules are incorrect.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.bad.plugin.type

Bad plugin type for device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.inquiry.failed

Failed to get standard inquiry for device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.invalid.disk.qfull.value

QFullSampleSize should be bigger than QFullThreshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.latency.high

Device I/O latency increased

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.qerr.change.config

SCSI ChangeQErrSetting configuration value has been changed. This may cause unexpected behavior.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.qerr.changed

QErr configuration value has been changed. This may cause unexpected behavior.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.local.failed

Failed to verify if the device from plugin is a local - not shared - device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.pseudo.failed

Failed to verify if the device from plugin is a pseudo device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.ssd.failed

Failed to verify if the device from plugin is a Solid State Disk device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.limitreached

The maximum number of supported devices has been reached

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.off

Device has been turned off administratively

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss

Device has been removed or is permanently inaccessible

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.noopens

Permanently inaccessible device has no more opens

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.pluggedback

Device has been plugged back in after being marked permanently inaccessible

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.withreservationheld

Device has been removed or is permanently inaccessible, while holding a reservation.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.thinprov.atquota

Thin Provisioned Device Nearing Capacity

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.scsipath.limitreached

Maximum number of storage paths

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.unsupported.plugin.type

Scsi Device Allocation not supported for plugin type

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.apd.start

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.apd.timeout

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.devicepor

Frequent PowerOn Reset Unit Attention of storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.lost

Storage connectivity lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.pathpor

Frequent PowerOn Reset Unit Attention of Storage Path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.pathstatechanges

Frequent State Changes of Storage Path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.discovery.connect.error

iSCSI discovery failed. The iSCSI Initiator could not establish a network connection to the discovery address.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.discovery.login.error

iSCSI discovery failed. The Discovery target returned a login error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.connect.error

Login to iSCSI target failed. The iSCSI initiator could not establish a network connection to the target

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.login.error

Login to iSCSI target failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.permanently.lost

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.redundancy.degraded

Storage redundancy degraded

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.redundancy.lost

Storage redundancy lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.syslog.config

System logging is not configured on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.syslog.nonpersistent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vfat.filesystem.full.other

The VFAT filesystem is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vfat.filesystem.full.scratch

The host's scratch partition, which is the VFAT filesystem, is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.failure

An operation on the root filesystem has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.inodetable.full

The root filesystem's file table is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.ramdisk.full

The ramdisk is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.ramdisk.inodetable.full

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.fault.failure

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.forcefulPageRetire

The VM contains host physical page which was scheduled for immediate retirement

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.noSwapResponse

The VM did not respond to swap actions and is forcefully powered off to prevent system instability

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.vmtrack

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.ats.support.lost

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.error.volume.is.locked

Volume is locked

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.extent.offline

Attached device is offline

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.extent.online

Backing file system came online

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.recovered

Access to volume successfully restored

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.timedout

Volume connectivity lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.unrecoverable

Volume connectivity lost and subsequent recovery attempts have failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.journal.createfailed

No space for journal. Opening volume in read-only metadata mode with limited write support.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.lock.corruptondisk

Corrupt on-disk lock was detected on volume. Other regions of the volume might be damaged too.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.mount.connect.failed

Unable to connect to NFS server

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.mount.limit.exceeded

NFS has reached the maximum number of supported volumes

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.server.disconnect

NFS Server disconnected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.server.restored

NFS Server reconnected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.resource.corruptondisk

Corrupt resource metadata region was detected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.volume.locked

Volume locked

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.remote.failure

Hose has become unreachable

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.storage.failure

Logging to storage has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.storage.logdir.invalid

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.unexpected

Log daemon has failed for an unexpected reason

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vpxa.core.dumped

Application crashed and a core file might have been created.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.clustering.disabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.not.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.redundancy.lost

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.redundancy.reduced

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.no.network.connectivity

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.vmknic.not.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event ExitedStandbyModeEvent

This event records that the host is no longer in standby mode.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event ExitingStandbyModeEvent

This event records that a host has begun the process of exiting standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ExitMaintenanceModeEvent

This event records that the host is no longer in maintenance mode.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ExitStandbyModeFailedEvent

This event records that the host failed to exit standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event FailoverLevelRestored

This event records that the amount of cluster resources has increased and is now sufficient to satisfy the configured HA failover level.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralEvent

This is actually the base class for general events and should not be seen. The derived general events are the ones that will be generated. See VMware's documentation for the complete list of these events.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostErrorEvent

This event is the general error event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostInfoEvent

This event is the general information event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostWarningEvent

This event is the general warning event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralUserEvent

This event is the general user event type.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmErrorEvent

This event is the general error event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmInfoEvent

This event is the general information event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmWarningEvent

This event is the general warning event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GhostDvsProxySwitchDetectedEvent

This event records when vCenter server found DVS proxy switches on the host that don't match any DVS defined in vCenter.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event GhostDvsProxySwitchRemovedEvent

This event records when the ghost DVS proxy switches (a.k.a host proxy switches that don't match any DVS defined in vCenter) were removed on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event GlobalMessageChangedEvent

This event records a change to the global message.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.AppQuiescedDeltaCompletedEvent

Application consistent delta completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.ConnectionRestoredToHbrServerEvent

Connection to replication server restored for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaAbortedEvent

Delta aborted for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaCompletedEvent

Delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaStartedEvent

Delta for VM started

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FailedToStartDeltaEvent

Failed to start delta for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FailedToStartSyncEvent

Failed to start full sync for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FSQuiescedDeltaCompletedEvent

File system consistent delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.InvalidDiskReplicationConfigurationEvent

VM replication configuration is invalid

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.InvalidVmReplicationConfigurationEvent

VM replication configuration is invalid

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.NoConnectionToHbrServerEvent

No connection to replication server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.NoProgressWithHbrServerEvent

Replication server error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.QuiesceNotSupported

Quiescing is not supported for VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.SyncCompletedEvent

VM full sync completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.SyncStartedEvent

Full sync started for VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.UnquiescedDeltaCompletedEvent

Delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.VmReplicationConfigurationChangedEvent

VM replication configuration changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event HealthStatusChangedEvent

Event used to report change in health status of vCenter components.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostAddedEvent

This event records the addition of a host to vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostAddFailedEvent

This event records that adding a host failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostAdminDisableEvent

This event records that the permission on the host has been changed such that only the user account used for vCenter operation will have Administrator permission.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostAdminEnableEvent

This event records that the administrator permission has been restored.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostCnxFailedAccountFailedEvent

This event records a failure to connect to a host due to a failure to set up a management account.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedAlreadyManagedEvent

This event records a failure to connect to a host due to the host being managed by a different vCenter server.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadCcagentEvent

This event records a failure to connect to a host due to no response being received from the host agent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadUsernameEvent

This event records a failure to connect to a host due to an invalid user name and password combination.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadVersionEvent

This event records a failure to connect to a host due to an incompatible client version.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedCcagentUpgradeEvent

This event records a failure to connect to a host due to a conflict with an upgrade or installation of the host agent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedEvent

This event records a failure to connect to a host due to an unspecified condition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNetworkErrorEvent

This event records a failure to connect to a host due to a network error.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoAccessEvent

This event records a failure to connect to a host due to insufficient account privileges.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoConnectionEvent

This event records a failure to connect to a host due to a host not being present on the network.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoLicenseEvent

This event records a failure to connect to a host due to a licensing issue.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNotFoundEvent

This event records a failure to connect to a host due to a failure to resolve the host name.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedTimeoutEvent

This event records a failure to connect to a host due to a timeout on the connection attempt.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostComplianceCheckedEvent

This event records that a compliance check was triggered on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostCompliantEvent

This event records that host is in compliance.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostConfigAppliedEvent

This event records that a configuration was applied on a host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostConnectedEvent

This event records a successful host connection. After this event is generated, there will also be a VmConnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostConnectionLostEvent

This event records the (unexpected) loss of a host connection. This might occur if a ESX system was powered down, for example. After this event is generated, there will also be a VmDisconnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasDisabledEvent

This event records when HA has been disabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasDisablingEvent

This event records when HA is being disabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasEnabledEvent

This event records when HA has been enabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasEnablingEvent

This event records when HA has been enabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasErrorEvent

This event records when there is a HA error on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasOkEvent

This event records when HA on a host returns to normal after an error.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDisconnectedEvent

This event records the completion of a user requested disconnect of a host. Following this event, there will be a VmDisconnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDVPortEvent

dvPort connected to host changed status

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event HostEnableAdminFailedEvent

This event records the failure to restore some of the administrator's permissions.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostExtraNetworksEvent

This event records the fact that a host has extra networks not used by other hosts for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostGetShortNameFailedEvent

This event records that hostname -s failed or returned a name containing '.'.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostInAuditModeEvent

Host is running in audit mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event HostInventoryFullEvent

This event records if the inventory of hosts has reached the capacity of the current version of vCenter.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostInventoryUnreadableEvent

Event indicating that the virtual machine inventory file on the host is damaged or unreadable.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostIpChangedEvent

This event records a change in host IP address.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIpInconsistentEvent

This event records that the IP address resolution returned different addresses on the host. Please check your host's network configuration.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIpToShortNameFailedEvent

This event records that the host's IP address could not be resolved to a short name.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIsolationIpPingFailedEvent

This event records that the isolation address could not be pinged. The default isolation address is the service console's default gateway.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostLicenseExpiredEvent

This event records an expired host license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostLocalPortCreatedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event HostMissingNetworksEvent

This event records the fact that a host is missing networks that other hosts are using for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostMonitoringStateChangedEvent

This event records when host monitoring state has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoAvailableNetworksEvent

This event records the fact that a host does not have any available networks for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoHAEnabledPortGroupsEvent

This event records the fact that a host does not have any HA-enabled port groups.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNonCompliantEvent

This event records that host went out of compliance.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoRedundantManagementNetworkEvent

This event records the fact that a host does not have a redundant management network. It is recommended that host management networks be configured with redundancy.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostNotInClusterEvent

This event records that the host is not a cluster member.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostOvercommittedEvent

This event records when a host's capacity cannot satisfy resource configuration constraints.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostPrimaryAgentNotShortNameEvent

This event records that the primary agent specified is not a short name. The name of the primary agent is usually stored as a short name. You should not normally see this error. Please check the network configurations of your hosts.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostProfileAppliedEvent

This event records that a Profile application was done on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostReconnectionFailedEvent

This event records a failed attempt to re-establish a host connection.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostRemovedEvent

This event records the removal of a host from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostShortNameInconsistentEvent

This event records that host name resolution returned different names on the host. Please check your host's network configuration and your DNS configuration. There may be duplicate entries.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostShortNameToIpFailedEvent

This event records that host name resolution returned different names on the host. Please check your host's network configuration and your DNS configuration. There may be duplicate entries.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostShutdownEvent

This event records the shutdown of a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostStatusChangedEvent

This event records when a host's overall status changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostSyncFailedEvent

This event records a failure to sync up with the vCenter agent on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostUpgradeFailedEvent

This event records a failure to connect to a host due to an installation or upgrade issue.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostUserWorldSwapNotEnabledEvent

This event records that the userworld swap is not enabled on the host. HA needs userworld swap to be configured on embedded ESX hosts to function.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostVnicConnectedToCustomizedDVPortEvent

This event records when some host vnics were reconfigured to use DVPorts with port level configuration, which might be different from the DVportgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostWwnChangedEvent

This event records a change in a host's WWN (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostWwnConflictEvent

This event records a conflict of host WWNs (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event IncorrectHostInformationEvent

This event records if the host did not provide the information needed to acquire the correct set of licenses.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event InfoUpgradeEvent

This event is a general information event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event InsufficientFailoverResourcesEvent

This event records that the cluster resources are insufficient to satisfy the configured HA failover level.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event InvalidEditionEvent

This event records if the license edition is set to an invalid value.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event IScsiBootFailureEvent

Could not boot from iScsi

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event LicenseExpiredEvent

This event records the expiration of a license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LicenseNonComplianceEvent

This event records that the inventory is not license compliant.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event LicenseRestrictedEvent

This event records if the required licenses could not be reserved because of a restriction in the option file.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event LicenseServerAvailableEvent

This event is reported if the LicenseServer was previously unreachable and is now reachable.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LicenseServerUnavailableEvent

This event is reported if the LicenseServer becomes unreachable.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LocalDatastoreCreatedEvent

This event records when a local datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LocalTSMEnabledEvent

Local Tech Support Mode for the host has been enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event LockerMisconfiguredEvent

Locker has not been configured properly. This event is fired when the datastore configured to back the locker does not exist or when connectivity to the datastore is lost.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event LockerReconfiguredEvent

Locker has not been configured properly. This event is fired when the datastore configured to back the locker does not exist or when connectivity to the datastore is lost.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event MigrationErrorEvent

A migration error occurred.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationHostErrorEvent

This records a migration error that includes the destination host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationHostWarningEvent

This records a migration warning that includes the destination host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationResourceErrorEvent

This records a migration error that includes both the destination host and resource pool.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationResourceWarningEvent

This records a migration warning that includes both the destination host and resource pool.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationWarningEvent

This records a migration warning.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MtuMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event MtuMismatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event NASDatastoreCreatedEvent

This event records when a NAS datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NetworkRollbackEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event NoAccessUserEvent

This event records a failed user logon due to insufficient access permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NoDatastoresConfiguredEvent

No datastores have been configured on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event NoLicenseEvent

A NoLicenseEvent is reported if the required licenses could not be reserved. Each feature that is not fully licensed is reported.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NoMaintenanceModeDrsRecommendationForVM

This event records that DRS did not recommend a migration for a powered on virtual machine, even though its host is going into maintenance mode. DRS may not be able to recommend a migration for a virtual machine for reasons, include but not limited to:

· No other connected host is compatible with this virtual machine.
· None of the other compatible hosts have sufficient resources to satisfy the reservation requirements of this virtual machine.
· Moving to any other host would violate a DRS rule. For example, all other compatible hosts have some incompatible virtual machines running.
· DRS is disabled on this virtual machine.
· This virtual machine was still in the process of migrating into the host going into maintenance mode and was not considered by DRS.
· This virtual machine was in the process of migrating to another host when the host tried to enter maintenance mode.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NonVIWorkloadDetectedOnDatastoreEvent

This event records that non-VI workload is detected on the datastore

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event NotEnoughResourcesToStartVmEvent

This event records when the HA does not find sufficient resources to failover a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event OutOfSyncDvsHost

The list of hosts that have the DVS configuration on the host diverged from that of the vCenter Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event PermissionAddedEvent

This event records the creation of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event PermissionRemovedEvent

This event records the removal of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event PermissionUpdatedEvent

This event records the update of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ProfileAssociatedEvent

This event records that a Profile was associated with a managed entitiy.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileChangedEvent

This event records that the profile has beed edited.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileCreatedEvent

This event records that a Profile was created.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileDissociatedEvent

This event records that a Profile was dissassociated from a managed entity.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileEvent

This event records a Profile specific event.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileReferenceHostChangedEvent

This event records that the reference host associated with this profile has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileRemovedEvent

This event records that a Profile was removed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event RecoveryEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event RemoteTSMEnabledEvent

Remote Tech Support Mode for the host has been enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event ResourcePoolCreatedEvent

This event records when a new resource pool is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolDestroyedEvent

This event records when a resource pool is destroyed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolMovedEvent

This event records when a resource pool is moved.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolReconfiguredEvent

This event records when a resource pool configuration is changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourceViolatedEvent

This event records when a conflict with a resource pool's resource configuration is detected.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleAddedEvent

This event records the creation of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleRemovedEvent

This class records the removal of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleUpdatedEvent

This event records the creation of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RollbackEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ScheduledTaskCompletedEvent

This event records the completion of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskCreatedEvent

This event records the creation of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEmailCompletedEvent

This event records the sending of a notification via email for a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEmailFailedEvent

This event records the failure of an attempt to send a notification via email for a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEvent

This event records the completion of a scheduled task. The name of the task is indicated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskFailedEvent

This event records the failure of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskReconfiguredEvent

This event records the reconfiguration of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskRemovedEvent

This event records the removal of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskStartedEvent

This event records when a scheduled task started.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ServerLicenseExpiredEvent

This event records an expired vCenter server license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ServerStartedSessionEvent

This event records the starting of the vCenter server.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event SessionTerminatedEvent

This event records the termination of a session.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TaskEvent

This event records the completion of a manually triggered task. The name of the task is indicated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TaskTimeoutEvent

This event records when a task is cleaned up because of a timeout.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event TeamingMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event TeamingMisMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event TemplateBeingUpgradedEvent

This event records the start of a template upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TemplateUpgradedEvent

This event records that the template upgrade succeeded.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TemplateUpgradeFailedEvent

This event records that the template upgrade failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TimedOutHostOperationEvent

This event indicates that an operation performed on the host timed out. Typically, a previous event in the sequence of events contains more information about the cause of the operation timing out.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UnlicensedVirtualMachinesEvent

This event records that we have unlicensed virtual machines on the specified host. This can be both a Config issue and an entry in the event log.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UnlicensedVirtualMachinesFoundEvent

This event records that we discovered unlicensed virtual machines on the specified host. After this event is entered into the event log, we expect to see a corresponding UnlicensedVirtualMachinesEvent configIssue on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UpdatedAgentBeingRestartedEvent

This event records that the agent has been patched and will be restarted.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UpgradeEvent

This event records that the agent has been patched and will be restarted.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UplinkPortMtuNotSupportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortMtuSupportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortVlanTrunkedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortVlanUntrunkedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UserAssignedToGroup

This event records that a user account membership was added to a group.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserLoginSessionEvent

This event records a user logon. Because these are so prolific, they are ignored (by default) by the Veeam VMware Collector.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserLogoutSessionEvent

This event records a user logout. Because these are so numerous, they are ignored (by default) by the Veeam VMware Collector.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserPasswordChanged

This event records that a user password changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserUnassignedFromGroup

This event records that a user account membership was removed from a group.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserUpgradeEvent

This event is a general user event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VcAgentUninstalledEvent

This event records when the vCenter agent on a host is uninstalled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VcAgentUninstallFailedEvent

This event records when the vCenter agent on a host failed to uninstall.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VcAgentUpgradedEvent

This event records when the vCenter agent on a host upgraded.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VcAgentUpgradeFailedEvent

This event records when the vCenter agent on a host failed to upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event vim.event.LicenseDowngradedEvent

License downgrade

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VimAccountPasswordChangedEvent

Password for the Vim account user on the host has been changed. This is an account created by vCenter and used to manage the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmAcquiredMksTicketEvent

This event records a user successfully acquiring an MKS ticket (i.e., a mouse-keyboard-screen connection ticket).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmAcquiredTicketEvent

This event records a user successfully acquiring a ticket

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmAutoRenameEvent

This event records that a virtual machine was automatically renamed because of a name conflict.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingClonedEvent

This event records a virtual machine being cloned.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingClonedNoFolderEvent

This event records a virtual machine being cloned

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmBeingCreatedEvent

This event records a virtual machine being created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingDeployedEvent

This event records a virtual machine being deployed from a template.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingHotMigratedEvent

This event records that a virtual machine is being hot-migrated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingMigratedEvent

This event records that a virtual machine is being migrated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingRelocatedEvent

This event records that a virtual machine is being relocated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmClonedEvent

This event records the completion of a virtual machine cloning operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmCloneFailedEvent

This event records a failure to clone a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmConfigMissingEvent

This event records if the configuration file can not be found.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmConnectedEvent

This event is generated by the VC for each VM on a host whenever the host is reconnected to the VC. One event per VM will be generated, regardless of the power state of the VM.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmCreatedEvent

This event records that a virtual machine was successfully created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDasBeingResetEvent

This event records when a virtual machine is reset by HA VM Health Monitoring on hosts that do not support the create screenshot api or if the createscreenshot api fails.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasBeingResetWithScreenshotEvent

This event records when a virtual machine is reset by HA VM Health Monitoring on hosts that support the create screenshot api.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasResetFailedEvent

This event records when HA VM Health Monitoring fails to reset a virtual machine after failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasUpdateErrorEvent

The event records that an error occured when updating the HA agents with the current state of the virtual machine. If this occurs during a powerOn operation, the virtual machine will not be failed over in the event of a host failure. If it occurs during a powerOff, the virtual machine will be automatically powered on if the host it was last running on crashes.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDasUpdateOkEvent

This event records that HA agents have been updated with the current state of the virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDateRolledBackEvent

This event records when the vCenter server date rolled back.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDeployedEvent

This event records the completion of a virtual machine deployment operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDeployFailedEvent

This event records a failure to deploy from a template.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDisconnectedEvent

This event is generated by the VC for each VM on a host whenever the host becomes disconnected from the VC. One event per VM will be generated, regardless of the power state of the VM.

"Disconnection" of the host includes both planned disconnections (indicated by HostDisconnectedEvent) and unplanned disconnections (indicated by HostConnectionLostEvent).

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDiscoveredEvent

This event records a virtual machine discovery.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDiskFailedEvent

This event records a failure to create a virtual disk in a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDVPortEvent

dvPort connected to VM changed status

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmEmigratingEvent

This event records a virtual machine migration.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmEndRecordingEvent

This event indicates the end of a recording session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmEndReplayingEvent

This event indicates the end of a replay session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmEvent

This is a catch-all event for various VM events (the type of event is listed in the event). See VMware's documentation for the list of possible events.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedMigrateEvent

This event records a failure to migrate a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedRelayoutEvent

This event records a specific failure to re-layout a virtual machine, such as a failure to access the disk. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedRelayoutOnVmfs2DatastoreEvent

This event records a failure to re-layout a virtual machine when the virtual machine still has disks on a VMFS2 volume. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedStartingSecondaryEvent

This event records vmotion failure when starting a secondary VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFailedToPowerOffEvent

This event records a failure to power off a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToPowerOnEvent

This event records a failure to power on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToRebootGuestEvent

This event records a failure to reboot the guest on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToResetEvent

This event records a failure to reset a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToShutdownGuestEvent

This event records a failure to shut down the guest on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToStandbyGuestEvent

This event records a failure to set the guest on a virtual machine toa standby state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToSuspendEvent

This event records a failure to suspend a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedUpdatingSecondaryConfig

This event records after a failover the new new primary failed to update the config of the secondary vm.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFailoverFailed

This event records when a virtual machine failover was unsuccessful.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceStateChangedEvent

This event records a fault tolerance state change. A default alarm will be triggered upon this event, which would change the vm state: the vm state is red if the newState is needSecondary; the vm state is yellow if the newState is disabled; the vm state is green if the newState is notConfigured, starting, enabled or running.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceTurnedOffEvent

This event records that all secondary virtual machines have been removed and fault tolerance protection turned off for this virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceVmTerminatedEvent

This event records a secondary or primary VM is terminated. The reason could be : divergence, lost connection to secondary, partial hardware failure of secondary, or by user.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreCreatedEvent

This event records when a VMFS datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreExpandedEvent

This event records when a datastore is expanded.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreExtendedEvent

This event records when a datastore is extended.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmGuestRebootEvent

This is a virtual machine guest reboot request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmGuestShutdownEvent

This is a virtual machine guest shutdown request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmGuestStandbyEvent

This is a virtual machine guest standby request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmHealthMonitoringStateChangedEvent

This event records when host monitoring state has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidAssignedEvent

This event records the assignment of a new instance UUID to a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidChangedEvent

This event records a change in a virtual machine's instance UUID.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidConflictEvent

This event records a conflict of virtual machine instance UUIDs.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMacAssignedEvent

This event records the assignment of a new MAC address to a virtual network adapter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMacChangedEvent

This event records a change in a virtual machine's MAC address.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMacConflictEvent

This event records a MAC address conflict for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMaxFTRestartCountReached

This event is fired when FT VM reached the max restart count.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMaxRestartCountReached

This event is fired when the VM reached the max restart count.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMessageErrorEvent

This event records when an error message (consisting of a collection of "observations") is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMessageEvent

This event records when a message is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMessageWarningEvent

This event records when a warning message (consisting of a collection of "observations") is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMigratedEvent

This event records a virtual machine migration.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmNoCompatibleHostForSecondaryEvent

This event records that no compatible host was found to place a secondary VM. A default alarm will be triggered upon this event, which by default would trigger a SNMP trap.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmNoNetworkAccessEvent

This event records a migration failure when the destination host is not on the same network as the source host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmOrphanedEvent

This event records a virtual machine for which no host is responsible.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VMotionLicenseExpiredEvent

This event records an expired VMotion license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweredOffEvent

This event records when a virtual machine finished powering off.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweredOnEvent

This event records when a virtual machine finished powering on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweringOnWithCustomizedDVPortEvent

This event records when a virtual machine was powering on using DVPorts with port level configuration, which might be different from the DVportgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmPowerOffOnIsolationEvent

This event records when a virtual machine has been powered off on an isolated host in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPrimaryFailoverEvent

This event records an fault tolerance failover. The reason could be : lost connection to primary, partial hardware failure of primary or by user.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmReconfiguredEvent

This event records a reconfiguration of the virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRegisteredEvent

This event records that a virtual machine was successfully registered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelayoutSuccessfulEvent

This event records that a virtual machine was successfully converted to the new virtual machine format on a VMFS3 volume.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelayoutUpToDateEvent

This event records that a virtual machine is already in the correct format. No re-layout is necessary. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmReloadFromPathEvent

This event records that a virtual machine was successfully reloaded from a new configuration path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmReloadFromPathFailedEvent

This event records that a virtual machine reload from a new configuration path failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmRelocatedEvent

This event records the completion of a virtual machine relocation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelocateFailedEvent

This event records a failure to relocate a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRemoteConsoleConnectedEvent

This event records that a remote console was connected to the VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmRemoteConsoleDisconnectedEvent

This event records that a remote console was disconnected from the VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmRemovedEvent

This event records a virtual machine removed from vCenter management.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRenamedEvent

This event records the renaming of a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRequirementsExceedCurrentEVCModeEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event VmResettingEvent

This event records a virtual machine resetting.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResourcePoolMovedEvent

This event records when a virtual machine is moved from one resource pool to another.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResourceReallocatedEvent

This event records a change in resource allocation of a virtual machine.

The name of the virtual machine is in the event. This event is generated typically in DRS configurations when VC detects that the available resources (such as CPU) are changing.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRestartedOnAlternateHostEvent

This event records that the virtual machine was restarted on a host, since its original host had failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResumingEvent

This event records a virtual machine resuming.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryAddedEvent

This event records a secondary VM is added.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryDisabledBySystemEvent

This event records that a fault tolerance secondary VM has been disabled by vCenter because the VM could not be powered on.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryDisabledEvent

This event records a secondary VM is disabled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryEnabledEvent

This event records a secondary VM is enabled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryStartedEvent

This event records a secondary VM is started successfully.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmShutdownOnIsolationEvent

This event records when a virtual machine has been shut down on an isolated host in a HA cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartingEvent

This event records a virtual machine powering on. It typically will be followed by a VmPoweredOnEvent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmStartingSecondaryEvent

This event records a vmotion to start a secondary VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartRecordingEvent

This event indicates the start of a recording session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartReplayingEvent

This event indicates the start of a replay session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStaticMacConflictEvent

This event records a static MAC address conflict for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmStoppingEvent

This event records a virtual machine stopping.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSuspendedEvent

This event records when a virtual machine finished suspending.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSuspendingEvent

This event records a virtual machine suspending.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmTimedoutStartingSecondaryEvent

This event records timeout when starting a secondary VM. A default alarm will be triggered upon this event, which by default would trigger a SNMP trap.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmUnsupportedStartingEvent

This event records when an unsupported guest is powering on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradeCompleteEvent

This event records the successful completion of an upgrade operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradeFailedEvent

This event records a failure to upgrade virtual hardware.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradingEvent

This event records the process of upgrading the virtual hardware on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidAssignedEvent

This event records the assignment of a new BIOS UUID to a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidChangedEvent

This event records a change in a virtual machine's BIOS UUID. Veeam has observed that during migrations this event may be generated even though the UUID is not changing.

A sample event is included below (note that on this version of ESX the name of the VM is missing after the word "for", and the UUID is actually not changing).

Changed BIOS UUID from 500e3054-23fd-6ff6-58a7-037500940891 to 500e3054-23fd-6ff6-58a7-037500940891 for on esx04.seattle.veeam.local in SEATTLE VmUuidChangedEvent

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidConflictEvent

This event records a conflict of virtual machine BIOS UUIDs. That is, a virtual machine has been detected with a duplicate UUID (Universally Unique Identifier).

When a VM is cloned, its UUID is also clone and will remain with the same UUID until 2 VMs with the same UUID are powered on. Only when the VM is running is the uniqueness of UUIDs assured. When the hypervisor detects a VM powering up has a duplicate UUID it will change it and issue this event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmVnicPoolReservationViolationClearEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event VmVnicPoolReservationViolationRaiseEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event VmWwnAssignedEvent

This event records the assignment of a new WWN (World Wide Name) to a virtual machine.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmWwnChangedEvent

This event records a change in a virtual machine's WWN (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmWwnConflictEvent

This event records a conflict of virtual machine WWNs (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event vprob.net.connectivity.lost

Lost Network Connectivity

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.e1000.tso6.notsupported

No IPv6 TSO support

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.migrate.bindtovmk

Invalid vmknic specified in /Migrate/Vmknic

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.proxyswitch.port.unavailable

VNic connect to switch failed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.redundancy.degraded

Network Redundancy Degraded

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.redundancy.lost

Lost Network Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.scsi.device.thinprov.atquota

Space utilization on thin-provisioned device exceeded configured threshold

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event vprob.storage.connectivity.lost

Lost Storage Connectivity

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.storage.redundancy.degraded

Degraded Storage Path Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.storage.redundancy.lost

Lost Storage Path Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.error.volume.is.locked

Volume is locked

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.extent.offline

Device is offline

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.extent.online

Device is online

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.recovered

VMFS Volume Connectivity Restored

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.timedout

VMFS Volume Connectivity Degraded

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.unrecoverable

VMFS Volume Connectivity Lost

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.journal.createfailed

No Space To Create VMFS Journal

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.lock.corruptondisk

VMFS Lock Corruption Detected

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.nfs.server.disconnect

Lost connection to NFS server

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.nfs.server.restored

Restored connection to NFS server

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.resource.corruptondisk

VMFS Resource Corruption Detected

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.volume.locked

VMFS Locked By Remote Host

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event WarningUpgradeEvent

This event is a general warning event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference